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Startup and Shutdown

This set of topics includes options for customizing the startup and shutdown.

Starting MATLAB (p. 1-2)

Quitting MATLAB (p. 1-16)

General information about starting
a MATLAB® session.

End a MATLAB session. Instruct
MATLAB to perform specified
operations upon shutdown.
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Instructions for starting MATLAB depend on your platform. For a list of
supported platforms, see the system requirements in the Products section of
the MathWorks Web site, http://www.mathworks.com. Topics related to
starting MATLAB are

o “Starting MATLAB on Windows Platforms” on page 1-2
o “Starting MATLAB on UNIX Platforms” on page 1-5

e “Startup Directory for MATLAB” on page 1-6

e “Startup Options” on page 1-7

e “Startup and Calling Java from MATLAB” on page 1-11
® “Toolbox Path Caching in MATLAB” on page 1-11

Starting MATLAB on Windows Platforms

To start MATLAB on a Microsoft Windows platform, select the

Start > Programs > MATLAB > R2006b > MATLAB R2006b, or
double-click the MATLAB R2006b shortcut icon @ on your Windows desktop.
The shortcut was automatically created when you installed MATLAB. If
you have trouble starting MATLAB, see troubleshooting information in the
Installation Guide for Windows.

To start MATLAB from a DOS window, cd to the directory in which
matlab.exe is installed and type matlab at the DOS prompt.

After starting MATLAB, the desktop opens. All of the desktop components
that were open when you last shut down MATLAB will be opened on startup.
For more information, see Chapter 2, “Desktop”.

You can also start MATLAB on Windows platforms by double-clicking a
MATLARB file, such as .mat, .md1, and .fig files, in Windows Explorer. Be
sure to open any subsequent MATLAB files from within MATLAB so as not to
start a new instance. (Each time you double-click a MATLAB file in Windows
Explorer, it starts a new instance of MATLAB.)

Double-clicking an M-file (.m), by default, starts the MATLAB stand-alone
Editor instead of MATLAB — for more information, see “Opening the Editor


http://www.mathworks.com

Starting MATLAB

Without Starting MATLAB” on page 6-11. You can start MATLAB by
double-clicking an M-file or any other file type by changing the file association
for the file type, either when you install MATLAB or as described in “Starting
MATLAB from an M-File or Other File Type in Windows” on page 1-3.

Error Log Reporter

Upon startup, if MATLAB detects an error log generated by a serious problem
encountered during the previous session, an Error Log Reporter prompts

you to e-mail the log to The MathWorks for analysis. Click Send Report to
e-mail the log, or click Help for more information. After sending the log, a
confirmation message appears in the Command Window.

Starting MATLAB from an M-File or Other File Type in Windows

When you installed MATLAB for Windows, you specified the file types to
associate with MATLAB. For example, if you accepted the default option,
double-clicking a MAT-file, FIG-file, P-file, or MDL-file from Windows
Explorer starts MATLAB. Note that each time you double-click a file
associated with MATLAB in Windows Explorer, it opens a new instance

of MATLAB. It does not open the file you double-clicked in the MATLAB
instance already open. To open an M-file in the existing instance of MATLAB,
drag the M-file from Windows Explorer to the MATLAB Editor/Debugger.

By default, double-clicking an M-file opens the MATLAB stand-alone Editor.
If the MATLAB stand-alone Editor is already open when you double-click
an M-file in Windows Explorer, the M-file opens in the existing instance of
the stand-alone Editor.

Other applications you use can change these file associations. For
example, Microsoft Access might associate files having a .mat extension
so double-clicking a MAT-file would open Access rather than MATLAB.
If MATLAB file types are not associated with MATLAB, follow these
instructions to associate them with MATLAB.

If you are viewing this topic in the MATLAB Help browser, you can run
one of the utilities provided here to add Windows associations for common
MATLARB file types. This requires you to have permission to write to the
HKEY_CLASSES ROOT registry key, which typically requires power user or
administrator privileges.

1-3
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® Run utility to associate MATLAB with M-files (double-clicking an M-file
opens the MATLAB stand-alone Editor)

¢ Run utility to associate MATLAB with MAT-files
¢ Run utility to associate MATLAB with FIG-files
® Run utility to associate MATLAB with P-files

® Run utility to associate MATLAB with MDL-files

® Run utility to associate MATLAB with all of these file types (M, MAT, FIG,
P, MDL)

The file type icon in Windows Explorer might not reflect the change
immediately.

File associations for Windows Explorer do not affect what happens when you
open a MATLAB file type from within MATLAB. MATLAB acts on the file
using the MATLAB tool associated with that file type. For example, even if
you associate .mat files with Microsoft Access, when you open a MAT-file from
within MATLAB, it loads the data into the MATLAB workspace. Opening

an M-file from within MATLAB opens the file in the Editor/Debugger, not
the MATLAB stand-alone Editor. For more information, see “Opening and
Running Files” on page 5-43, and .

Changing File Associations for MATLAB from Windows. Another way
to change MATLAB file associations for Windows is from Windows Explorer.
This is useful if you want to change file associations for file types other than
those offered by the utilities, change the M-file association to open MATLAB
rather than the MATLAB stand-alone Editor, or perform specific actions in
MATLAB when the file opens.

This example illustrates how to change associations so that when you
double-click an M-file in Windows Explorer, it opens MATLAB. Note that
these instructions might not exactly apply to your version of Windows. If you
encounter differences or problems, try to delete the association before using
these instructions, or see your Windows documentation.

1 In Windows Explorer, select Tools > Folder Options.
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2 In the resulting Folder Options dialog box, select the File Types tab. From
the Registered file types list, select the M extension. Under Details
for M extension, click Change.

3 In the resulting Open With dialog box, click Browse. Then look for and
select the MATLAB executable, matlab.exe, and click Open. The file is
located in the directory in which you installed MATLAB. A typical location
is D:\Applications\MATLAB\R2006b\matlab\bin\win32\matlab.exe.

4 In the Open With dialog box, click OK. In the Folder Options dialog box,
click Close.

Starting MATLAB on UNIX Platforms

To start MATLAB on a UNIX platform, type MATLAB at the operating system
prompt.

If you did not set up symbolic links in the installation procedure, you must
enter the full pathname to start MATLAB, matlabroot/bin/matlab, where
matlabroot is the name of your MATLAB installation directory. If you have
trouble starting MATLAB, see troubleshooting information in the Installation
Guide for UNIX.

After starting MATLAB, the desktop opens. All of the desktop components
that were open when you last shut down MATLAB will be opened on startup.
If the DISPLAY environment variable is not set or is invalid, the desktop will
not display. For more information, see Chapter 2, “Desktop”.

Note On Macintosh systems, you cannot perform a remote login, that is, you
cannot run MATLAB remotely. For example, you cannot rlogin.

Error Log Reporter

Upon startup, if MATLAB detects an error log generated by a serious problem
encountered during the previous session, an Error Log Reporter prompts

you to e-mail the log to The MathWorks for analysis. Click Send Report to
e-mail the log, or click Help for more information. After sending the log, a
confirmation message appears in the Command Window.

1-5
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Startup Directory for MATLAB

The current directory in MATLAB when it starts is called the startup
directory. The default startup directory depends on your platform and
installation. You can specify a different startup directory.

Startup Directory on Windows Platforms

On Windows platforms, when you installed MATLAB, the default startup
directory was set to matlabroot/work, where matlabroot is the directory in
which MATLAB files are installed.

Startup Directory on UNIX Platforms

On UNIX platforms, the default startup directory is the directory you are in
on your UNIX file system when you start MATLAB.

Changing the Startup Directory
You can start MATLAB in a directory other than the default.

For Windows Platforms Only. To change the startup directory on
Windows platforms,

1 Right-click the MATLAB shortcut icon and select Properties from the
context menu.

The Properties dialog box for matlab.exe opens to the Shortcut page.

2 Enter the new startup directory in the Start in field and click OK.

The next time you start MATLAB using that shortcut icon, the current
directory will be the one you specified in step 2.

You can make multiple shortcuts to start MATLAB, each with its own startup
directory, and with each startup directory having different startup options.

For All Platforms. To change the startup directory,

1 Create a startup.m file — see “Using the Startup File for MATLAB,
startup.m” on page 1-7.
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2 Inthe startup.mfile, include the cd function to change to the new directory.

3 Put the startup.m file in the current startup directory.

Startup Options
You can define startup options for MATLAB that instruct MATLAB to perform

certain operations when you start it. There are two ways to specify startup
options for MATLAB:

® “Using the Startup File for MATLAB, startup.m” on page 1-7
® “Adding Startup Options for Windows Platforms” on page 1-8
® “Adding Startup Options for UNIX Platforms” on page 1-10

Using the Startup File for MATLAB, startup.m

At startup, MATLAB automatically executes the master M-file matlabrc.m
and, if it exists, startup.m. The file matlabrc.m, which is in the local
directory, is reserved for use by The MathWorks, and by the system manager
on multiuser systems.

The file startup.m is for you to specify startup options. For example, you can
modify the default search path, predefine variables in your workspace, or
define Handle Graphics® defaults. Creating a startup.m file with the lines

addpath /home/me/mytools
cd /home/me/mytools

adds /home/me/mytools to your default search path and makes mytools
the current directory upon startup.

Location of startup.m. Place the startup.m file in the current startup
directory, which is where MATLAB first looks for it. For more information,
see “Startup Directory for MATLAB” on page 1-6. You can instead place it

in matlabroot/toolbox/local, which is the next place MATLAB looks for
startup.m, where matlabroot is the directory in which MATLAB is installed.



1 Startup and Shutdown

1-8

Adding Startup Options for Windows Platforms
You can add selected startup options (also called command flags or command

line switches) to the target path for your Windows shortcut for MATLAB. Or
you can add them to the matlab function when you start MATLAB in a DOS
window. The process is described in the following topics:

e “Startup Options in Windows Shortcut” on page 1-8

e “Startup Options in DOS Window” on page 1-8

e “List of Startup Options for Windows Platforms” on page 1-9

Startup Options in Windows Shortcut. To use startup options in the
Windows shortcut for MATLAB, follow these steps:

1 Right-click the MATLAB shortcut icon #\ and select Properties from the
context menu. The Properties dialog box for matlab.exe opens to the
Shortcut pane.

2 In the Target field, after the target path for matlab.exe, add the startup
option. For example, adding /r filename runs the M-file filename after
startup.

3 Click OK.

This example adds /r results to the end of the file path, which instructs
MATLAB to automatically run the file results after startup. The statement
in the Target field might appear as

H:\Programs\matlab.exe /r results

Use only the filename, not the file extension or pathname. For example,
MATLAB produces an error when you run

. matlab /r C:\results.m

Startup Options in DOS Window. When you start MATLAB in a DOS
window, include startup options after the matlab function.
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This example adds the/r startup option to change the current directory to
F:\myfiles and run the mylabdata function located in that directory after
starting MATLAB in a DOS window:

matlab /r "cd('F:\myfiles'), mylabdata"

Alternatively, separate the commands using semicolons:

matlab /r cd('F:\myfiles');mylabdata

List of Startup Options for Windows Platforms. Use these options in
the target path of the Windows shortcut for MATLAB, or with the matlab
function in a DOS window. The following table lists some commonly used
startup options You can use a hyphen (-) instead of a slash (/), for example,
-nosplash. For a complete list of the startup options for Windows platforms,
see the reference page for the matlab (Windows) function.

Option Description

/c licensefile Set LM_LICENSE_FILE to licensefile. It can have
the form port@host.

/logfile Automatically write output from MATLAB to the

logfilename specified log file.

/minimize Start MATLAB with the desktop minimized. Any

desktop tools or documents that were undocked
when MATLAB was last closed will not be
minimized upon startup.

/nosplash Start MATLAB without displaying the MATLAB
splash screen.
/r MATLAB file Automatically run the specified MATLAB M-file,

either commands supplied with MATLAB or your
own M-files, immediately after MATLAB starts.
This is also referred to as calling MATLAB in batch
mode. Separate multiple commands with commas
or semicolons (;). M-files must be on the MATLAB
path or in the MATLAB startup directory. Do not
include the pathname or a file extension.
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Adding Startup Options for UNIX Platforms

Include startup options (also called command flags or command line switches)
after the matlab startup command.

For example, to start MATLAB without the splash screen, type

matlab -nosplash

List of Startup Options for UNIX Platforms. The following tables list
some commonly used startup options.

For a complete list, see the matlab (UNIX) reference page.

Option Description

-h or -help Display startup options (without starting
MATLAB).

-logfile log Automatically write output from MATLAB to the
specified log file.

-nodesktop Start MATLAB without bringing up the MATLAB

desktop. Use this option to run without an
X-window, for example, in VI'100 mode, or in batch
processing mode. Note that if you pipe to MATLAB
using the > constructor, the nodesktop option is
used automatically.

With nodesktop, you can still use most
development environment tools by starting them
via a function. For example, use preferences to
open the Preferences dialog box and helpbrowser
to open the Help browser.

Do not use nodesktop to provide a command line
interface. If you prefer a command line interface,
select Desktop > Desktop Layout > Command
Window > Only.
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Option

Description

-nojvm

Start MATLAB without loading the Java VM. This
minimizes memory usage and improves initial
startup speed, but restricts functionality. With
nojvm, you cannot use the desktop, or any tools
that require Java.

For example, you cannot set preferences if you
start MATLAB with the -nojvm option. However,
you can start MATLAB once without the -nojvm
option, set the preference, and quit MATLAB.
MATLAB will remember that preference when you
start it again, even if you use the -nojvm option.

-nosplash

Start MATLAB without displaying the splash
screen during startup.

-r MATLAB_command

Automatically run the specified MATLAB M-file,
either commands supplied with MATLAB or your
own M-files, immediately after MATLAB starts.
This is also referred to as calling MATLAB in batch
mode. Separate multiple commands with commas
or semicolons (;). M-files must be on the MATLAB
path or in the MATLAB startup directory. Do not
include the pathname or a file extension.

Startup and Calling Java from MATLAB

When MATLAB starts, it constructs the Java class path using
librarypath.txt as well as classpath.txt. If you call Java from MATLAB,
see more about this in “The Java Class Path” and “Locating Native Method
Libraries” in the MATLAB External Interfaces documentation.

Toolbox Path Caching in MATLAB

For performance reasons, MATLAB caches toolbox directory information
across sessions. The caching features are mostly transparent to you. However,
if MATLAB does not see the latest versions of your M-files or if you receive
warnings about the toolbox path cache, you might need to update the cache.
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Using the Cache File Upon Startup

Upon startup, MATLAB gets information from a cache file to build the toolbox
directory cache. Because of the cache file, startup is faster, especially if you
run MATLAB from a network server or if you have many toolbox directories.
When you end a session, MATLAB updates the cache file.

MATLAB does not use the cache file at startup if you clear the Enable
toolbox path cache check box in File > Preferences > General. Instead,
it creates the cache by reading from the operating system directories, which
is slower than using the cache file.

Updating the Cache and Cache File

How the Toolbox Path Cache Works. MATLAB caches (essentially, stores
in a known files list) the names and locations of files in matlabroot/toolbox
directories. These directories are for MathWorks supplied files that should
not change except for product installations and updates. Caching those
directories provides better performance during a session because MATLAB
does not actively monitor those directories.

We strongly recommend that you save any M-files you create and any
MathWorks supplied M-files that you edit in a directory that is not

in the matlabroot/toolbox directory tree. If you keep your files in
matlabroot/toolbox directories, they may be overwritten when you install
a new version of MATLAB.

When to Update the Cache. When you add files to matlabroot/toolbox
directories, the cache and the cache file need to be updated. MATLAB updates
the cache and cache file automatically when you install toolboxes or toolbox
updates using the MATLAB installer. MATLAB also updates the cache and
cache file automatically when you use MATLAB tools, such as when you save
files from the MATLAB Editor/Debugger to matlabroot/toolbox directories.

When you add or remove files in matlabroot/toolbox directories by some
other means, MATLAB might not recognize those changes. For example,

when you

¢ Save new files in matlabroot/toolbox directories using an external editor
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® Use operating system features and commands to add or remove files in
matlabroot/toolbox directories

MATLAB displays this message:
Undefined function or variable

You need to update the cache so MATLAB will recognize the changes you
made in matlabroot/toolbox directories.

Steps to Update the Cache. To update the cache and the cache file,

1 Select File > Preferences > General.

The General Preferences pane is displayed.

2 Click Update Toolbox Path Cache and click OK.
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Additional Diagnostics with Toolbox Path Caching

To display information about startup time when you start MATLAB, select
the Enable toolbox path cache diagnostics check box in General
Preferences.
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Quitting MATLAB

To quit MATLAB at any time, do one of the following:

¢ Click the Close box *lin the MATLAB desktop.
o Select Exit MATLAB from the desktop File menu.
® Type quit at the Command Window prompt.

MATLAB closes after

® Prompting you to confirm quitting, if that preference is specified (see
“Confirm Quitting MATLAB” on page 1-16)

* Prompting you to save any unsaved files

¢ Running the finish.m script, if it exists in the current directory or on the
MATLAB path (see “Running a Script When Quitting MATLAB” on page
1-17)

Confirm Quitting MATLAB

To set a preference that displays a confirmation dialog box when you quit
MATLAB, select File > Preferences > General > Confirmation Dialogs,
select the Confirm before quitting check box, and click OK. MATLAB then
displays the following dialog box when you quit.

& Are ol sure you wart to exit MATLAB?Y

[ Do nat show this prompt agaEin.

Zancel |

For more information, see “Confirmation Dialogs” on page 2-60.

You can also display your own quitting confirmation dialog box using a
finish.m script, as described in the following section.
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Running a Script When Quitting MATLAB

When MATLAB quits, it runs the script finish.m, if finish.m exists in the
current directory or anywhere on the MATLAB search path. You create the
file finish.m. It contains statements to run when MATLAB terminates, such
as saving the workspace or displaying a confirmation dialog box. There are
two sample files in matlabroot/toolbox/local that you can use as the basis
for your own finish.m file:

e finishsav.m — Includes a save function so the workspace is saved to
a MAT-file when MATLAB quits.

e finishdlg.m — Displays a confirmation dialog box that allows you to
cancel quitting.

For more information, see the finish reference page.

Abnormal Termination

In the event MATLAB experiences a segmentation violation or other serious
problem, save your files and workspace if possible, exit MATLAB, and restart.

Upon startup, if MATLAB detects an error log generated by a serious problem
during the previous session, an Error Log Reporter prompts you to e-mail
the log to The MathWorks for analysis. If the problem occurs repeatedly,
make note of what seems to cause it and look for information about it in the
MathWorks Bug Reports database.

There are some situations where the Error Log Reporter will not open,

for example when you start MATLAB with a -r option or run in deployed
mode. If you experience segmentation violations but do not see the Error
Log Reporter on subsequent startups, you can instead e-mail the reports by
following the instructions at the end of the segmentation violation message in
the Command Window.
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Desktop

If you are viewing this document in the Help browser, you can watch the
Desktop and Command Window video demo for an overview of the major
functionality. The easiest way to learn to use the desktop is just by working
with it. If you have problems or questions, refer to the following sections.

Overview of the Desktop (p. 2-2)

Arranging the Desktop — Overview
(p. 2-5)

Common Desktop Features (p. 2-21)

Fonts, Colors, and Other Preferences

(p. 2-46)
Accessibility (p. 2-66)

Basic summary of the desktop and
its tools.

Open and arrange desktop tools
and documents to suit your needs.
Scan the examples and follow the
instructions to arrange your desktop.

Use the Start button, MATLAB
shortcuts, toolbars, menus and
context menus, status bar, and
keyboard shortcuts. Select multiple
items, cut, copy, and paste, use page
setup for printing, and access the
MathWorks Web site from MATLAB.

Specify options for desktop tools,
including fonts and colors.

Use assistive technologies and
accessibility features when working
with MathWorks software.
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Overview of the Desktop

When you start MATLAB, it displays the MATLAB desktop, a set of tools
(graphical user interfaces or GUIs) for managing files, variables, and
applications associated with MATLAB.

The first time you start MATLAB, the desktop appears with the default
layout, as shown in the following illustration. You can change the desktop
arrangement to meet your needs, including resizing, moving, and closing tools.
For details, see “Arranging the Desktop — Overview” on page 2-5.

The Editor/Debugger and Array Editor support multiple document windows
within them. Similarly, you can group multiple figure windows together. For
information about working with documents in the desktop, see “Opening and
Arranging Documents” on page 2-7.
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Summary of Desktop Tools

The following tools are managed by the MATLAB desktop, although not all of
them appear by default when you first start. If you prefer a command-line
interface, you can often use equivalent functions to accomplish the same
result. To perform the equivalent of the GUI tasks in M-files, you must

use the equivalent function. Instructions for using equivalent functions to
perform the task are provided with the documentation for each tool and are
typically labeled as Function Alternatives.

Desktop Tool

Description

Array Editor

View array contents in a table format and edit the values.

Command History

View a log of the functions you entered in the Command
Window, copy them, execute them, and more.

Command Window

Run MATLAB statements.

Current Directory Browser

View files, perform file operations such as open, find files
and file content, and manage and tune your files.

Editor/Debugger Create, edit, debug, and analyze M-files (files containing
MATLAB statements).
Figures Create, modify, view, and print MATLAB figures.

File Comparisons

View line-by-line differences between two files.

Help Browser

View and search the documentation for all your
MathWorks products.

Profiler

Improve the performance of your M-files.

Start Button

Run tools and access documentation for all your
MathWorks products, and create and use MATLAB
shortcuts.

Web Browser

View HTML and related files produced by MATLAB.

Workspace Browser

View and make changes to the contents of the workspace.

24



Arranging the Desktop — Overview

Arranging the Desktop — Overview

You can modify the desktop configuration to best meet your needs. Because
the desktop uses many standard graphical user interface (GUI) conventions,
it is easy to learn about arranging the desktop just by using it.

The desktop manages tools and documents differently. The Command History
and Editor/Debugger are examples of tools, and an M-file is an example of a
document, which appears in the Editor/Debugger tool.

These are the main actions you perform in arranging your desktop tools and
documents:

® “Opening and Arranging Tools” on page 2-5

® “Opening and Arranging Documents” on page 2-7

e “Examples of Desktop Arrangements” on page 2-12

¢ “Saving Desktop Layouts” on page 2-20

See also “Examples of Desktop Arrangements” on page 2-12.

Opening and Arranging Tools

This table summarizes actions for arranging desktop tools. For further
information, click the “see more details online” links—you must be using this
document in the Help browser to access these details.

Tool Action

Steps to Perform

Opening desktop tools To maximize your work area, keep open only those tools you

use. To open a tool, select the tool name from the Desktop
menu. Opened tools have a check mark before them in

the menu. The tool appears in the location it occupied the
last time it was open. The sizes of other tools adjust to
accommodate the newly opened tool. See more details online.
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Tool Action

Steps to Perform

Navigating among desktop tools

The Window menu displays all open desktop tools and
documents, as well as opened tools for other MathWorks
products. Select an entry in the Window menu to go directly
to that tool or document. Another way to access an undocked
desktop tool is by selecting its entry in the Windows task
bar, or the equivalent for your platform. See also “Keyboard
Shortcuts (Accelerators) and Mnemonics” on page 2-36 and,
more details online.

Closing desktop tools

To close a desktop tool, select the item in the Desktop menu,
which clears the check mark in the menu and closes the tool.
Or click the Close box (X) in the title bar for the tool, or select
File > Close for the tool. See more details online.

Resizing tools

To resize tools in the MATLAB desktop, drag the separator
bar, which is the bar between tools. You can hide the title
bars for tools in the desktop so the tools use less space —
select Desktop > Titles. See more details online.

Moving tools within the desktop

To move a tool in the MATLAB desktop, drag the title bar
of the tool toward where you want the tool to be located.

As you drag the tool, an outline of it appears. When the
outline nears a position where you can keep it, the outline
snaps to that location. Release the mouse button. The tool
stays at the new location. Other tools in the desktop resize
to accommodate the new configuration. The inside edges of
the desktop container and tools all act as if they are “sticky,”
S0 you can position a tool along any inside edge. See more
details online.

Moving tools out of the desktop
(undocking)

Move a tool out of the desktop to make it larger or easier

to work with. To move a tool outside the MATLAB desktop
(called undocking), select the tool to make it active, and then
selectDesktop > Undock > Toolname. The tool appears
outside the MATLAB desktop and an entry for it appears in
the Windows task bar or the equivalent for your platform.
Tools within the desktop resize accordingly. Another way to
undock is by using the Undock button 2l in the tool’s title
bar. See more details online.
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Tool Action Steps to Perform
Moving tools into the desktop To move a tool that is outside the MATLAB desktop into the
(docking) desktop, click the Dock button =l in the tool’s menu bar, or

select Desktop > Dock Toolname. See more details online.

Grouping (tabbing) tools together | You can group tools so that they overlay each other in the
MATLAB desktop, and then access each tool via its tab. To
group tools together, drag the title bar of one tool in the
desktop on top of the title bar of another tool in the desktop.
To make a tool active, click its tab. See more details online.

Opening and Arranging Documents

Open a document, such as an M-file or a variable, and it opens in its tool,
for example, the Editor/Debugger or Array Editor. The following example
illustration shows a desktop arrangement that includes Editor/Debugger

and Array Editor documents. See instructions in “Summary of Actions for
Arranging Documents” on page 2-9.

Example of Documents in the Desktop
Some common actions for working with documents in the desktop are

Use tabs to go to open tools. Use the document bar to go to open documents.

Use the Window menu or equivalent toolbar buttons to position documents.

¢ (Close or undock a tool, including all documents in the tool.

Undock a document from its tool. Use the document Close box with the
Ctrl key to close the document without saving it or displaying the unsaved
document dialog box.

See also “Examples of Desktop Arrangements” on page 2-12.



2 Desktop

Close or undock active tool, including all open documents in the tool

Position documents with these buttons. Undock document from tool.

File Edit Text Cell Tools Dehug Deskiog ‘Wihdow Help

D] B o o 8| 2| e = &
@ Editor - D:Amymfiles\povertystais.m  ? Workspace W
D@ Wil o *Orx ||[PES RS - 1
1 - load povertydats - Mame - I Walus |CIaSS
2 - £ = figure: H 1 doukle
3 - plot(year,families,'k','LineWic FHfamilies  <d3x1d.. double
4 - hold on Ffernale  <43x1 d... double
5 - plot(year,female,'k', ' Linelidck HH recfam <43x1 d... double
6 — ploti(year,recfam,'r',' Linelidck EHreﬂEm <43x1 d... double
7 - ploti(year,recfem, 'r', ' Linelidtk™ <43x1 d... doubl
Document 4 | _,|—| [ year X pubie
bar 7‘} collatz m ><||pcnver‘tys*tats.m ><| |
Tabs —Eultor | Array Editor | 4] | r

Command Window ?

X

F» edit collatz

> povertystats

r» edit povertystats
F

4 start | script ln 6 0ol 8 [OvR ,

2-8



Arranging the Desktop — Overview

Summary of Actions for Arranging Documents

This table summarizes actions for arranging documents in their tool. For
further information, click the click the “see more details online” links—you
must be using this document in the Help browser to access these details.

Document Action Overview

Opening documents When you open a MATLAB document, it opens in the associated
tool. If the tool is not already open, it opens when you open the
document and appears in the position it occupied when last used.
Figures open undocked, regardless of the last position occupied.

How to open a document depends on the document type:
e M-file: Select File > Open and select the M-file. It opens in the
Editor/Debugger.

¢ Workspace variable: In the Workspace browser, double-click the
variable. It opens in the Array Editor.

e HTML file: In the Current Directory browser, double-click the
file. It opens in the MATLAB Web Browser.

¢ Figure: Type plot or use another graphics function. The plot
appears in a figure window.

There are many additional ways to open documents. See more
details online.
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Document Action

Overview

Navigating among
documents — the
document bar

When more than one document is open within a tool, each document
is either maximized (the default), or arranged so that multiple
documents are visible at once. Click a document that is in view

to make it the active document. See also “Keyboard Shortcuts
(Accelerators) and Mnemonics” on page 2-36.

Use the document bar to go to a document that is open but not in
view. The names of all open documents appear in the document
bar. Select a document name in the document bar to make that
document active. To show the document bar if it is not open, select
Desktop > Document Bar > Bar Position and select the position
for it, for example, Right. See more details online.

Entries for undocked documents appear in the Windows task bar,
or the equivalent for your platform. Click the task bar entry for a
document to make that document active.

Positioning, moving, and
resizing documents

To position open documents within their tool, select an arrangement
from the Window menu when the tool is active, or by using the
equivalent toolbar button for Maximize, Float, Left/Right Tile,
Top/Bottom Tile, and Tile. On the Macintosh platform, the tile
option might not be available in the Window menu so use the Tile
button H instead.

With the tile arrangements, you refine the document position by
moving the pointer over the handle (a) on the separator bar. A Close
box then appears. When you click the Close box between two open
documents, both documents stay open, but one moves on top of the
other. When you click the Close box between a document and an
empty tile, the empty tile closes.

To move a document in a tiled arrangement, drag the title

bar of a document to another tile. To resize tiled documents,

drag the separator bar between the documents. See also the
Editor/Debugger’s “Split Screen Display” on page 6-39, which allows
you to view two different parts of the same file simultaneously.

To move or resize maximized documents, you move or resize their
tool.

See more details online.
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Document Action

Overview

Closing documents

To close a document, click the Close box in the document’s title bar.
After closing all the documents in a tool, the tool remains open
with no documents in it. If you select the Close box for the tool,
all documents in that tool close.

In the Editor/Debugger, when you close a file that has unsaved
changes, a prompt appears asking if you want to save the document.
To close a file without saving changes and without seeing the
prompt, use Ctrl when you click the document’s Close box. See
more details online.

Moving documents and
tools out of the desktop
(undocking)

To undock all documents in a tool from the desktop, click the
Undock button 2l in the tool’s title bar. The tool and its documents
move outside of the desktop. See more details online.

To undock a document from its tool, click the Undock button 2
for the document. The Undock button is either in the document’s
title bar, menu bar, or toolbar, depending on the document type
and whether or not the document is within the desktop or is in its
tool outside of the desktop.

Undocked tools and documents have entries in the Windows task
bar (or the equivalent for your platform).

Docking documents and
tools

When you dock a document that is not in the desktop, it moves to
the position in the tool that it occupied before you undocked he
document. To dock a document, click the Dock button 2l in the
document’s menu bar. See more details online.

Grouping documents in a
tool outside the desktop

To group all of the documents for a tool together outside of the
desktop, undock the tool from the desktop, not just the documents.

If you have already undocked all of the documents and closed the
empty tool that had contained them, select Desktop > Dock All in
Editor, for example. This moves all the documents into the tool in
the desktop. Then undock the tool.
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Examples of Desktop Arrangements

Scan the illustrations in the following examples for a desktop arrangement
similar to what you want, and then follow the brief instructions to achieve the
arrangement. There are many different ways to accomplish the result; these
instructions present just one way. The instructions might not apply exactly,
depending on how your desktop looks before you start.

e “Tool Outside of Desktop and Other Tools Tabbed Inside Desktop Example”
on page 2-13

e “Tiled Documents in Desktop Example” on page 2-14

¢ “No Empty Document Tiles Example” on page 2-16

¢ “Maximized Documents Outside of the Desktop Example” on page 2-17

¢ “Floating (Cascaded) Figures in Desktop Example” on page 2-18

¢ “Undocked Tools and Documents Example” on page 2-19
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Tiled Documents in Desktop Example

When you open a document (for example, an M-file), it also opens the tool (for
example, the Editor/Debugger). If tools or documents are outside the desktop,
you can move them inside by clicking the Dock button =i in the tool’s title bar
and in any separate document menu bars, or by using the Desktop > Dock
menu items.

Select Window > Left/Right Tile or use the [I] toolbar button to show two
M-files in side-by-side tiles.

When tools and documents are docked, you might want to save space by
hiding toolbars and document bars. Here, the shortcuts toolbar is hidden.
Select Desktop > Toolbar name to hide (or show) a toolbar. To see or move
the document bar, select Desktop > Document Bar > Bar Position, and
choose its location, for example, Top.



Arranging the Desktop — Overview

The shortcuts toolbar is hidden. The document bar is at

Use buttons to arrange

the top of the Editor/Debugger. documents.
-k MATLAB | || =]
File Edit Text Cell Tools Debug Desktop Window Help

0w & B oo o | 8 5| 7 | [cwmnrerotiesichusem 7] L

| »

N E|t2Ro oS #r|RRB[E 2D
Jpwer‘tystats.m ><|| collatzall.m ><|

A= load povertydata - 1 function collatzall (n) -

&= f = figure; Z % Compute and plot lengt

3 - plot (year, families, 'E', 'L 3 % Prepare ficure

b= hold on = clf

&= plot (year, female, 'b' [ 'Lin 5= set{gof, 'DoubleButffer’ [ 'o

B - plot(year , recfam, 'vr', 'Linw B — set (goa, 'Hicale', 'linear' =

1| I » <| | »

Command Window A X
e
c4!~§«tart| collatzal Ln 1 Col 1 [ovR 4
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Close empty tile using handle on separator bar.

]

Before

Tile more

No Empty Document Tiles Example

To hide a document under another, drag a document’s title bar on top

of another document. The document on top fully covers the document
underneath. This gives more space to the active document. To see hidden
documents, use the Window menu or document bar.

To show two documents at once, use a tile arrangement. To see more than
two documents at once, select the Tile button and move the pointer across the
grid menu item on the toolbar to select the number of tiles you want. The
grid in the following “before” illustration has four tiles, but there are only
three documents open. (The empty tile is gray in the menu.) You can move a
document to any empty tile by dragging its title bar to the new location. To
close an empty tile, position the pointer over the handle . on the separator bar.
It becomes a Close box, as shown here, which you click to close the empty
tile. After clicking the Close box, the empty tile closes and the neighboring
document expands as shown in the following “after” illustration. Similarly,
click the Close box between two tiles containing documents, and one becomes
hidden.

After

than two documeants with the grid icon.

& Editor M [=]E3
File Edit Texi Cell Tools Debut Deskto Wihdow Helg | | File Edit Text Cell Tool: Debut Deskin Window Help « |
B : T | - »
DB 2@ o|&F @ D E|t R «|&[ -] 7/Ez
J povertystate.m ><| collatzallm = || collatz m -l | J povertystatsm  ® || collstzall.m ><| collatz.m ><| |
A x A x LA DAmymfilesicoll .. a2 x
1 — load povertydat & 1 functfion collatﬂ 1 - load povert.\j'dat.ﬂ 1 function collat &
g - f = figure; z % Compute and E Z = £ = figqure; Z ¥ Compute and p
3 - pletiyear,famil 3 % Prepare figu:r 3 = plotiyear, fanil 3 % Prepare figqur
4 - hold on hd 4 - clf hd 4 - hold on & 4 — clf
4 3 4! 3 1 * E - setigcf, 'Double
_ XI A 5 — set {gca, 'HEcale
Dymymfilesicoll . a x —[§ | - 5
1 function sequer & 1 function sequerﬂA g8 % Determine anc
z % Collatz prob z % Collats prob 9
bl % For any posit 3 % For.ar.ry posit 10 - seq_length=zerc
4 k3 Diwvide 1n by™ 4 # Divide n by Ty, _ for m o= 1-n hat
4 3 4 L3 (I I 3
| collstz Ln 1 o 1 ||ovR |y | collatzal Ln 1 col 1 |ouR |
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Document bar
on laft.

Maximized Documents Outside of the Desktop Example
Some common actions for working with documents outside of the desktop are

¢ Group all Editor/Debugger documents together — select Desktop > Dock
All in Editor from any Editor/Debugger document.

® Move all Editor/Debugger documents outside of the desktop — select
Desktop > Undock Editor when the Editor/Debugger is the active
window.

e Make a document occupy the full area in the Editor/Debugger —
click the Maximize button in the Editor/Debugger toolbar, or select
Window > Maximize.

¢ Display the cell toolbar — select Desktop > Cell Toolbar. This menu item
is available only when the current document is an M-file.

e Access any document in the Editor/Debugger using the document bar.
To show the document bar on the left side of the Editor/Debugger,
select Desktop > Bar Position > Document Bar > Left from the
Editor/Debugger.

Celltoolbar for rapid cods Maximize Document button.

iteration and publishing.

I*- Editor - d:\mymfiles\collatz.m !
File Edit Text Cell Tools Debug Deskiop ‘Window Help 3 la x
e E| 2R «&G|#f | 888 B 0O
7 | B8 B - fln +!] £ 1 x| o o
e P 1 function sequence=collatzin) . -
m 2 % Collatz problem. Generate a secquence of integers |
MESEE TS = | 3 % For any positive integer, n:
4 % Divide n by 2 1if n is even
5 % Maltiply nn by 3 and add 1 if n is odd
& % Fepeat for the result
7 % Continue until the result iz 1%
&
9 SEQUENCE = I}
10 next_wvalue = n; -
Rl | 5
| collatz [tn 1 col 1 |owR 4
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Floating (Cascaded) Figures in Desktop Example

You can show multiple figures at once in the desktop. By default, figures
open outside the desktop. Click the Dock button in each figure’s menu bar to
move the figures into the desktop.

You can float (also called cascade) the figures by selecting Window > Float, or
clicking the Float button 5. To get even more screen area for the figures, hide
the document bar as shown in this example — select Desktop > Document
Bar > Bar Position > Hide.

Dock figures in tha desktop. Document bar is hidden.
) MATLAB
File Edit %iew Insert Tools| Debug Desktop ‘Window Help
D@|%En“|ﬁﬁf|@|ld:meﬁles ﬂJ

e S EE
- DeEa s RO || 2[5

N e
libd ans HToaster

o : EFiguez 2 _ 0 x
10000
A families  <43x1 do

a0c

M fernale =43x1 do
A recfam <43x1 do
M recfern =43x1 do
M vear <43%1 do

P ks

0
1840

1860 1920 2000 2020

Command Window A X
»> figure; plot (families, 'Displavlame', 'families'): figt;l
figure; plot (families, 'Displavlame', 'families'); figure |
> povertystats

e -

B | :
A start| 4
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Undocked Tools and Documents Example

You can use tools and documents outside of the desktop. One way to
achieve this is to first undock the tool from the desktop by selecting
Desktop > Undock Toolname. Then undock documents from the undocked
tool by selecting Desktop > Undock Documentname from the tool. If you
undock all documents from a tool, an “empty” tool window remains.

In this example, one of the Editor/Debugger documents, povertystats.m,
includes the name of the tool with it and the other Editor/Debugger document,
collatz.m, does not. Contrast this with the Array Editor documents, where
neither document window includes the name of the tool. This is because when
documents are undocked from both the desktop and their tool, you can close
the tool but the tool’s undocked documents remain open. If you closed the
Editor/Debugger, the collatz.m document would remain open. To close all
undocked documents and their tools at once, select Window > Close All
Documents from an undocked document window.
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Saving Desktop Layouts

When you end a session, MATLAB saves the desktop layout. The next time
you start MATLAB, the desktop is restored the way you last had it.

To use a predefined layout, select Desktop > Desktop Layout, and choose a
configuration. See more details in the online documentation.

To save your own layouts for later reuse, select Desktop > Save Layout and
provide a name. To ruse the layout, select the name from Desktop > Desktop
Layout. See more details in the online documentation.
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Common Desktop Features
This section presents useful details about common features of desktop tools:

e “Start Button for Accessing Tools” on page 2-21

e “Shortcuts for MATLAB — Easily Run a Group of Statements” on page 2-23
¢ “Web Browser” on page 2-30

¢ “Menus and Context Menus” on page 2-32

e “Macintosh Differences” on page 2-33

e “Toolbars” on page 2-33

e “Status Bar” on page 2-35

® “Sizing, Arranging, and Sorting Columns in Tools” on page 2-35

¢ “Keyboard Shortcuts (Accelerators) and Mnemonics” on page 2-36
e “Selecting Multiple Items” on page 2-39

e “Cut, Copy, Paste, and Move” on page 2-39

¢ “Printing and Page Setup Options for Desktop Tools” on page 2-41
® “Accessing The MathWorks on the Web” on page 2-44

Start Button for Accessing Tools

The MATLAB Start button provides easy access to tools, demos, and
documentation for all your MathWorks products. From it, you can also create
and run MATLAB shortcuts, which are groups of MATLAB statements.

Using the Start Button

1 Click the Start button to view a menu of product categories and desktop
tools installed on your system. As an alternative, press Alt+S to view the
Start button contents (except on Macintosh platforms). In the following
illustration, MATLAB is selected.
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2 From the menu and submenu items, select an item to open it. Use the icons
to quickly locate a type of product or tool — see the following description

of icons.

For example, select Start > MATLAB > GUIDE (GUI Builder) to open

that tool.

Icons in the Start Button. Icons help you quickly locate a particular type of
product or tool. This table describes the action performed when you select an
entry with one of these icons in the Start button.

Icon Description of Action When Opened

e Documentation for that product opens in the Help browser.

i Demos for the product are listed in the Help browser
Demos pane.

Selected tool opens.

[ Block library opens.

a3 Document opens in your system Web browser.
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Customizing the Start Button

You can add your own toolboxes to the Start button. Select Start > Desktop
Tools > View Source Files to open the Start Button Configuration Files
dialog box. For more information, click the Help button in the dialog box.

Shortcuts for MATLAB — Easily Run a Group of
Statements

A MATLAB shortcut is an easy way to run a group of MATLAB functions that
you use regularly. These topics provide details:

® “What Is a Shortcut?” on page 2-23

o “Examples of Useful Shortcuts” on page 2-24

e “Creating Shortcuts” on page 2-24

® “Running Shortcuts” on page 2-26

e “Shortcuts Toolbar” on page 2-27

® “Organizing and Editing Shortcuts” on page 2-29

What Is a Shortcut?

A MATLAB shortcut is an easy way to run a group of MATLAB statements.
First you create a shortcut that contains all the statements. Then you select
and run the shortcut to execute all the statements it contains. Create, run,
and organize shortcuts from the Start > Shortcuts menu or the desktop
Shortcuts toolbar.

Differences Between Shortcuts and M-Files. A shortcut is like an M-file
script, but unlike an M-file, a shortcut does not have to be on the MATLAB
search path or in the current directory when you run it. In addition, you can
run the shortcut by selecting it from the Start button or desktop Shortcuts
toolbar, which are readily accessible.

Although shortcuts run MATLAB statements, they are not M-files and are
not stored as M-files.
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Examples of Useful Shortcuts
These are some examples of useful types of shortcuts:

If you frequently run the same group of functions, consider creating a
shortcut for them. An example of this is setting up your environment
when you start working if you do not use a startup file, or if there are
statements you do not want to include in the startup file. Some users
create a shortcut for even a single function they use frequently, such as
clc to clear the Command Window.

Create a shortcut to set the same properties for figures you create, such as
adding a legend and setting the background color.

Create a shortcut for a long statement, such as changing the current
directory (cd) when the pathnames are long.

Create a shortcut for a statement you do not easily remember but need to
use.

Creating Shortcuts

This is an example of a shortcut you might create for a project you work on,
the Sea Temperature project. When you work on that project, you might want
to set up your environment in a certain way by running a series of statements.
You create a shortcut called sea_temp_env, which contains the statements.
Then when you work on the project, you run the shortcut to execute all of the
statements with a single click. The statements are

more on

format long e

cd d:/mymfiles/sea_temp_project
clear

workspace

filebrowser

clc

To create a shortcut, perform the following steps:

From the Start button, select Shortcuts > New Shortcut.

The Shortcut Editor dialog box appears.
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2 Create the shortcut by completing the dialog box.

a Provide a shortcut name in the Label field, for example,
sea_temp_environment.

b Put the MATLAB statements in the Callback field as shown in the
following illustration. Either type them in, or copy and paste or drag
them from a desktop tool. Edit the statements as needed. The field uses
the Editor/Debugger preferences for key bindings, colors, and fonts.
Note that if you copy the statements from the Command Window, the
prompt appears in the shortcut, but MATLAB removes the prompt when
you save the shortcut.

¢ Assign a category, which is like a directory for organizing shortcuts.
Specify sea_temp_project. To add the shortcut to the shortcuts toolbar,
select the Toolbar Shortcuts category.

d Use the default shortcuts icon [, or select your own.

e Click Save. MATLAB automatically removes any Command Window
prompts (>>) in the Callback field upon saving the shortcuts.

<} Shortcut Editor =] E3

Lakel: Isea_temp_environmer‘rt

calback: lyore on

format long e

cd di/mymfiles/sea temp project
clear

workspace;: Lfilebrowser

cle

Category: I =ea_temp_project LI

lcor: I [#] Standard icon LI J

Saves shortout to Start button, Selecting "Toolbar Shorcuts"
category also saves to Shorcuts toolbar.

Save Cancel | Help |

3 MATLAB adds the shortcut to the Shortcuts entry in the Start button,
and to the Shortcuts toolbar, if you selected that Category.
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After creating a shortcut, run it by selecting it from its category in the
Start button. You can also run it from the Shortcuts toolbar if you selected
the Toolbar Shortcuts category.

MATLAB maintains shortcut information in the file shortcuts.xml. Type
prefdir, and MATLAB displays the location of the file. Most likely, you
will not need to access this file, as MATLAB updates the file automatically.

For more information on the options in the Shortcut Editor dialog box, click
the Help button.

Additional Ways to Create Shortcuts. You can also use these methods to
create shortcuts:

® Add shortcuts to and run them from the desktop Shortcuts toolbar. See
“Shortcuts Toolbar” on page 2-27.

®* From the Command History window, create a shortcut by selecting
statements, right-clicking, and selecting Create Shortcut from the context
menu. By default, shortcuts created from the Command History window
are assigned to the Toolbar Shortcuts category, meaning they will appear
on the Shortcuts toolbar.

® From the Help browser, select Favorites > Add to Favorites, complete
the Favorites Editor dialog box, and the shortcut appears in the shortcuts
Help Browser Favorites category. You can also access Help Browser
Favorites shortcuts from the Help browser Favorites menu.

* Drag statements from a desktop tool, such as the Command History, onto
the Start button.

Running Shortcuts

To run a shortcut, select the shortcut name, for example,
sea_temp_environment, from the Start > Shortcuts menu or from one of
its category submenus. All of the statements in the shortcut Callback field
execute. It is as if you ran those statements from the Command Window,
although they are not reflected in the Command History window.

If you added a shortcut to the Shortcuts toolbar, you can run it by clicking its
icon on the shortcuts toolbar.
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Shortcuts Toolbar

The Shortcuts toolbar is an alternative to creating and running

shortcuts via the Start button. To show or hide the shortcuts toolbar, use
Desktop > Shortcuts Toolbar. To create and run shortcuts via the desktop
Shortcuts toolbar, perform these steps:

1 Select statements from the Command History window, the Command
Window, or an M-file.

2 Drag the selection to the desktop Shortcuts toolbar. The following
illustration shows two statements being dragged from the Command
Window.

Shortcuts toolbar—Drag statements to it to create a shortcut,

File Edit Debug Desktop ‘Window Help
D@|$Eﬂ“‘ﬁﬂ9|@“&w?mfiles LI

Shortcuts [#] How to &dd  [#] Whist's Nesa

i

-> format long e

> more on

e

4 start i

3 The Shortcut Editor dialog box appears. The Callback field contains the
selected statements, which you can edit as needed. If prompts (>>) from the
Command Window appear, note that MATLAB automatically removes them
when you save the shortcut. The Category field is Toolbar Shortcuts,
which you must retain in order for the shortcut to appear on the toolbar.

Provide the Label, select an Icon, and click Save.
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Click an
item to run
that
shortcut.
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The shortcut icon and label appear on the toolbar. If you have more
shortcuts on the toolbar than can be displayed at once, use the drop-down
list to access all of them. For more information, click the Help button in
the Shortcut Editor dialog box.

4 (Click the icon on the Shortcuts toolbar to run the shortcut. You can also
run the shortcut from the Start button by selecting it in the Toolbar
Shortcuts category.

Rightclick a shortcutand  Right-click in the Shortcuts toolbar and thenuse  Drag selacted statements to the

then dalate ar edit it. tha Show Labels item to hide shortcut labels Shortcuts toolbar to create a new
and show only the icans. shortcut on the toolbar.
<) MATLAE _[Ofix]

File Edit Debug Desktop ‘Window Help
| Ij:| & B B < “‘ﬁﬁ@‘@”&w?mﬁles 3 J £

Shortcuts [A] Howe to Add [#] What's Mewe  [#] sea_temp_environmert

You can also add a shortcut to the desktop Shortcuts toolbar by right-clicking
the toolbar and selecting New Shortcut. Complete the resulting Shortcut
Editor dialog box. Assuming you maintain the Toolbar Shortcuts category,
the shortcut appears on the toolbar. To change the order of the shortcuts on
the toolbar, select Start > Shortcuts > Organize Shortcuts and move the
shortcuts within the Toolbar Shortcuts category.

How to Add and What’s New Shortcuts. The Shortcuts toolbar includes
two shortcuts provided with MATLAB. The How to Add shortcut provides
help about shortcuts and adding them to the Shortcuts toolbar. What’s New
displays the Release Notes documentation.

To remove the How to Add or What’s New shortcut from the Shortcuts
toolbar, choose a different category. For instructions, see “Organizing and
Editing Shortcuts” on page 2-29.

If you do not want to keep these shortcuts, remove each one by right-clicking
its toolbar shortcut button and selecting Delete from the context menu. Click
OK in the confirmation dialog box to remove the shortcut.
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Shortcut Labels on Toolbar. You can hide the shortcut labels on the
toolbar. Right-click in the Shortcuts toolbar. From the context menu, select
Show Labels, which clears the check mark next to the item. The shortcut
icons appear on the toolbar without labels. When you move the mouse over
a shortcut icon, its label appears as a tooltip. To make labels display in the
toolbar, right-click the toolbar and select Show Labels, which adds a check
mark next to the item and displays the labels.

Organizing and Editing Shortcuts

To create categories for shortcuts, and to move, edit, and delete shortcuts,
perform these steps:

1 Select Shortcuts > Organize Shortcuts from the Start button.
Alternatively, access it via the shortcuts toolbar context menu.

The Shortcuts Organizer dialog box appears. When a shortcut category is
selected in the dialog box, the Edit Shortcut button is replaced by the
Rename Category button.

Move shortcuts and more. For example, drag a shortcut to

anothar categaory.
<} Shortcuts Organizer - |O] x|
Plesn Categary... | =1 Shortcuts
New Shorteut.. | = Help Browser Favarites
| 2 Toalbar Shortcuts

Eclit Sharteut...

ks =7 What are Shortcuts?
Mave to Category... | = sea_temp_project

Delete Shortout

-

':El sea_temp_finish |

Cloze | Help |
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2 Use the buttons in the dialog box to edit and organize shortcuts and
categories. You can also right-click an item and select an action from the
context menu.

Changes take effect immediately.

3 Click Close.

For more information about using the Shortcuts Organizer dialog box, click
the Help button.

Web Browser

Some tools in MATLAB and related products display HTML documents in
the MATLAB Web Browser. For example, after using the Editor/Debugger’s
cell features to publish an M-file to HTML, you view the HTML file in the
MATLAB Web Browser. Because the MATLAB Web Browser is a desktop tool,
you can dock it and perform other desktop operations on it.

Example of Web browser displaying results of M-file
published to HTML format.

%*Web Browser - Calculate Sine Wave =]
File Edit %iew Go Debug Deskiop “Window Help A x

- = | % ‘ % | Ltlcatil:lr'liID:nnymfilesnﬂmlisine_wavel.r'rlml j HOAHX IE

-

Calculate Sine Wave
Calculate and plot a sine wave.
Contents

+ Calculate and Plot Sine Wave
« Modify Plot Properties

Calculate and Plot Sine Wave
Define the range for x.
0<xr<bw

R | :
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To display an HTML document in the Web Browser, double-click the document
name in the Current Directory browser or use the web function. The web
function supports arguments that display documents in your system browser,
for example, Netscape, or in the Help browser.

The toolbar buttons and menu items in the Web Browser are similar to those
found in the Help browser display pane. For more information, see “Viewing
Documentation in the Help Browser” on page 4-25.

One feature of the Web Browser not found in the Help browser is the Location
field. In the Web Browser, type a URL in the field to display that Web page.

Like any Web browser, the MATLAB Web Browser might not support all of
the HTML or related features used in a particular Web site or HTML page.
For example, the MATLAB Web Browser does not support the display of
.bmp (bitmap) image files. Instead use .gif or .jpeg formats for image files
in HTML pages. As another example, it does not support HTML pages you
generate directly from Microsoft Word and PowerPoint.

Internet Connection and Fonts for Web Browser — Web
Preferences

To specify a proxy server to connect from the MATLAB Web Browser to the
Internet, use Web preferences. You might need to specify this preference if
you have a firewall, for example. If you have a firewall and do not specify the
proxy settings, links from the Web Browser to URLs will not work.

Select File > Preferences > Web. By default, the check box Use a proxy
server to connect to the Internet is not selected. This is for when you have
a direct connection to the Internet.

To specify a proxy server, select the check box and specify the Proxy host and
Proxy port. See your system administrator for the information you need to
specify the proxy settings. As an example, 172.16.10.8 illustrates the format
for host, and 3128 is the type of value you enter for port.

Fonts for Web Browser. To modify the font used in the Web Browser, select
File > Preferences > Fonts. The Web Browser uses the font settings you
specify for HTML Proportional Text tool. For more information about setting
fonts, click the Help button in the preference pane for Fonts.
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Menus and Context Menus

Merged Menus

When you use a tool in the desktop, its menu appears at the top of the
desktop. When you work in a different tool in the desktop, you still use the
menu at the top of the desktop, but the menu content changes to support that
tool. When you undock a tool from the desktop, access its menu at the top

of the undocked tool.

Context Menus

Many of the features in MATLAB desktop tools are available from context
menus, also known as pop-up or right-click menus. To access a context menu,
right-click a selection or an area, or press Ctrl+Shift+F10. The context menu
for the selection or tool appears, presenting the available actions. For example,
following is the context menu for a selection in the Command History window.

If a context menu does not appear, try right-clicking in a different part of
the tool. When a context menu item is gray, the item does not apply to the
current selection or area.

Access contaxt (pop-up) menus by rightclicking a
selaction or any area in a toal.

<} Command History I [=] k3

File Edit Debut Deskio Windoy Help ~
figure: ;I

hold on

Cut Crl+
Copy Cirl+C

14— T+ d4 .
‘| | Ewvaluate Selection

[len,dim] =le;

Create M-File k
Create Shortcut

Frofile Code
Delete Selection
Delete to Selaction
Clear Entire History
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Macintosh Differences

MATLAB on the Macintosh platform sometimes uses Macintosh GUI
conventions, which might be different from what is stated in the MATLAB
documentation, but the intended action should be clear. For example, if
you select File > Save on the Macintosh, the Save dialog box that appears
presents the options Don’t Save and Save. On Windows and UNIX
platforms, the Save dialog box presents the options Yes, No, and Cancel.

The standard Macintosh mouse is a single-button device. Other platforms
use a mouse with more than one button. MATLAB takes advantage of
these buttons. The documentation does not usually present the equivalent
Macintosh instruction. When the documentation instruction is right-click,
use Ctrl+click on the Macintosh. When the documentation instruction is
middle-click, use Command-+click on the Macintosh.

Toolbars

The toolbar in the desktop provides easy access to frequently used operations.
Position the pointer over a button for a second or two and a tooltip appears
that describes the item.

Undo last Open Simulink _
adit. library browsar. View or
Open  Copy. Rado change Browse to
fila. lagt Opan o Help g_“"ﬂg changs
Cut. | Paste. | undo. Profiler. Ireciory. currant
| | | b‘rowse r ‘ dire ctr ry.
|T_h| = | & @ v cu | ﬂ@ | ? | ID:'lmymfiIes l 1ﬂ J
‘ Mov'e up
Create new fils in Tooltip describes Select previously used one
Editar/Debugger. buttan. current diractary. directary.

Some tools also have their own toolbars, which are located within the tool’s
own window. For example, the Current Directory browser has its own toolbar.
When you undock one of these tools, the undocked tool includes the toolbar.
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To hide a toolbar, or to show it again after hiding it, use the appropriate
toolbar item in the Desktop menu. As an alternative, right-click a toolbar or
menu bar and select a toolbar from the context menu to hide or show it.

For figure windows, use the toolbar item in its View menu.

Current Directory Field

The current directory field in the desktop toolbar shows the MATLAB current
working directory. You can change the current directory using this field and
any of these methods:

¢ Type the new current directory directly in the field.

¢ Use the drop-down list to change to a previously used current directory. To
specify the number of entries maintained each session, use the History
preference you access via File > Preferences > Current Directory.

¢ Use the Browse for folder button ... to select a new current directory.

¢ Use the Go Up One Level button £ to move the current directory up one
level.

The same current directory field also appears in the Current Directory
browser when the Current Directory browser is undocked from the desktop.
Use the Current Directory browser to perform many additional file operations.
For more information, see “File Management Operations” on page 5-34.
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Status Bar

Along the bottom of the desktop is the status bar. It displays messages,
such as when MATLAB is busy executing statements or when the Profiler
is on. Some tools, such as the Editor/Debugger, display additional status
information, such as the current line number. Not all status information
appears on the status bar — many MATLAB functions and tools provide
status information that is not reported to the status bar.

You can construct your own functions to provide status information. See the
timer function, and search for other specific terms describing the status of
interest.

Sizing, Arranging, and Sorting Columns in Tools

Some desktop tools present information in columns, such as the Current
Directory browser.

To change the column width, drag the separator bar between two column
headings in a tool. When a column is too narrow to show all the information
in it, position the pointer over an item and the full value for that item displays
like a tooltip.

To rearrange the columns in a tool, drag the column header to a different
position. To sort the information by a particular column, click the column
header. For example, in the Current Directory browser, click the Last
Modified date to sort the items in date order. Some columns also allow you
to reverse the sort order by clicking the column header again. A small gray
arrow in the header indicates the current sort order — for example, an up
arrow in the Last Modified Date column header indicates an ascending sort
order, meaning the oldest files are at the top of the list.
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Click acolumn haading to sort by that column. Click again to revarse To reorder columns,
drag a column header,
like Description, to
anather position.

the sort order.

Holdthe pointer
over a field to
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value for that
column.
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Keyboard Shortcuts (Accelerators) and Mnemonics

You can access many of the menu items using shortcut keys (sometimes called

accelerators or hot keys) for your platform. For example, use the Ctrl+X

shortcut to perform a cut on Windows platforms. Many of the menu items
show the shortcuts. Additional standard shortcuts for your platform usually
work but only one is listed with each menu item.

See additional shortcuts for the Command Window at “Keyboard Shortcuts
in the Command Window” on page 3-23, and for the Editor/Debugger at
“Keyboard Shortcuts in the Editor/Debugger” on page 6-31.

Instructions in the documentation specify shortcuts using the Windows
Ctrl+ key convention, but with Macintosh key bindings selected, you can
use the Command key instead. On the Macintosh, to make full use of all
keyboard shortcuts, you need to select the Full Access system preference
for Keyboard Shortcuts.

You can also use mnemonics to access menu items and buttons, such as Alt+F

to open the File menu. This is not supported on the Macintosh platform.

Mnemonics are listed with the menu item or button. For example, on the File

menu, the F in File is underlined, which indicates that Alt+F opens the
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menu. In the Profiler, the R in the Run this code toolbar field is underlined,
indicating that Alt+R moves the cursor to this field.

Note that some versions of Windows do not automatically show the mnemonics
on the menu. For example, you might need to hold down the Alt key while the
tool is selected in order to see the mnemonics on the menus and buttons. In
Windows 2000, go to Display Control Panel, select Effects, and clear the
item Hide keyboard navigation indicators until I use the Alt key. See
your Windows documentation for details.

Following are some general shortcuts that are not listed on menu items.

Key

Result

Enter

The equivalent of double-clicking, Enter performs the default action
for a selection. For example, press Enter while a statement in the
Command History window is selected to run that statement in the
Command Window.

For buttons in tools and dialog boxes, Enter executes the default
button (the button with a border around it). If there is no default
button, press the space bar to execute the active button (the button
with a dotted outline inside it). See “Default Button and Active
Button (Button with Focus)” on page 2-39 for an illustration.

Esc (escape)

Cancels the current action. For example, if you select the Edit menu,
the menu items display. Pressing Esc retracts the menu items.
Pressing Esc in a dialog box is the same as selecting the Cancel

button.

Tab Advances to the next button or field in a tool or dialog box.
In the Command Window, completes a statement if the tab
completion preference is selected.

Space bar For buttons in tools and dialog boxes, activates the active button. See

“Default Button and Active Button (Button with Focus)” on page 2-39
for an illustration of selecting default and active buttons using keys.
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Key

Result

+ or - or * on numeric
keypad

Use these keys on the numeric keypad to expand and collapse
items in tree views. The Help browser Help Navigator pane and
the Command History window use tree views. Use + to expand
the selected item, use - to collapse the selected item, and use * to
recursively expand it, meaning open all items contained in the
selected item.

Alt+S Displays the Start button menu (except on Macintosh platforms).

Alt+Y Provides access to the current directory field in the toolbar (except
on Macintosh platforms).

Ctrl+Tab Moves to the next open tool in the desktop, or to the next open group
of tools tabbed together.

Ctrl+Shift+Tab Moves to the previous open tool or group of tabbed tools in the

desktop.

Ctrl+Page Down

Moves to the next tool within a group of tools tabbed together. In a
group of documents, moves to next document.

Ctrl+Page Up

Moves to the previous tool within a group of tools tabbed together. In
a group of documents, moves to previous document.

Ctrl+F6 Moves to the next tool or document (only for Windows and Solaris
platforms).

Ctrl+Shift+F6 Moves to the previous tool or document (only for Windows and
Solaris platforms).

Alt+F4 Closes the desktop, thereby quitting MATLAB. Or outside the

desktop, closes the active window (except on Macintosh platforms).

For additional shortcuts available in the various desktop tools, see the
documentation for each tool. For example, see “Keyboard Shortcuts in
the Command Window” on page 3-23 and “Keyboard Shortcuts in the

Editor/Debugger” on page 6-31.

Go To First Letter (Type Ahead) Feature in Desktop Tool Lists
In the Current Directory browser and Command History window, you can
type a letter to move directly to the next item in the list that starts with the
letter you typed. This is sometimes referred to as type ahead.
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Default Button and Active Button (Button with Focus)
These illustrations demonstrate the default versus active button in a dialog
box.

The default button has a border around it. Harg,
= Save is the default button. Prass the Enter key to
Cancel | execute the default button.

~ The active buttan (the button with focus) has a dotted outline
| inside it. Hare, Cancel is the active button. Press the space bar
to execute the active buttan.

Harae, the Help button is bath the default buttan and the active
buttan. In some cases, the default always changes to match the
active button. You can press sither Enter or the space bar to
axecute the Help buttan

Selecting Multiple Items

In many desktop tools, you can select multiple items and then select an action
to perform on all the selected items. Select multiple items using the standard
practices for your platform.

For example, if your platform is Windows, do the following to select multiple
items:

1 Click the first item you want to select.

2 Hold the Ctrl key and then click the next item you want to select. Repeat
this step until you have selected all the items you want. To select contiguous
items, select the first item, hold the Shift key, and then select the last item.

Now you can perform an action on the selected items, such as delete.

To clear one of multiple selected items, use Ctrl+click. To clear all selected
items, click outside of the selection.

Cut, Copy, Paste, and Move

You can cut and copy a selection from a desktop tool to the clipboard and then
paste it from the clipboard into another tool or application. Use the Edit
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menu, toolbar, context menus, or standard keyboard shortcuts. For example,
you can copy a selection of statements from the Command History window
and paste them into some MATLAB desktop tools.

Use Paste to move items copied to the clipboard from other applications.
The Paste to Workspace item in the Edit menu opens the selection on the
clipboard in the Import Wizard. You can use this to copy data from another
application, such as Excel, into MATLAB. For details, see the “Using the
Import Wizard”.

When editing in the Command Window and Editor/Debugger, to move text to
a new location, select the text and drag it. To copy text, press Ctrl and drag
the selected text to the new location.

To undo the most recent cut, copy, or paste command, select Undo from the
Edit menu. Use Redo to reverse the Undo. For some tools, you can undo
multiple times in succession.

See also the clipboard function.

Drag and Drop

You can also move or copy a selection from one tool to another by dragging the
selection. For example, make a selection in the Command History window
and drag it to the Command Window, which pastes it there. Edit the lines

in the Command Window, if needed, and then press the Enter key to run
the lines from the Command Window.

Another example is to drag a filename from the Current Directory browser
to the Editor/Debugger to open that file in the Editor/Debugger. If you drag
editable text, for example, text in the Editor/Debugger, the text is cut rather
than copied. Use Ctrl and drag to copy rather than cut editable text.

On Windows platforms, you can drag items from external applications into
MATLAB. For example, dragging text from a Microsoft Word document into
the Editor/Debugger cuts and pastes it into the open file. Dragging an M-file
from Windows Explorer to the Command Window runs the file. Similarly, you
can drag selections from desktop tools to other applications. For example, you
can drag text from the Editor/Debugger to Microsoft Word.
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Printing and Page Setup Options for Desktop Tools

You can print from all desktop tools except the Current Directory browser, but
there are some differences in usage.

To print, select File > Print from the tool. A Print dialog box opens. The
Properties button in the Print dialog box is enabled for the Web and Help
browsers and the Profiler, but is not enabled for the other desktop tools.

To specify standard page setup options for your platform when you print
from the Command History, Workspace browser, and Array Editor, select
File > Page Setup. A standard page setup dialog box for your platform opens.

MATLAB provides special page setup options for printing from the Command
Window and Editor/Debugger. The setup options are essentially the same for
both tools, with minor variations. This section covers their use:

* “Specifying Page Setup Options” on page 2-41

¢ “Layout Options for Page Setup” on page 2-42

e “Header Options for Page Setup” on page 2-43

¢ “Fonts Options for Page Setup” on page 2-43

Specifying Page Setup Options

To specify page setup options, perform these steps:

1 In the tool you want to print from, for example, the Command Window,
select File > Page Setup.

The Page Setup dialog box opens for that tool.
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Page Setup: MATLAB Command Window |

Layout | Header | Fonts |

~Options
¥ Print header D::::h:._... et
¥ Print line numbers et
™ wrap lines E:‘E:-:::.:“

- Syntax highlighting R
£ Black and white text e
" Colored text :
% Styled text

(0]34 cancel

2 Click the Layout, Header, or Fonts tab in the dialog box and set those
options for that tool, as detailed in subsequent sections.

3 Click OK.

4 After specifying the options, select File > Print in the tool you want to
print from, for example, the Command Window.

The contents from the tool are printed, using the options you specified in
Page Setup.

Layout Options for Page Setup

You can specify the following layout options. A preview area shows you the
effects of your selections:

¢ Print header — Print the header specified in the Header pane.

¢ Print line numbers — Print line numbers.

¢ Wrap lines — Wrap any lines that are longer than the printed page width.
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Syntax highlighting — For keywords and comments that are highlighted
in the Command Window, specify how they are to appear in print. Options
are black and white text (that is, no highlighting), colored text (for use with
a color printer), or styled text. For styled text, keywords appear in bold,
comments appear in italics, and all other text appears in the normal style.
Only keywords and comments you input in the Command Window are
highlighted; output is not highlighted.

Header Options for Page Setup

If you want to print a header, select the Layout tab and then select Print
header. Then select the Header tab and specify how the elements of the
header are to appear. A preview area shows you the effects of your selections:

¢ Page number — Format for the page number, for example # of n

¢ Border — Border style for the header, for example, Shaded box

* Layout — Layout style for the header. For example, Standard one line

includes the date, time, and page number all on one line

Fonts Options for Page Setup
Specify the font to be used for the printed contents:

From Choose font, select the element, either Body or Header, where Body
text is everything except the Header.

Select the font to use for that element. For example, select Use Command
Window font for Body text if you want the printed text to be the same as
the font that appears in the Command Window. This is the font specified in
File > Preferences > Fonts > Custom for the Command Window.

Repeat for the other element. If you did not select Print header on

the Layout pane, you do not need to specify the Header font. As an
example, for Header text, select Use custom font and then specify the font
characteristics — type, style, and size. After you specify a custom font, the
Sample area shows how the font will look.
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Accessing The MathWorks on the Web

You can access popular MathWorks Web pages from the MATLAB desktop.
Select one of the following items from the Help > Web Resources menu.
For most items, the selected Web page then opens in your default system
Web browser, for example, Netscape:

The MathWorks Web Site — Home page of the MathWorks Web site
(http://www.mathworks.com).

Products & Services — MathWorks Products and Services page
(http://www.mathworks.com/products/) with information about the full
family of products.

Support — MathWorks Support page
(http://www.mathworks.com/support) where you can
look for solutions to problems you are having, or report new problems.

MathWorks Account

= Login in or Create Account — Login page for MathWorks Account
(http://www.mathworks.com/accesslogin/). If you are registered,
your main account page displays. Otherwise, you are directed to a page
where you register online. Registration allows you to view your product
registration and license information and helps you stay up to date on
the latest MATLAB developments.

= Get Passcodes and Manage Licenses — If you have a MathWorks
Account, displays your Licenses page.

= Get Product Trials — If you have a MathWorks Account, provides
access to trial versions of products.

MATLAB Central — MATLAB Central Web site
(http://www.mathworks.com/matlabcentral/) for the MATLAB user
community. It includes MATLAB contest entries and results, a MATLAB
screen saver, and these technical resources:

= MATLAB File Exchange — Code library of files contributed by
MathWorks customers and employees, available for free download and
use with MathWorks products.

= MATLAB Newsgroup Access — Provides access to the Usenet
newsgroup for MATLAB and related products, comp.soft-sys.matlab,
where you can post and answer questions, as well as view the archives.


http://www.mathworks.com
http://www.mathworks.com/products/
http://www.mathworks.com/support
http://www.mathworks.com/accesslogin/
http://www.mathworks.com/matlabcentral/
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e MATLAB Newsletters — Access to online versions of News and Notes and
MATLAB Digest. News and Notes is published twice a year and contains
feature articles, technical notes, and product information for MATLAB
users. MATLAB Digest, an electronic bulletin consisting of technical notes,
solutions, and timely announcements to the user community, is issued more
frequently. See http://www.mathworks.com/company/newsletters.

Check for Updates

This features allows you to easily determine if more recent versions of your
MathWorks products are available. Select Help > Check for Updates. A
dialog box appears, listing the version numbers of all MathWorks products
installed on your system. Click Check for Updates in the dialog box, which
accesses the MathWorks Web site and reports back for each product if a newer
version is available or if your version is the latest.

Terms of Use and Patents
Access the terms of use and patent information for MathWorks products.
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Fonts, Colors, and Other Preferences

Use preferences to change the font characteristics and the text and
background colors for tools in the desktop:

* “Fonts Preferences for Desktop Tools” on page 2-46

® “Colors Preferences for Desktop Tools” on page 2-53

® “General Preferences for MATLAB” on page 2-58

® “About Preferences” on page 2-63

Fonts Preferences for Desktop Tools
Use desktop font preferences to specify the font characteristics for MATLAB

desktop tools. The font characteristics are

* Name (also called family or type), for example, select SansSerif

® Style, for example, select bold

® Size in points, for example, type 11 points

Select File > Preferences > Fonts to set fonts for desktop tools. You can
specify the font to be used by all tools that primarily display code such as the

Command Window, and specify the font to be used by all other desktop tools.
Or you can separately specify the font for any desktop tool.

Select the font characteristics from the lists shown. For font size, not all
entries are shown. You can type in a size, including one not shown.

You can use the antialiasing font preference to smooth desktop fonts — see
“Antialiasing for Desktop Fonts” on page 2-53.

You can set some font options differently for printing — see “Printing and
Page Setup Options for Desktop Tools” on page 2-41.

For information about making additional fonts available to MATLAB, see
“Making Fonts Available to MATLAB” on page 2-53.
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With the code and text font styles, you can easily apply the
same font to all desktop tools that display code or text,
respectivaly.

Type afant size if
itisnotinthe list.

« ): Preferences =101 %

[l General Fonts Preferences
- MAT Files
-Confirmation Dialogs
LeSoyrce Control

—Desktop code font

F-Keyhoard Currently uzed by Command Windowe, Command History, Editor
- .
CLstom Monospaced ll I Flain ll I 10 ll

""" Colors Satnple

----- Commatc Windowy

..... Command History The dquick brown fox jumps over the lazy
[#-EditorTrebugoer dog. 1234567390

..... Web

----- Current Directary

----- Array Editor
----- GUIDE ~Desktop text fort

""" Time =eries Toolz Currently used by: Help Mavigator, HTRL Proportional Text, Current

:lgssgi %Depn‘:.fe:':trg::llate Directory Workspace, Array Editor

----- SystemTest SansSerif ll I Plain LI IJ“:I LI

----- Instrument Control
FH-irtual Reality Sarmple

B Sitmulink The quick brown fox jumps over the lazy dog. 1234567830

T+

[T use artialiazing to smoath deskiop forts

04 Cancel | Apply | Help

Select antialiasing preference to give fonts a smoother appearance.

Desktop Code Font and Desktop Text Font

You specify separate font characteristics for tools that primarily display
code (Desktop code font), such as the Command Window, and tools that
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primarily display text (Desktop text font), such as the Current Directory
browser. Many users prefer that code display in a monospace font to provide
better alignment, and prefer a more narrow font style for text information.
With the desktop code font preference, you set just one preference to apply
a monospace style to all tools that display code (except the Help and Web
Browsers). Similarly, you can set just one preference to apply a text font to
all desktop tools that display text.

The following illustrations show how the Editor/Debugger would look using a
monospace font and a proportional font. Note that a monospace font is useful
when you care about alignment, but a proportional font uses less space.

With a monospaced font, all charactars are the same width. Hare, the font is 10 pt.
Monospace. Note the 10th character in each line aligns with the Editor/Debugger's
right-hand text limit, which is set to column 10.

& Editor - Untitled*®
File Edit Text Ce|l Tools Debug Desktop ‘Window Help | a x

DS | REo 5|87

aR(F d°0d

1 1234567550
2 abodefghil
3 ABCDEFGHIJ
| script Ln 3 Col 11 |owR
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With a proportional font, characters are different widths. Hare, the fontis 10 pt.
SansSerif. Each line contains 10 characters but the length of each line differs. The
Editor/Debuggar’s right-hand text limit is not relevant.

& Editor - Untitled?2

File Edit Text Cel Tools Debug Desktop ‘Window Help ~ 2 x

D H| i@ |S(Mr @8R >0
1 1234567550
2 ahcdefghi]
3 ABCDEFGHL

|script |Ln 3 Cal 11 |O‘-.-’H s

Default Font Settings. Default settings are listed in the following table.

Note that Lucida Console approximates the fixedsys font available in earlier
versions of MATLAB.
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Font Type

Default Characteristics and
Sample

Tools Using Font Type by
Default

Desktop code font Monospaced, Plain, 10 point

Jamwmple code font

Command History
Command Window

Editor/Debugger (which also
applies to the Shortcuts
Editor)

Desktop text font

SansSerif, Plain, 10 point
Sample text font

Array Editor

Current Directory browser
(which also applies to the
Path browser)

Help Navigator

HTML Proportional Text.
This is the font used for
noncode text in the Web
browser (including, for
example, HTML reports
generated from cell
publishing), Profiler, and
Help browser display pane.
While you can select the font
name, you cannot change
the font style (for example,
to bold or italic) for HTML
Proportional Text. Changes
to size affect noncode and
code text.

Workspace browser
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When you change a font characteristic for Desktop code font, the
characteristic takes effect for all tools that use the desktop code font. The
same is true when you change a font characteristic for Desktop text font.

After changing a characteristic, a sample in the dialog box shows how it will
look. Click Apply or OK to make the change take effect in the desktop tools.
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See Also. “About Preferences” on page 2-63.

Custom Fonts Preferences

If you do not want to use the current settings for “Desktop Code Font and
Desktop Text Font” on page 2-47, you can specify that a tool use the code font,
the text font, or a different font. Select File > Preferences > Fonts. Click +
and select Custom. The Fonts Custom Preferences pane appears.

Use custom fonts preferencesto specify the tools that use the code style font and the tools that
use the text style font. You can also apply a custom font to any tool.

. Preferences

)

T

E-General

MaT-Files
sConfirmation Dialogs
- Sayrce Contral

H-Kevhoard

----- Command Windaw
----- Coammand History

[H-EditorDebugger

----- Current Directary
----- Array Editor

----- Tirne Series Toaolz

+-Figure Copy Template

----- Repart Generataor
----- SystemTest
----- Instrument Cortral

B-irtual Reality
[H-Sirmulink

Fonts Custom Preferences

For each desktop tool, you can specify that it use the deskiop code font, des
text fort, or & custom ford. To set desktop fort properties, use the main Ford
preference panel.

—Desktop toals ~Fort ta Use

[ =y

5 @ Deskiop code
Command History

Ecltor " Deskiop text

Help Marvigator -

HTML Proportional Text Custorm:

e nt Direct

ml}lrrE reeen SanzsSerif

otkspace

Array Editor Flair L” 10

—Sarnple

The guick brown fox Jjumps owver the lazy dog.
1234567590

Rl | B

Ok Cancel | Apply | Help |

Select a tool from the Desktop tools list. The type of font it uses, code or
text, appears under Font to Use. In the illustration shown, the Command
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Window uses the Desktop code font, which is defined in the Fonts pane
as described in the previous section.

To change the font characteristics the selected tool uses, select a different radio
button. For Custom, you then specify the font characteristics for that tool.

Changing the Font — Example

This example changes the default settings (see “Default Font Settings” on
page 2-49) for the desktop code font, changes the Command History font
preference so that it uses the desktop text font instead of the code font, and
specifies a custom font for the Current Directory browser:

1 Change the characteristics for the desktop code font. On the Fonts pane,
set the Desktop code font to Times New Roman, Plain, 14 point. Use
the default for the Desktop text font, SansSerif, Plain, 10 point. Click

Apply.

2 Make the Command History window use the desktop text font. Select
Fonts, click +, select Custom, and then select Command History from
Desktop tools. Select the Desktop text radio button.

3 Apply a custom font to the Current Directory browser. Select Current
Directory from Desktop tools. Select the Custom radio button. Select
Arial Narrow and Plain, and type 11 in the size field. Click OK.

The following table details the results of the changes.

Tool Font Type Font Characteristics

Command Window Desktop code Times New Roman,
Plain, 14 point

Command History Desktop text SansSerif, Plain, 10
point

Editor/Debugger Desktop code Times New Roman,
Plain, 14 point

Help Navigator Desktop text SansSerif, Plain, 10
point
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Tool

Font Type

Font Characteristics

HTML Proportional
Text

Desktop text

SansSerif, Plain, 10
point

Current Directory

Custom

Arial Narrow, Plain, 11
point

Workspace Desktop text SansSerif, Plain, 10
point
Array Editor Desktop text SansSerif, Plain, 10

point

See Also. For help about how MATLAB stores preferences and help for other
preferences, see “About Preferences” on page 2-63.

Antialiasing for Desktop Fonts
Select the antialiasing preference on the Preference > Fonts pane to give

desktop fonts a smoother appearance. The preference applies to all tools that

use the desktop code and text fonts. Note that MATLAB does not support
Microsoft ClearType font mode, but antialiasing provides a similar effect.

Making Fonts Available to MATLAB

On Windows platforms, desktop components (such as the Command Window

and Workspace browser), figure windows, and uicontrols support only

TrueType and OpenType fonts. Some graphics objects can render bitmapped

fonts as well, such as xlabel, ylabel, title, and text.

To make a new compatible font available to MATLAB, install the font by

selecting Start > Control Panel > Fonts in the Windows desktop, and then

selecting File > Install New Font. Restart MATLAB so that it can use the

font.

Colors Preferences for Desktop Tools

Desktop color preferences specify the colors used in MATLAB
desktop tools and the colors that convey syntax highlighting. Select
File > Preferences > Colors to set color preferences for desktop tools. You
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can set some color options differently for printing — see “Printing and Page
Setup Options for Desktop Tools” on page 2-41.

To set colors for text and the background, clear the Use system colors
check box and then salect colors from the palettes.

= ): Preferences B ] 51
F-General Colors Preferences
F-Heyhoard
[F-Forts v, Desktap toal calars
- Command Window \17 Use systern colors
~Command History
[#-Editor/Debugger Tieut N - | Eackaraumd N - |
el —h-file syntax highlighting colors
~=Zurrent Directary
ey Editor Keywards [ ] v| Comments || v|
- UIDE i | ] : |
=i i Lirit ated st ¥
~Time Series Tools e - e -
[#-Figure Copy Template S 2 o
vstem commands [ ] | Errars [ |
The Sample —Report Generator
area shows ~SystemTest ~Sample
how tha InEtrument Control
. [#-wirtual Reality %3 create a file for output
changas will - Simulink ltouch testFile.txt
look. fid = fopen|'testFile.txt', 'w'):
. for i=1:10
Specify the colar

iy fprintfifid,'$6.2f Yn, 1i);:
aof hyperlinks in

end
the Command
Window and the Hyperlink color v| Restore Default Colors |
Index pang of
the Help

browser. (ol I Cancel | Apply | Help |

¢ “Desktop Tool Colors” on page 2-55

¢ “Syntax Highlighting Colors” on page 2-56
e “Hyperlink Color” on page 2-58

® “See Also” on page 2-58
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Desktop Tool Colors

Use Desktop tool colors to change the color of the text and background in
the desktop tools. The colors also apply to the Import Wizard. The colors do
not apply to the HTML display pane nor to the Web Browser.

Select the check box Use system colors if you want the desktop to use the
same text and background colors that your platform (for example, Windows)
uses for other applications.

To specify different text and background colors, follow these steps:
1 Clear the Use system colors check box.

2 Click the arrow next to the Text color and choose a new color from the
palette shown.

When you choose a color, the Sample area in the dialog box updates to
show you how it will look.

3 Click the arrow next to the Background color and choose a new color.

If you use a gray background color, a selection in an inactive window will
not be visible.

4 Click Apply or OK to see the changes in the desktop tools.

Click Restore Default Colors to return to the default settings for desktop
tool colors, as well as for syntax highlighting colors.

The following illustration shows how the Current Directory browser looks

with blue-green text and a beige background. These colors are only discernible
in the online version of this documentation.
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Gray Background Color. For some UNIX platforms, there is a gray
background color for desktop tools, such as the Editor/Debugger. This occurs
when the preference for Desktop tool colors is set to Use system colors,
and the system’s window manager uses gray as the background color default.
To change the color, clear the check box for Use system colors and then
select a new Background color from the palette.

Syntax Highlighting Colors

In the Command Window, Command History, Editor/Debugger, and Shortcuts
callback area, MATLAB conveys syntax information via different colors to
help you easily identify elements, such as if/else statements. This is known
as syntax highlighting.

In the Command Window, only the input you type is highlighted; output from
running MATLAB functions is not highlighted. In the Editor/Debugger, you
can specify syntax highlighting preferences for use with files in M, C/C++,
Java, and HTML. For details, click the Help button in the Preferences
dialog box for the Editor/Debugger to see Language Preferences in the online
documentation.

Use preferences to specify the syntax highlighting colors. When you choose a
color, the Sample area in the dialog box updates to show you how it will look.
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Comments

System commands

String

Y preate a file for output
Lltouch testFile.fpxt

—Sample

Toxt fid = fopeni('testFile.txt', 'w'};:
for i=1:10
Kaywords fprintf(fid, '$6.2f Yn, 1i):

nd |

Unterminatad strings

The default colors are listed here:

Keywords — Flow control functions, such as for and if, as well as the
continuation ellipsis (. ..), are colored blue.

Comments — All lines beginning with a %, designating the lines as
comments in MATLAB, are colored green. Similarly, the block comment
symbols, %{ and %}, as well as the code in between, appear in green. Text
following the continuation ellipsis on a line is also green because it is

a comment.

Strings — Type a string and it is colored maroon. When you complete the
string with the closing quotation mark ('), it becomes purple. Note that for
functions you enter using command syntax instead of function syntax, the
arguments are highlighted as strings. This is to alert you that in command
notation, variables are passed as literal strings rather than as their values.
For more information, see “MATLAB Command Syntax” in the MATLAB
Programming documentation.

Unterminated strings — A single quote without a matching single quote,
and whatever follows the quote, are colored maroon. This might alert you
to a possible error.

System commands — Commands such as the ! (shell escape) are colored
gold.

Errors — Error text that appears after you run code, including any
hyperlinks, is colored red.

Click Restore Default Colors to return to the default settings for syntax
highlighting colors and desktop tool colors.
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Hyperlink Color

Specify the Hyperlink color, which applies to links in the Command Window
and the Help browser Index pane. If you use a dark background color for
those tools, be sure to use a light or other contrasting color for hyperlinks so
that you can see them.

See Also

For information about other preferences and how MATLAB stores preferences,
see “About Preferences” on page 2-63.

General Preferences for MATLAB

Select File > Preferences > General from any desktop tool to access
General Preferences.

: Preferences — ==l

General Preferences

MAT-Files
Confirmation Dialogs
~Source Cortrol

Toolbox path caching

H-Keyboard ¥ Enable toolhox path cache
[-Forts
----- Colors [~ Enable toolko: path cache diagnostics
----- Comnmand Yyindosw
----- Commnand History Update Toalbox Path Cache
[#-EditorDebugyer
------ Help
..... Wk Figure window printing
""" Current Directory Specity how colored lines and text are sent to the printer.
----- Array Editor & ;
..... GUIDE Usze printer defaults

----- Tirne Seties Tools
[#-Figure Copy Template
""" Report Generator  Always send as color
----- SystemTest

----- Instrumert Cortral
F-irtual Reality
[F-Sirnulink ' Move files to the Recycle Bin

'8 Always send as black and white

Default behavior of the delete function

* Delete files permanently

Ok I Cancel | Apply | Help |
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These preferences apply to all relevant tools in MATLAB.

¢ Toolbox path caching preference — see “Toolbox Path Caching in MATLAB”
on page 1-11

® Figure window printing — see “Printing and Exporting” in MATLAB
Graphics documentation

¢ “Default Behavior of the Delete Function” on page 2-59
¢ “MAT-Files” on page 2-60
® “Confirmation Dialogs” on page 2-60

e Chapter 9, “Source Control Interface”

Default Behavior of the Delete Function

Files you delete using the delete function are permanently removed by
default. There is no opportunity to retrieve them.

You can use this preference to instead move deleted files to the Recycle Bin
on Windows, to the Trash Can on Macintosh, or to a tmp directory on UNIX
platforms. Then, you can recover any accidentally deleted files from these
locations. Deleted files in these locations are not automatically removed; you
must remove them using operating system features, such as Empty Recycle
Bin on Windows. When you select this preference, delete might run slower.

Function Alternative. The MATLAB delete preference actually sets
the state of the recycle function upon startup and when you change the
preference. You can override the behavior of the preference by setting the
recycle function state. For example, regardless of the preference setting,
when you run

recycle('off')
delete('thisfile.m')

MATLAB permanently removes thisfile.m from the current directory. Files
you subsequently remove using delete are also permanently removed, unless
you reapply the preference to recycle or run recycle('on'). Regardless of the
state of the recycle function when you end a session, the next time you start
MATLAB, the setting for the preference is honored. For more information, see
the recycle and delete reference pages.
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Note that this preference and the recycle function do not apply to files
you delete using the Current Directory browser. For more information, see
“Cutting or Deleting Files and Directories” on page 5-41.

MAT-Files

The MAT-file save options apply when you use the save function and the
Save menu items (for MAT-files) in desktop tools. This preference also applies
to FIG-files, which include GUIs you create with GUIDE.

By default, MATLAB compresses the data when saving a MAT-file, thereby
reducing the storage space required. When you load the MAT-file, MATLAB
automatically uncompresses the data. In addition, MATLAB uses Unicode
character encoding for strings when you save a MAT-file, making the data
accessible to other MATLAB users, regardless of the default character
encoding scheme used by their systems.

Prior releases of MATLAB did not save compressed MAT-files. They also did
not use Unicode character encoding, which sometimes prevented the exchange
of MAT-files among users, particularly when they used localized systems.

The default preference for saving prevents you from using the MAT-files with
MATLAB Version 6 or 6.x. To save MAT-files for use with a previous version,
select the preference Ensure backward compatibility (-v6). Alternatively,
you can override the preference by using the save function with the-v6
option, which, for occasional use, might be more convenient than changing the
preference. For more information, see the save reference page.

Confirmation Dialogs

Use these preferences to instruct MATLAB to display or not display specific
confirmation dialog boxes.



Fonts, Colors, and Other Preferences

=10 |

General Confirmation Dialogs Preferences

The following diglog boxes require user confirmation. Select a check box
L if you wwant that dialog box to appear.
E State | Digloy Box Description I Tool %
~Cormmand Wincow ¥ warn betore deleting Command History tems Command History

|—Ke3-'bna_rd & Indlenting W warn before clearing the Command Windowvy Cammand Windaw
| Carmmand Histary ¥ Prowpt when ediing files thet do ot exist Edditor
[ﬂ_—EHdrItorJDebugger [T Confirm before exiting MATLAE General
_F\TEF; = Prompt to save on activate GLIDE
W'

—Current Directary I|; Pram.pt to =ave on Efxpart _ GUIDE
—array Editor Canfirrm when deleting variables Wiarkspace
—iGUIDE
[F-Figure Copy Templste
—Report Generator
—Instrument Caortral
H—irtual Reality
imulink

Kl oam

Select all | Clear all |
(0.4 | Cancel | Apply | Help |

When the check box for a confirmation dialog is selected and you perform the
action it refers to, the confirmation dialog box appears. If you clear that check
box, the dialog box does not appear when you perform the action.

When the confirmation dialog box does appear, it includes a Do not show
this prompt again check box. If you select the check box in the dialog box, it
automatically clears the check box for the confirmation preference.

For example, select the check box Warn before deleting Command History
items. Then select Edit > Delete Selection in the Command History,
MATLAB displays the following confirmation dialog box.
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« ): Command History

& All zelected commands will be deleted.

[™ Do nat show this prarmpt adsin.

Zancel |

If you select the Do not show this prompt again check box and click OK,
the confirmation dialog box will not appear the next time you delete items
from the Command History window. In addition, the Warn before deleting
Command History items check box in the Confirmations Dialogs
preferences pane is cleared.

The following table summarizes the confirmation dialog boxes.

Confirmation Dialogs
Check Box Item

About the Confirmation
Dialog Box

For More Information

Warn before deleting
Command History items

Appears when you delete
entries from the Command
History window.

“Deleting Entries from the
Command History Window”
on page 3-49

Warn before clearing the
Command Window

Appears when you clear the
Command Window content
using menu items. Does not
appear when you use the clc
function.

“Clearing the Command
Window” on page 3-28

Prompt when editing files that
do not exist

Appears when you type edit
filename, if filename does not
exist in the current directory
or on the MATLAB path.

“Function Alternative” on page
6-9

Confirm before exiting
MATLAB

Appears when you quit
MATLAB.

“Quitting MATLAB” on page
1-16
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Confirmation Dialogs About the Confirmation

Check Box Item Dialog Box For More Information

Prompt to save on activate Appears when you have Layout Editor Preferences in
unsaved changes to a figure the GUIDE documentation

and M-file, and then activate
the GUI, by clicking the Run
button, for example.

Prompt to save on export Appears when you have Layout Editor Preferences in
unsaved changes to a figure the GUIDE documentation
and M-file, and then select
File > Export.

Confirm when deleting Appears when you delete “Deleting Workspace
variables variables from the workspace | Variables” on page 5-8
using menu items. Does
not appear with the clear
function.

About Preferences

Use preferences to specify options for each desktop tool:
1 Select File > Preferences.

2 In the left pane of the Preferences dialog box, preferences appear for
MATLAB tools as well as for any other MathWorks products installed on
your system.

Choose a tool and click the + to display more preferences for that tool.
From the expanded list, select the entry you want. The right pane shows
the preferences for that item.

3 Change settings. Click Apply or OK to set the preferences. Preferences
take effect immediately. They remain persistent across MATLAB sessions.

Note that some tools allow you to control these settings from within the tool

without setting a preference. Use that method if you only want the change to
apply to the current session.
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Function Alternative
Open the Preferences dialog box using the preferences function.

Preferences File — matlab.prf

Preferences are stored in a preferences file, matlab.prf. Type prefdir in the
Command Window to see the full pathname for the preferences directory that
contains matlab.prf. The preference directory also contains related files.

On Macintosh platforms, the directory might be in a hidden folder, for
example, myname/.matlab/R2006b. To access the directory, select Go > Go
to Folder in the Mac OS Finder. In the resulting dialog box, type the path
returned by prefdir and press Enter.

The matlab.prf file is loaded when MATLAB starts and is overwritten when
you close MATLAB.

When you install a new version of MATLAB, it tries to use your existing
preferences from the previous version, where possible.

The preferences file that MATLAB uses depends on the release. For more
information, see the reference page for prefdir.

Summary of Preferences

Preference What You Can Specify

General Preferences Toolbox path caching, figure window printing, delete
function behavior, MAT-file save formats, confirmation
dialogs, and source control.

Keyboard Key bindings, tab completion, and delimiter matching for
the Command Window and the Editor/Debugger.

Fonts Font type, style, and size for desktop tools. Customize
for any tool.

Colors Colors for text, background, syntax highlighting, and
hyperlinks in desktop tools.
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Preference

What You Can Specify

M-Lint

Show or hide M-Lint messages in the Editor/Debugger
M-Lint automatic code analyzer and in the M-Lint Code
Check Report.

Command Window

Numeric format and display, accessibility, and tab size.

Command History

Display, filtering, and saving.

Editor/Debugger Editor type, startup options, display, tab size and
indenting, language, including M-Lint messages,
publishing, and autosave.

Help Product filter and synchronization.

Web Internet proxy server settings.

Current Directory

Number of entries in history and display options.

Array Editor Numeric format, use of Enter key, and decimal separator.
Workspace Statistical calculation options.
GUIDE Display options.

Time Series Tools

Property Editor dialog and x-axes warning dialog.

Figure Copy Template

Application, text, line, uicontrols, axis, format,
background color, and size.

Other products

Preferences for other installed MathWorks products.
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“Software Accessibility Support” on page 2-66
“Documentation Accessibility Support” on page 2-67
“Assistive Technologies” on page 2-68

“Installation Notes for Accessibility Support” on page 2-69
“Troubleshooting” on page 2-72

Software Accessibility Support

MathWorks products includes a number of modifications to make them more
accessible to all users. Software accessibility support for blind and visually
impaired users includes

Support for screen readers and screen magnifiers, as described in
Command-line alternatives for most graphical user interface (GUI) options
Keyboard access to GUI components

A clear indication of the current cursor focus

Information available to assistive technologies about user interface
elements, including the identity, operation, and state of the element

Nonreliance on color coding as the sole means of conveying information
about working with a GUI

Noninterference with user-selected contrast and color selections and other
individual display attributes, as well as noninterference for other operating
system-level accessibility features

Consistent meaning for bit-mapped images used in GUIs

HTML documentation that is accessible to screen readers

Keyboard access to the user interface includes support for “sticky keys,” which
allow you to press key combinations (such as Ctrl+C) sequentially rather
than simultaneously.
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Except for scopes and real-time data acquisition, the MathWorks software
does not use flashing or blinking text, objects, or other elements having a
flash or blink frequency greater than 2 Hz and lower than 55 Hz.

The MathWorks believes that its products do not rely on auditory cues as the
sole means of conveying information about working with a GUIL. However,

if you do encounter any issues in this regard, please report them to the
MathWorks Technical Support group.

http://www.mathworks.com/contact_TS.html

Documentation Accessibility Support

Documentation is available in HTML format for all MathWorks products
that are included in R2006b.

Accessing the Documentation

To access the documentation with a screen reader, go to the R2006b
documentation area on the MathWorks Web site at

http://www.mathworks.com/access/helpdesk/help/helpdesk.html

Navigating the Documentation

Note that the first page that opens lists the products. To get the
documentation for a specific product, click the link for that product.

The table of contents is in a separate frame. You can use a document’s table of
contents to navigate through the sections of that document.

Because you will be using a general Web browser, you will not be able to use
the search feature included in the MATLAB Help browser. You will have
access to an index for the specific document you are using. The cross-product
index of the MATLAB Help browser is not available when you are using a
general Web browser.

Products

The documentation for all products is in HTML and can be read with a screen
reader. However, for most products, most equations and most graphics are
not accessible.
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The following product documentation has been modified (as described below)
to enhance its accessibility for people using a screen reader such as JAWS:

e MATLAB (many sections, but not the function reference pages (however,
M-file help is accessible))

¢ Excel Link

¢ Optimization Toolbox

¢ Signal Processing Toolbox

e Statistics Toolbox

Documentation Modifications
Modifications to the documentation include the following:

¢ Describing illustrations in text (either directly or via links)

® Providing text to describe the content of tables (as necessary)

Restructuring information in tables to be easily understood when a screen
reader is used

Providing text links in addition to any image mapped links

Equations

Equations that are integrated in paragraphs are generally explained in words.
However, most complex equations that are represented as graphics are not
currently explained with alternative text.

Assistive Technologies

Note To take advantage of accessibility support features, you must use
MathWorks products on a Microsoft Windows platform.

Tested Assistive Technologies
For R2006b, The MathWorks has tested the following assistive technologies:
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e JAWS 5.0, 6.0, and 7.0 for Windows (screen reader) from Freedom Scientific

® Built-in accessibility aids from Microsoft, including the Magnifier and
“sticky keys”

Use of Other Assistive Technologies

Although The MathWorks has not tested other assistive technologies, such as
other screen readers or ZoomText Xtra (screen magnifier) from Ai Squared,
The MathWorks believes that most of the accessibility support built into its
products should work with most assistive technologies that are generally
similar to the ones tested.

If you use other assistive technologies than the ones tested, The MathWorks
is very interested in hearing from you about your experiences.

Installation Notes for Accessibility Support

Note If you are not using a screen reader such as JAWS, you can skip this
section.

This section describes the installation process for setting up your MATLAB
environment to work effectively with JAWS.

Use the regular MATLAB installation script to install the products for which
you are licensed. The installation script has been modified to improve its
accessibility for all users.

Note Java Access Bridge 1.1 is installed automatically when you install
MATLAB.

After you complete the product installation, there are some additional steps
you need to perform to ensure JAWS works effectively with MathWorks
products.
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Setting Up JAWS
Make sure that JAWS is installed on your machine. If it is, there is probably a
shortcut to it on the Windows desktop.

Setting up JAWS involves these tasks:

1 Add the Access Bridge to your Windows path (for networked installations
only).

2 Create the accessibility.properties file.
These tasks are described in more detail below.

(For Networked Installations Only) Add Access Bridge to Your Path.
If you are running MATLAB in a networked installation environment (that is,
if the MATLAB Installer was not run on your machine), you need to take the
following steps to add Access Bridge to your Windows path.

Note This procedure assumes your Windows Start button is set to Classic
mode. To set Classic mode, from the Start button, select Settings. Next
select Task Bar and Menu. Then select the Start Menu tab and make sure
the Classic Start Menu option is enabled. Click OK and you are done.

1 From the Start button, select Settings, next select Control Panel. Scroll
down and click the System icon to display the System Properties dialog box.

2 In the System Properties dialog box, select the Advanced tab.
3 Click Environment Variables.

4 Under System variables, select the Path option.

5 Click the Edit button.

6 To the start of the Path environment variable, add the directory that
contains matlab.exe; for example:

C:\matlab71\bin\win32;
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Be sure to include that semicolon between the end of this directory name
and the text that was already there.

7 Click OK three times.

8 If JAWS is already running, exit and restart.

Note JAWS must be started with these path changes in effect to work
properly with MATLAB.

Create the accessibility.properties File.

1 Create a text file that contains the following two lines:

screen_magnifier_present=true
assistive_technologies=com.sun.java.accessibility.AccessBridge

2 Use the filename accessibility.properties.
3 Move the accessibility.properties file into
$(matlabroot)\sys\java\jre\win32\jre1.5.0\1ib\

JAWS Pronunciation Dictionary. As a convenience, The MathWorks
provides a pronunciation dictionary for JAWS. This dictionary is in a file
called MATLAB. jdf.

During installation, the file is copied to your system under the MATLAB root
directory at sys\Jaws\matlab.jdf.

To use the dictionary, you must copy it to the \SETTINGS\ENU folder located
beneath the JAWS root installation directory.

You need to restart JAWS and MATLAB for the settings to take effect.

Testing
After you install JAWS and set up your environment as described above, you
should test to ensure JAWS is working properly:
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1 Start JAWS.

2 Start MATLAB.

JAWS should start talking to you as you select menu items and work with the
MATLAB user interface in other ways.

Troubleshooting

This section identifies workarounds for some possible issues you may
encounter related to accessibility support in MathWorks products.

JAWS Does Not Detect When the MATLAB Installation Has
Started

When you select setup.exe, the Windows copying dialog box opens and you
are informed. After the files have been copied, the installation splash screen
opens, and then the installer starts. However, JAWS does not inform you that
the installer has begun: the installer either starts up below other windows
or applications or it is minimized. Since the installer is not an active item,
nothing is read.

Therefore, check the Windows applications bar for the installer. After you go
to the installer, you can use JAWS to perform the installation.

JAWS Stops Speaking
When many desktop components are open, JAWS with MATLAB sometimes
stops speaking.

If this happens, close most of the desktop components, exit MATLAB, and
restart.

Command Output Not Read

In the MATLAB Command Window, JAWS does not automatically read the
results of commands.

To read command output, first select File > Preferences > Command
Window, select the option Use arrow keys for navigation instead of
command history recall, and click OK. Then, in the Command Window,
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press the arrow keys to move to the command output and use JAWS
keystrokes to read the output.

With this preference set, you cannot use arrow keys to recall previous
commands. Instead use the following key bindings:
* Windows key bindings:
= Previous history: Ctrl+up arrow
= Next history: Ctrl+down arrow
¢ Emacs key bindings:
= Previous history: Ctrl+p
= Next history: Ctrl+n

To return to using the up and down arrow keys to recall previous commands,
clear the preference.

Some GUI Menus Are Treated as Check Boxes

For some GUIs (for example, the figure window), menus are treated by JAWS
as though they are check boxes, whether or not they actually are.

You can choose a menu item for such GUIs by using accelerator keys (e.g.,
Ctrl+N to select New Figure), if one is associated with a menu item. You can
also use mnemonics for menu navigation (e.g., AIt+E).

Note that check boxes that you encounter by tabbing through the elements of
a GUI are handled properly.

Text Ignored in Some GUIs

For some dialog boxes, JAWS reads the dialog box title and any buttons, but
ignores any text in the dialog box.

Also, in parts of some GUIs, such as some text-entry fields, JAWS ignores the
label of the field. However, JAWS will read any text in the text box.
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Running Functions —
Command Window and
History

If you are viewing this document in the Help browser, you can watch the
Desktop and Command Window video demo and the Command History video
demo for an overview of the major functionality. The Command Window is
where you run (execute) MATLAB statements, while the Command History is
a log of the statements you have run.

Opening the Command Window Access the Command Window.
(p. 3-3)

Running Functions and Programs, Enter statements at the prompt.
and Entering Variables (p. 3-5) Run M-files, interrupt programs,

run external programs, and examine
errors. Evaluate and open selections.

Controlling Input (p. 3-12) Consider case sensitivity, enter long
statements, edit statements, and use
syntax highlighting and keyboard
shortcuts.

Controlling Output (p. 3-26) Suppress, page and format output,
clear and print contents, and save a
session.

Searching in the Command Window Use the Find dialog or incremental
(p. 3-30) search features to find content in the
Command Window.
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Preferences for the Command
Window (p. 3-36)

Command History (p. 3-44)

Preferences for Command History
(p. 3-51)

Specify options for text, display, tab
size, accessibility, and indenting
for the Command Window and the
Editor/Debugger.

View session histories. Run
statements, copy entries, search, and
print the history. Set preferences.

Specify how often to automatically
save the history file and the types of
statements to exclude.



Opening the Command Window

Opening the Command Window

The Command Window is one of the main tools you use to enter data, run
MATLAB functions and other M-files, and display results. If you are viewing
this document in the Help browser, you can watch the Desktop and Command
Window video demo for an overview of the major functionality.

When the Command Window is not open, access it by selecting Command
Window from the Desktop menu. Alternatively, open the Command Window
with the commandwindow function.

If you prefer a simple command line interface without the other MATLAB
desktop tools, select Desktop > Desktop Layout > Command Window
Only. For more information, see “Arranging the Desktop — Overview” on
page 2-5.

The Command Window prompt, >>, is where you enter statements. For
example, you can enter a MATLAB function with arguments, or assign
values to variables. The prompt indicates that MATLAB is ready to accept
input from you. When you see the prompt, you can enter a variable or run a
statement. This prompt is also known as the command line.

<) Command Window &1 =] 3

File Edit Debug Desktop Window Help

e
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When MATLAB displays the K>> prompt in the Command Window, MATLAB
is in debug mode. Type dbquit to return to normal mode. For more
information, see Chapter 6, “Editing and Debugging M-Files”

MATLAB displays the EDU>> prompt for the MATLAB Student Version.

3-4



Running Functions and Programs, and Entering Variables

Running Functions and Programs, and Entering Variables

¢ “Running Statements at the Command Line Prompt” on page 3-5
¢ “Running External Programs” on page 3-7
¢ “Evaluating or Opening a Selection” on page 3-9

e “Hyperlinks for Running Functions” on page 3-10

Running Statements at the Command Line Prompt

Entering Variables and Running Functions

At the prompt, enter data and run functions. For example, to create A, a
3-by-3 matrix, type

A=1[123; 456; 78 10]

When you press the Enter or Return key after typing the line, MATLAB
responds with

A =
1 2 3
4 5 6
7 8 10

To run a function, type the function including all arguments and press Enter
or Return. MATLAB displays the result. For example, type

magic(2)

and MATLAB returns

ans =
1 3
4 2

Definition of a Statement. All of the information you type before pressing
Enter or Return is known as a statement. This can include:
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® Variable assignments: For example, a = 3

® Commands: M-files provided with MATLAB or toolboxes that do not accept
input arguments, for example, clc, which clears the Command Window.

e Scripts: M-files (MATLAB program files) you write that do not take input
arguments or return output arguments, for example, myfile.m.

¢ Functions and their arguments: M-files that can accept input arguments
and return output arguments, for example, magic.

Some functions support a form that does not require an input argument,
thereby operating as commands. For convenience, the term function is used to
refer to both functions and commands.

When you enter program control statements, such as if ... end, the
prompt does not appear until you complete the set of functions. In the
following example, you press Enter at the end of each line, but the prompt
does not appear until you complete the set of statements with end.

) Command Window 1 1 (=] k3

File Edit Debug Desktop Window Help
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'greater!
elseif L < B
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Running M-Files

Run M-files, files that contain code in the MATLAB language, the same way
that you would run any other MATLAB function. Type the name of the M-file
in the Command Window and press Enter or Return. The M-file must be in
the MATLAB current directory or on the MATLAB search path — for details,
see “Search Path” on page 5-22. You can also use the run function and specify
the full pathname to an M-file script.



Running Functions and Programs, and Entering Variables

To determine the name of the M-file currently running, use mfilename.

Examining Errors

If an error message appears when you run an M-file, click the underlined
portion of the error message, or position the cursor within the filename
and press Ctrl+Enter. The offending M-file opens in the Editor/Debugger,
scrolled to the line containing the error.

Processing Order

In MATLAB, you can only run one process at a time. If MATLAB is busy
running one function, any further statements you issue are buffered in a
queue. The next statement will run when the previous one finishes.

Interrupting a Running Program

You can stop a running program by pressing Ctrl+C or Ctrl+Break at any
time. On Macintosh platforms, you can also use Command+. (the Command
key and the period key) to stop the program. For certain operations, stopping
the program might generate errors in the Command Window.

For M-files that run a long time, or that call built-ins or MEX-files that run a
long time, Ctrl+C does not always effectively stop execution. Typically, this
happens on Windows rather than UNIX platforms. If you experience this
problem, you can help MATLAB break execution by including a drawnow,
pause, or getframe function in your M-file, for example, within a large loop.
Note that Ctrl+C might be less responsive if you started MATLAB with the
-nodesktop option.

Running External Programs

The exclamation point character, !, sometimes called bang, is a shell escape
and indicates that the rest of the input line is a command to the operating
system it. Use to invoke utilities or call other executable programs without
quitting MATLAB. On UNIX, for example,

lvi yearlystats.m
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invokes the vi editor for a file named yearlystats.m. After the external
program completes or you quit the program, the operating system returns
control to MATLAB. Add & to the end of the line, such as

Idir &

on Windows platforms to display the output in a separate window or to run
the application in background mode. For example

lexcel.exe &

opens Excel and returns control to the Command Window so you can continue
running MATLAB statements.

See the reference pages for the unix, dos, and system functions for details
about running external programs that return results and status.

Note To execute operating system commands with specific environment
variables, include all commands to the operating system within the system
call. Separate the commands using & (ampersand) for DOS, and ; (semicolon)
for UNIX. This applies to the MATLAB ! (bang), dos, unix, and system
functions. Another approach is to set environment variables before starting
MATLAB.

On Macintosh platforms, you cannot run AppleScript directly from MATLAB.
However, you can run the Macintosh OS X osascript function from the
MATLAB unix or ! (bang) function to run AppleScript from MATLAB.

UNIX System Path and Running UNIX Programs from MATLAB

To run a UNIX program from MATLAB if its directory is not on the UNIX
system path MATLAB uses, take one of the actions described here.

Change Current Directory in MATLAB. Change the current directory in
MATLAB to the directory that contains the program you want to run.

Modify the UNIX System Path MATLAB Uses. Add the directories to the
system path from the shell. The exact steps depend on your shell. This is
an example using sh:
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1 At the system command prompt, type

export PATH="$PATH:<mydirectory>"

where <mydirectory> is the directory that contains the program you want
to run.

2 Start MATLAB.
3 In MATLAB, type

lecho $PATH

The directory containing the file is added to the system path that MATLAB
uses. This change applies only to the current session of the terminal window.

Automatically Modify System Path at MATLAB Startup. If you want
to add a directory to the PATH environment variable each time you start
MATLAB, perform these steps:

1 In a text editor, open the file MATLAB/bin/matlab. This file is used to
start MATLAB.

2 Add this line to the beginning of the matlab file
export PATH="$PATH:<mydirectory>"
where <mydirectory> is the directory you want to add to the path.
If you run a tsch shell instead of a bash shell, use setenv instead of export.
3 Save the file.
The matlab file will modify the PATH environment variable, and then start

MATLAB.

Evaluating or Opening a Selection

Make a selection in the Command Window and press Enter or Return. The
selection is appended to whatever is at the prompt, and MATLAB executes it.
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Similarly, you can select a statement from any MATLAB desktop tool,
right-click, and select Evaluate Selection from the context menu.
Alternatively, after making a selection, use the shortcut key, F9, or for some
tools, press Enter or Return. For example, you can scroll up in the Command
Window, select a statement you entered previously, and then press Enter to
run it. If you try to evaluate a selection while MATLAB is busy, for example,
running an M-file, execution waits until the current operation is done.

You can open a function, file, variable, or Simulink® model from the Command
Window. Select the name in the Command Window, and then right-click and
select Open Selection from the context window. This runs the open function
for the item you selected so that it opens in the appropriate tool:

M-files and other text files open in the Editor/Debugger.

Figure files (. fig) open in a figure window.

Variables open in the Array Editor.

Models open in Simulink.

See the open reference page for details about what action occurs if there are
name conflicts. If no action exists to work with the selected item, Open
selection calls edit.

Function Alternative

Use open or edit to open a file in the Editor/Debugger. Use type to display
the M-file in the Command Window.

Hyperlinks for Running Functions

Use matlab: to run a specified statement when you click a hyperlink in the
Command Window. For example

disp('<a href="matlab:magic(4)">Generate magic square</a>')
displays

Generate magic sSoquare
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When you click the link Generate magic square, MATLAB runs magic(4).
Alternatively, you can press Ctrl+Enter if the cursor is positioned in the link
text. You can use the disp, error, fprintf, or warning function with this
feature. Change the hyperlink color using Colors Preferences — see “Colors
Preferences for Desktop Tools” on page 2-53. For more information, including
examples, see the matlabcolon (matlab:) reference page.

3-11
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Controlling Input

e “Case and Space Sensitivity” on page 3-12

e “Syntax Highlighting” on page 3-13

¢ “Matching Delimiters (Parentheses)” on page 3-14

e “Cut, Copy, Paste, and Undo Features” on page 3-14

e “Enter Multiple Lines Without Running Them” on page 3-15
¢ “Entering Multiple Functions in a Line” on page 3-15

¢ “Entering Long Statements (Line Continuation)” on page 3-15
e “Recalling Previous Lines” on page 3-16

e “Tab Completion in the Command Window” on page 3-17

e “Keyboard Shortcuts in the Command Window” on page 3-23
* “Navigating Above the Command Line” on page 3-25

Case and Space Sensitivity

Uppercase and Lowercase for Variables

With respect to case, MATLAB requires an exact match for variable names.
For example, if you have a variable a, you cannot refer to that variable as A.

Uppercase and Lowercase for Files and Functions

With respect to functions, filenames, objects, and classes on the search path
or in the current directory, MATLAB prefers an exact match with regard to
case. MATLAB runs a function if you do not enter the function name using
the exact case, but displays a warning the first time you do this.

To avoid ambiguity and warning messages, always match the case exactly. It
is a best practice to use lowercase only when running and naming functions.
This is especially useful when you use both Windows and UNIX platforms
because their file systems behave differently with regard to case.

Note that if you use the help function, function names are shown in all
uppercase, for example, PLOT, solely to distinguish them. Some functions for
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interfacing to Java do use mixed case and the M-file help and documentation
accurately reflect that.

Examples. The directory first is at the top of the search path and contains
the file A.m. If you type a instead of A, MATLAB runs A.m but issues a
warning. When you type a again during that session, MATLAB runs A.m but
does not show the warning.

Add the directory second after first on the search path, with the file a.m in
second. The directory first contains A.m, while second contains a.m Type a.
MATLAB runs a.m but displays a warning the first time you do this.

Spaces in Expressions

Blank spaces around operators such as -, :, and ( ), are optional, but they
can improve readability. For example, MATLAB interprets the following
statements the same way.

y = sin (3 * pi) / 2
y=sin(3*pi)/2

Syntax Highlighting

Some entries appear in different colors to help you better find elements, such
as matching if/else statements. This is known as syntax highlighting. You
can change the colors using preferences. Note that output does not appear
with syntax highlighting, except for errors. For more information, see “Colors
Preferences for Desktop Tools” on page 2-53.

3-13
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Defaultcolors are shown here—to change them, use Preferences -> Colors.
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Matching Delimiters (Parentheses)

You can set a preference for MATLAB to notify you about matched and
unmatched delimiters. For example, when you type a parenthesis, bracket,
or brace, MATLAB highlights the matched delimiter in the pair. To set
these preferences, select File > Preferences > Keyboard > Delimiter
Matching. This feature is also available in the Editor/Debugger. For more
information, see “Delimiter Matching” on page 3-42.

Cut, Copy, Paste, and Undo Features

Use the Cut, Copy, Paste, Undo, and Redo features from the Edit menu
when working in the Command Window. You can also access some of these
features in the context menu for the Command Window.

Undo applies to some of the actions listed in Edit menu. You can undo
multiple times in succession until there are no remaining actions to undo.
Select Edit > Redo to reverse an undo.

If you use Enter, you cannot edit a line after entering it, even though you
have not completed the flow. In that event, use Ctrl+C to end the flow, and
then enter the statements again.
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Enter Multiple Lines Without Running Them

To enter multiple lines before running any of them, use Shift+Enter or
Shift+Return after typing a line. This is useful, for example, when entering
a set of statements containing keywords, such as if ... end. The cursor
moves down to the next line, which does not show a prompt, where you can
type the next line. Continue for more lines. Then press Enter or Return

to run all of the lines.

This allows you to edit any of the lines you entered before you pressing Enter
or Return.

Entering Multiple Functions in a Line

To enter multiple functions on a single line, separate the functions with a
comma (, ) or semicolon ( ; ). Using the semicolon instead of the comma will
suppress the output for the command preceding it. For example, put three
functions on one line to build a table of logarithms by typing

format short; x = (1:10)"'; logs = [x log10(x)]

and then press Enter or Return. The functions run in left-to-right order.

Entering Long Statements (Line Continuation)

If a statement does not fit on one line, enter three periods (.. .) , also called
dots, stops, or an ellipsis, at the end of the line to indicate it continues on
the next line. Then press Enter or Return. Continue typing the statement
on the next line. You can repeat the ellipsis to add a line break after each
line until you complete the statement. When you finish the statement, press
Enter or Return.

For items in single quotation marks, such as strings, you must complete the
string in the line on which it was started. For example, completing a string as
shown here

headers = ['Author Last Name, Author First Name, '
"Author Middle Initial']

results in

3-15
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headers =
Author Last Name, Author First Name, Author Middle Initial

MATLAB produces an error when you do not complete the string, as shown
here:

headers = ['Author Last Name, Author First Name,
Author Middle Initial']

??? headers = ['Author Last Name, Author First Name,
Error: Missing variable or function.

Note that MATLAB ignores anything appearing after the ... on a line, and
continues processing on the next line. This effectively creates a comment out
of the text following the ... on a line. For more information, see “Commenting
Out Part of a Statement” on page 6-20.

Recalling Previous Lines

Use the arrow, tab, and control keys on your keyboard to recall, edit, and
reuse functions you typed earlier. For example, suppose you mistakenly enter

rho = (1+ sqt(5))/2
Because you misspelled sqrt, MATLAB responds with

Undefined function or variable 'sqt'.

Instead of retyping the entire line, press the up arrow ** key. The previously
typed line is redisplayed. Use the left arrow key to move the cursor, add the
missing r, and press Enter or Return to run the line. Repeated use of the
up arrow key recalls earlier lines, from the current and previous sessions.
Using the up arrow key, you can recall any line maintained in the Command
History window.

Similarly, specify the first few characters of a line you entered previously and
press the up arrow key to recall the previous line. For example, type the
letters plo and then press the up arrow key. This displays the last line that
started with plo, as in the most recent plot function. Press the up arrow key



Controlling Input

again to display the next most recent line that began with plo, and so on.
Then press Enter or Return to run the line. This feature is case sensitive.

If the up arrow key moves the cursor up but does not recall previous lines,
clear the accessibility preference. For more information, see “Accessibility”
on page 3-38.

Another way to view and access commands from the current and previous
MATLAB sessions is with the Command History window — see “Command
History” on page 3-44.

Tab Completion in the Command Window

MATLAB helps you automatically complete the names of these items as you
type them in the Command Window:

® Function or model on the search path or in the current directory

¢ Filename or directory

Variable, including structures, in the current workspace

Handle Graphics property for figure in the current workspace

Type the first few characters of the item name and then press the Tab key.
To use tab completion, you must have the tab completion preference for the
Command Window selected. For details, see “Keyboard Preferences” on page
3-39.

Tab completion is also available in the Editor/Debugger, but there are some
slight differences in usage. See “Tab Completion in the Editor/Debugger”
on page 6-22.

These examples demonstrate how to use tab completion in the Command
Window:

“Basic Example — Unique Completion” on page 3-18

“Multiple Possible Completions” on page 3-18

“Tab Completion for Directories and Filenames” on page 3-21

“Tab Completion for Structures” on page 3-21

3-17
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e “Tab Completion for Properties” on page 3-22

Basic Example — Unique Completion

This example illustrates a basic use for tab completion. After creating a
variable, costs_march, type

costs

and press Tab. MATLAB automatically completes the name of the variable,
displaying

costs_march

Then complete the statement, adding any arguments, operators, or options,
and press Return or Enter to run it. In this example, if you just press
Enter, MATLAB displays the contents of costs_march. If MATLAB does not
complete the name costs_march but instead moves the cursor to the right,
you do not have the preference set for tab completion. If MATLAB displays No
Completions Found, costs_march does not exist in the current workspace.

You can use tab completion anywhere in the line, not just at the beginning.
For example, if you type

a = cost
and press Tab, MATLAB completes costs_march. You can also select co or

position the cursor after co and press Tab to complete costs_march.

Multiple Possible Completions

If there is more than one name that starts with the characters you typed,
when you press the Tab key, MATLAB displays a list of all names that start
with those characters. For example, type

cos

and press Tab. MATLAB displays
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cosd

cosets

zosh

costs march

The resulting list of possible completions includes the variable name you
created, costs_march, but also includes functions that begin with cos,
including cosets from the Communications Toolbox, if it is installed on the
system and on the MATLAB search path. MATLAB completes variable names
in the currently selected workspace, and the names of functions and models
on the MATLAB search path or in the current directory.

Continue typing to make your entry unique. For example, type the next
character, such as t in the example. MATLAB selects the first item in the list
that matches what you typed, in this case, costs_march. Press Enter (or
Return) or Tab to select that item, which completes the name at the prompt.
In the example, MATLAB displays costs_march at the prompt. Add any
arguments, and press Enter again to run the statement.

You can navigate the list of possible completions using up and down arrow
keys, and Page Up and Page Down keys. You can clear the list without
selecting anything by pressing Esce. Note that the list of possible completions
might include items that are not valid commands, such as private functions.
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Narrowing Completions Shown. You can narrow the list of completions
shown by typing a character and then pressing Tab if the Command Window
preference Tab key narrows completions is selected. This is particularly
useful for large lists. For example, type cam and press Tab to see the possible
completions. There is a scroll bar with the list because there are too many
completions to be seen at once.

« ): Command Window =101 x|
File Edit Debug Desktop Window Help u

x> camn|

Cameramenu

cameratoolbar
camlight v
camlookat
camorbit

Carmpan

Canpos =

Type p and press Tab again. MATLAB narrows the list, showing only all
possible camp completions.

« ) Command Window -0l x|
File Edit Debug Desktop ‘Window Help u
=r camp|

campos

CamposIn

campro]
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Continue narrowing the list in the same way. For the above example, type o
and press Tab to further narrow the list. Press Enter or Return to select
an item, which completes the name at the prompt.

Tab Completion for Directories and Filenames

Tab completion works for directories and filenames in MATLAB functions.
For example, type

edit d:/
and press Tab.

MATLAB displays the list of directories and files in d, from which you can
choose one. For example, type

mym

and press Tab.

MATLAB displays
edit d:/mymfiles/

where mymfiles is the only directory on your d drive whose name begins with
mym. Continue using tab completion to display and complete directory names
or filenames until you finish the edit statement.

Tab completion for directories and filenames is not supported for functions
you write.

Tab Completion for Structures

For structures in the current workspace, after the period separator, press
Tab. For example, type

mystruct.

and press Tab to display all fields of mystruct. If you type a structure and
include the start of a unique field after the period, pressing Tab completes
that structure and field entry.
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For example, type

mystruct.n

and press Tab, which completes the entry mystruct.name, where mystruct
contains no other fields that begin with n.

Tab Completion for Properties

Complete property names for figures in the current workspace using tab
completion, as in this graphics example. Here, f is a figure. Type

set(f, 'pap

and press Tab. MATLAB displays

set (£, 'paper

PaperOrientation

PaperPosition
PaperFPozitionMode
PaperSize
PaperType
PaperUnits

Select a property from the list. For example, type

u

and press Enter. MATLAB completes the property, including the closing
quote.

set(f, 'paperunits’'
Continue adding to the statement, as in this example
set(f, 'paperunits', 'c

and press Tab. MATLAB automatically completes the property
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set(f, 'paperUnits’,

‘centimeters'

because centimeters is the only possible completion.

Keyboard Shortcuts in the Command Window

Following is the list of arrow and control keys that serve as shortcuts for
using the Command Window. In addition to these shortcut keys (sometimes
called hot keys), you can use shortcuts for menu items, which you can view
on the menus, as well as general desktop shortcuts described in “Keyboard
Shortcuts (Accelerators) and Mnemonics” on page 2-36. If you select the
Emacs (MATLAB standard) preference for key bindings (see “Command
Window Key Bindings” on page 3-40 for an explanation), you can also use the
Ctrl+key combinations shown in the table.

Key

Control Key for MATLAB
standard (Emacs)
Preference

Operation

Ctrl+P

Recall previous line — for details, see “Recalling
Previous Lines” on page 3-16. See also
“Command History” on page 3-44, which is a
log of previously used functions, and “Keeping a
Session Log” on page 3-29.

With the Accessibility preference selected,
moves the cursor up a line when it is above
the prompt. In that event, use Ctrl+# to recall
previous lines for Windows and Macintosh key
bindings.

Ctrl+N

Recall next line — for details, see “Recalling
Previous Lines” on page 3-16. Works only after
using the up arrow or Ctrl+P.

With the Accessibility preference selected,
moves the cursor down a line when it is above
the prompt. In that event, use Ctrl+¥ to recall
previous lines for Windows and Macintosh key
bindings.

Ctrl+Home

None

Move to top of Command Window.
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Control Key for MATLAB
standard (Emacs)

Key Preference Operation

Ctrl+End None Move to end of Command Window.

= Ctrl+B Move back one character.

— Ctrl+F Move forward one character.

Ctrl+=— None Move left one word.

Ctrl+— None Move right one word.

Home Ctrl+A Move to beginning of current statement.

End Ctrl+E Move to end of current statement.

Esc Ctrl+U Clear the command line when cursor is at
the command line. Otherwise, move cursor to
command line.

Delete Ctrl+D Delete character at cursor.

Backspace Ctrl+H Delete character before cursor.

None Ctrl+K Cut contents (kill) from cursor to end of current
line.

Insert None Change to overwrite mode from insert mode,
or change to insert mode from overwrite mode.
View current mode in the status bar: OVR is
gray for insert mode. In overwrite mode, what
you type replaces existing text and the cursor
is a wide block. (Not supported on Macintosh
platforms.)

Double-click None Select current word. To select additional words,
hold mouse after second click and continue
dragging left or right.

Triple-click None Select current line. To select additional lines,
hold mouse after second click and continue
dragging up or down.

Shift+Home None Select from cursor to beginning of statement.

Shift+End None Select from cursor to end of statement.
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Control Key for MATLAB
standard (Emacs)

Key Preference Operation

Enter in None Append selection to statement at command line
selection and execute it.

Ctrl+Enter in None Open hyperlink displayed in Command Window.
hyperlink For example, in the hyperlink of an error

message, opens the file in the Editor/Debugger
at that line number.

Navigating Above the Command Line

To look at or copy information in the Command Window that is above the
command line (>> prompt), use the mouse and scroll bar, key combinations
such as Ctrl+Home, and search features. By default, the up and down arrow
keys recall statements so you cannot use them to move the cursor when it

is above the command line.

To use the up and down arrow keys to move the cursor when it is above the

command line, select File > Preferences > Command Window, and select
the Accessibility preference.
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Controlling Output

¢ “Echoing Execution” on page 3-26

® “Suppressing Output” on page 3-26

¢ “Paging of Output in the Command Window” on page 3-26
¢ “Formatting and Spacing Numeric Output” on page 3-27

e “Clearing the Command Window” on page 3-28

¢ “Printing Command Window Contents” on page 3-28

e “Keeping a Session Log” on page 3-29

Echoing Execution

To display each function within a statement as it executes, run echo on. For
details, see the echo reference page.

Suppressing Output

If you end a statement with a semicolon ( ; ) and then press Enter or Return,
MATLAB runs the statement but does not display any output. This is
particularly useful when you generate large matrices. For example, running

A = magic(100);

creates A but does not show the resulting matrix in the Command Window.

Paging of Output in the Command Window

If output in the Command Window is lengthy, it might not fit within the
screen and display too quickly for you to see it without scrolling back to it. To
avoid that problem, use the more function to control the paging of output in
the Command Window. By default, more is off.

After you type more on, MATLAB displays only a page (a screen full) of
output, pauses, and displays

--more- -

indicating there is more output to display. Press one of the following keys.
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Key Action

Enter or Return To advance to the next line
Space Bar To advance to the next page
q To stop displaying the output

You can scroll in the Command Window to see input and output that are no
longer in view. As an alternative to scrolling, you can use the up and down
arrow keys if the Command Window Accessibility preference is selected.

Formatting and Spacing Numeric Output

By default, numeric output in the Command Window is displayed as 5-digit
scaled, fixed-point values, called the short format. To change the numeric
format of output for the current and future sessions, set the Command
Window preference for text display. The text display format affects only how
numbers are shown, not how MATLAB computes or saves them.

Function Alternative

Use the format function to control the output format of the numeric values
displayed in the Command Window. The format you specify applies until you
change it or until the end of the session. More advanced alternatives are
listed in the “See Also” section of the format reference page.

Examples of Formats

Here are a few examples of the various formats and the output produced from
the following two-element vector x.

X = [4/3 1.2345e-6]

format short
1.3333 0.0000

format short e
1.3333e+000 1.2345e-006

format +
++
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A complete list and description of available formats is in the reference page
for format. For more control over the output format, use the sprintf and
fprintf functions.

Controlling Spacing

To control spacing in the output, use the Command Window preference for
text display or the format function. Use

format compact

to suppress blank lines, allowing you to view more information in the
Command Window. To include the blank lines, which can help make output
more readable, use

format loose

Clearing the Command Window

Select Clear Command Window from the Edit menu or context menu
to clear it. This does not clear the workspace, but only clears the view.
Afterwards, you still can use the up arrow key to recall previous functions.
A confirmation dialog box appears if you select the preference for it; see
preferences for “Confirmation Dialogs” on page 2-60 for more information.

Function Alternative

Use clc to clear the Command Window. Similar to clc is the home function,
which moves the prompt to provide a clear screen, but does not clear the
text so you can still scroll up to see it.

Printing Command Window Contents

To print the complete contents of the Command Window, select File > Print.
To print only a selection, first make the selection in the Command Window
and then select File > Print Selection.

Specify printing options for the Command Window by selecting File > Page
Setup. For example, you can print with a header. For more information, see
“Printing and Page Setup Options for Desktop Tools” on page 2-41.
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Keeping a Session Log

The diary Function

The diary function creates a copy of your MATLAB session in a disk file,
including keyboard input and system responses, but excluding graphics. You
can view and edit the resulting text file using any text editor, such as the
Editor/Debugger. To create a file on your disk called sept23.out that contains
all the functions you enter, as well as MATLAB output, enter

diary('sept23.out')

To stop recording the session, use
diary('off')

To view the file, run

edit('sept23.out')

Other Session Logs
There are two other means of viewing session information:

¢ The Command History window, which contains a log of all functions
executed in the current and previous sessions.

® The logfile startup option — see “Startup Options” on page 1-7.
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Searching in the Command Window

You can search for specified text that appears in the Command Window,
where the text was either part of input you supplied, or output displayed by
MATLAB. There are two search features for the Command Window:

¢ “Find Dialog Box” on page 3-30

¢ “Incremental Search” on page 3-31

After finding the text, you can copy and paste it to the prompt in the
Command Window to run it, or into an M-file or other file.

See also “Recalling Previous Lines” on page 3-16, “Tab Completion in the
Command Window” on page 3-17, and “Keyboard Shortcuts in the Command
Window” on page 3-23 for techniques to reuse previous statements and
navigate in the Command Window. To find files and text in files, see “Finding
Files and Content Within Files” on page 5-45.

Find Dialog Box

Select Find from the Edit menu to search for specified text in the Command
Window using the Find dialog box. Complete the dialog box. The search
begins at the current cursor position. MATLAB finds the text you specified
and highlights it. Click Find Next or Find Previous to find another
occurrence, or use the keyboard shortcuts F3 and Shift+F3.

X
Fitied wekiat: | ﬂ Firvel et
Look in: I Cortrane Window LI Find Frevious
[™ Matchcase [ wWholeword [ Wirap around Cloze

MATLAB beeps when a search for Find Next reaches the end of the
Command Window, or when a search for Find Previous reaches the top
of the Command Window. If you have Wrap around selected, it continues
searching after beeping.
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Note that you can only search for text currently displayed in the Command
Window. To increase the amount of information maintained in the Command
Window, increase the setting for the command session scroll buffer size in
Command Window Preferences, and do not clear the Command Window.

Change the selection in the Look in field to search for the specified text in
other MATLAB desktop tools.

Incremental Search

With the incremental search feature, the cursor moves to the next or previous
occurrence of the specified text in the Command Window. It is similar to the
Emacs search feature. To use the incremental search feature in the Command
Window,

1 Position the cursor where you want the search to begin.

2 How you begin the incremental search depends on your setting for the
Command Window key bindings preference:

® Press Ctrl+S for Emacs, or

¢ Press Ctrl+Shift+S for Windows
To look for the previous occurrence, press Ctrl+R or Ctrl+Shift+R instead.
An incremental search field, Inc Search, appears at the bottom of the

Command Window and is preceded by F for a forward search, or R when
you are looking for the previous occurrence (reverse search).
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Search begins at current cursor position.

<) Comm and Window

File Edit Debug Desktop ‘Window Help

> gLy

qLy =|
[15] 'Berlin'
[15] 'Boston'
[15] 'London'
[15] 'Melbourne'
[21] 'Berlin'
[21] 'Boston'
[21] 'London'
[21] 'Melbourne'
[22] 'Berlin'
[22] 'Berlin'
[22] 'Boston'
[22] 'Boston'
[22] 'London'
[22] 'London'
[22] 'Melbourne'
[22] 'Melbourne'

>

|Flnc Search: | Ké

Incramental search fia\d.

3 In the Inc Search field, type the text you want to find. For example, look
for Boston.

As you type the first letter, b, the first occurrence of that letter in the
Command Window after the current cursor position is highlighted. For the
example shown, the first occurrence of b is highlighted, the b in Berlin.
Note that incremental search allows for case sensitivity — see “Case
Sensitivity in Incremental Search” on page 3-34.
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MATLARB finds the next b.

<) Command Window E1 =] E3
File Edit Debug Desktop Window Help
gLy =
gty =

[15] Beriin:

[15] 'Boston'

[15] 'Londaon'

[15] 'Melbourne’

[21] 'Berlin'

[21] 'Boston'

[21] 'London!

[21] 'Melbourne’ —

[22] '"Berlin'

[22] 'Berlin'

[22] 'Boston!

[22] 'Bostaon' LI

|Flnc Search: b s

When you type the next letter, the first occurrence of the text becomes
highlighted. In the example, when you add the letter o to the b so that the
Inc Search field now has bo, the bo in Boston becomes highlighted.

¢ If you mistype in the Inc Search field, use the Back Space key to
remove the last letters and make corrections.
e After finding the bo, you can press Ctrl+W to complete that word. In

this example, Boston appears in the Inc Search field.

To find the next occurrence of Boston in the Command Window, press
Ctrl+S. To find the previous occurrence of the text, press Ctrl+R.

If MATLAB beeps, it means either that the text was not found, or the
search wrapped past the end (or beginning) of the Command Window and
continued at the beginning (or end).
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® When the text is not found, Failing appears in the incremental search
field. Modify the search term in the incremental search field and try
again. Use Ctrl+G to automatically remove characters back to the last
successful search. For example, if plode fails, Ctrl+G removes the de
from the search term because plo does exist in the Command Window.

6 To end the incremental search, press Esc or Enter, or any other key that is
not a character or number.

The Inc Search field no longer appears. The cursor is at the position
where the text was last found, with the search text highlighted.

Incremental search is also available in the Editor/Debugger — see
“Incremental Search” on page 6-45.

Case Sensitivity in Incremental Search

When you enter lowercase letters in the Inc Search field, for example, b,
incremental search looks for both lowercase and uppercase instances of the
letters, for example b and B. However, if you enter uppercase letters, for
example, B, incremental search only looks for instances that match the case
you entered.
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In the example, enter b0 in the Inc Search field and incremental search does
not find any matching text.

File Edit Debug Desktop Window Help
»> by =
gry =
[15] 'Eerlin'
[15] ‘Boston
[15] ' London'
[15] 'Melbourne'
[ncremental [21] 'Berlin'
search is [21] 'Boston' |
casa-sansitive [21] 'London!
when you entar [21] 'Melhourne'
uppercass [z22] 'Berlin'
letters. Heare, no [z2z] "Berlin'
matches are [22] 'Eoston! 4
found for bO———— | Failng F Inc Search: bo 4
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Preferences for the Command Window

Set these preferences for the Command Window:

¢ “Format, Display, Accessibility, and Tab Size Preferences” on page 3-36
e “Keyboard Preferences” on page 3-39 to set key bindings, tab completion,
and delimiter matching for the Command Window and the Editor/Debugger

Additional preferences that relate to the Command Window are

* “Fonts Preferences for Desktop Tools” on page 2-46

® “Confirmation Dialogs” on page 2-60

Format, Display, Accessibility, and Tab Size
Preferences

To set these preferences for the Command Window, select File > Preferences
and then select Command Window in the left pane of the Preferences dialog
box.
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Text Display
Specify the format, that is, how output appears in the Command Window.

Numeric format. Specify the output format of numeric values displayed in
the Command Window. This affects only how numbers are displayed, not how
MATLAB computes or saves them. The format reference page includes the
list of available formats, with examples.

Numeric display. Specify spacing of output in the Command Window. To

suppress blank lines, use compact. To display blank lines, use loose. For
more information, see the reference page for format.
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Display

Wrap lines. Select to make a single line of input or output in the Command
Window break into multiple lines in order to fit within the current width of
the Command Window. This is useful for console mode. With this option
selected, an entire line is visible without scrolling, and the horizontal scroll
bar does not appear because it is not needed.

Limit matrix display width to eighty columns. When selected, MATLAB
displays only 80 columns of matrix output, regardless of the width of the
Command Window. Clear the check box if you make the Command Window
wider than 80 columns and want matrix output to fill the width of the
Command Window. See also the display reference page.

To determine the number of columns and rows that will display in the
Command Window, given its current size, use

get (0, 'CommandWindowSize')

With the matrix display width preference cleared, the number of columns is
based on the width of the Command Window. With the preference set to 80
columns, the number of columns is always 80.

Number of lines in command window scroll buffer. Set the number of
lines maintained in the Command Window, from 1,000 to 25,000. This is the
number of lines you can see when you scroll vertically. A larger buffer means
you can view more lines and it provides a larger base for search features,
but requires more memory.

This preference setting does not impact the number of lines you can recall
when you use the up arrow key in the Command Window. Using the up
arrow key, you can recall all lines shown in the Command History window,
regardless of how many lines you can see in the Command Window.

Accessibility

Select this option to use the up and down arrow keys to move the cursor when
it is above the command line. With this preference selected, use the Ctrl+ up
arrow or down arrow key to recall statements for Windows and Macintosh
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key bindings, or Ctrl+P and Ctrl+N for MATLAB standard (Emacs) key
bindings.

Clear this preference to use the up and down arrow keys to recall statements.
Use the mouse and other features to move the cursor when above the
command line.

Tab key

Tab size. Number of spaces assigned to a tab stop when displaying output.
The default is four spaces, except on UNIX platforms where the default is eight
spaces. This does not apply when the tab completion preference is selected.

Keyboard Preferences

To set key binding, tab completion, and delimiter matching preferences for the
Command Window and the Editor/Debugger, select File > Preferences and
then select Keyboard in the left pane of the Preferences dialog box.
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Command Window Key Bindings
Specify the keyboard shortcuts (key bindings) to be used at the command line.

MATLAB standard (Emacs). Allows you to use the control keys listed in
“Keyboard Shortcuts in the Command Window” on page 3-23, which should be
familiar to existing MATLAB users and Emacs users. For example, Ctrl+A
moves the cursor to the beginning of the line.

Windows. Allows you to use standard Windows control keys. For example,
Ctrl+A is the shortcut for Edit > Select All, which selects the entire contents
of the Command Window.
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Macintosh. This option is available only on Macintosh platforms. It allows
you to use Macintosh keys, such as the Command key instead of the Ctrl key.

Editor/Debugger Key Bindings

Specify the keyboard shortcuts (key bindings) to be used by the
Editor/Debugger. The Editor/Debugger key bindings are also used by other
tools, for example, the Callback field in the Shortcut Editor dialog box.

Select Windows, Emacs, or Macintosh (available only on Macintosh
platforms), depending on which convention you want the Editor/Debugger to
follow for accelerators and shortcuts. The accelerators on the menus change
after you change this option.

For example, when you select Windows key bindings, the shortcut to paste

a selection is Ctrl+V. When you select Emacs key bindings, the shortcut to
paste a selection is Ctrl+Y. When you select Macintosh key bindings, the
shortcut to paste a selection is Command+V. You can see the accelerator on
the Edit menu for the Paste item.

Tab Completion

Enable in Command Window. Select the check box to use tab completion
when typing functions in the Command Window. Clear the check box if you
do not want to use the tab completion feature. In that event, when you press
the Tab key, MATLAB moves the cursor to the next tab stop rather than
completing a function — see also the preference for “Tab size” on page 3-39.

Enable in Editor/Debugger. Select the check box to use tab completion
when typing functions in the Editor/Debugger. Clear the check box if you do
not want to use the tab completion feature. In that event, when you press
the Tab key, MATLAB moves the cursor to the next tab stop rather than
completing a function — see also in the online documentation.

Tab key narrows completions. Select this check box to narrow the list of

possible completions shown by typing another character and pressing Tab.
For details, see “Narrowing Completions Shown” on page 3-20.
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Tabs and Indents
The links go to the panes where you can view and set preferences for

¢ Tab key size in the Command Window, which is used when the tab
completion preference is not set

¢ Tab key size and indenting preferences in the Editor/Debugger

Delimiter Matching

To set these preferences, select File > Preferences > Keyboard > Delimiter
Matching . These preferences apply to the Command Window and the
Editor/Debugger.

With these preferences selected, MATLAB alerts you to matched and
unmatched delimiters based on the MATLAB language syntax rules, where
delimiters are parentheses ( ), brackets [ ], and braces { }. For example, when
you type a parenthesis or another delimiter, MATLAB highlights the matched
parenthesis or delimiter in the pair.

Match while typing. Select the check box if you want to be alerted to
matches and mismatches in pairs of delimiters as you type them. Then choose
how you want MATLAB to alert you to matches by selecting an entry from
Show match with. When you type a closing (or opening) delimiter in the
Command Window or Editor/Debugger, MATLAB alerts you based on the
option you choose:

® Balance — The corresponding delimiter is highlighted briefly.

® Underline — Both delimiters in the pair are underlined briefly.

® Highlight — Both delimiters in the pair are highlighted briefly.

Choose how you want MATLAB to alert you to mismatches using Show
mismatch with. When you type a closing delimiter that does not have an
opening match, MATLAB alerts you based on the option you choose:

* Beep — MATLAB beeps.

e Strikethrough — The delimiter you typed is briefly crossed out.

¢ None — There is no action.
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Match on arrow key. Select the check box if you want to be alerted to
matches and mismatches in pairs of delimiters when you use an arrow key to
move the cursor over a delimiter. Then choose how you want MATLAB to alert
you to matches by selecting an entry from Show match with. When you
move the arrow over a closing (or opening) delimiter in the Command Window
or Editor/Debugger, MATLAB alerts you based on the option you choose:

® Underline — Both delimiters in the pair are underlined briefly.

® Highlight — Both delimiters in the pair are highlighted briefly.

Choose how you want MATLAB to alert you to mismatches by selecting an
entry from Show mismatch with. When you move an arrow key over a
delimiter that does not have a match, MATLAB alerts you based on the option
you choose:

* Beep — MATLAB beeps.

e Strikethrough — The delimiter is briefly crossed out.

¢ None — There is no alert.
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Command History

The Command History window displays a log of the statements most recently
run in the Command Window. If you are viewing this document in the Help
browser, you can watch the Command History video demo for an overview of
the major functionality.

To show or hide the Command History window, use the Desktop menu.
Alternatively, use commandhistory to open the MATLAB Command History
window when it is closed, or to select it when it is open. For details, see
“Arranging the Desktop — Overview” on page 2-5.

Use the Command History window as described in these sections:

¢ “Viewing Statements in the Command History Window” on page 3-45
® “Using Statements from the Command History Window” on page 3-46
e “Searching in the Command History Window” on page 3-47

¢ “Printing the Command History Window” on page 3-49

¢ “Deleting Entries from the Command History Window” on page 3-49

Timestamp marks the start of each session. Selact it to select all
statements in the history for that session.

Click-to hidehistory — ERSSUIULADIRTEDY
for that session. File Edit| Debug Desktop Window Help
Click + to expand: E-%-- 09/24/03 10:30 AN —-% -

which collats
collatz(2)
collatzplaot (3)
dbcuit

Selectone ar mare
lines and right-click to
copy, evaluate, create

PY. ' E-%-- 09/25/03 09:11 &AM --%
a shortcut, or create —4

. load theta

an M-file from the (17) =
salaction.

2

MATLAB provides other options for viewing a history of statements. See
also the following sections:
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e “Recalling Previous Lines” on page 3-16, which describes using the up
arrow in the Command Window

¢ The diary function reference page

e “Startup Options” on page 1-7, which includes the logfile startup option

Viewing Statements in the Command History
Window

The Command History window lists statements you ran in the current session
and in previous sessions. The time and date for each session appear at the top
of the history of statements for that session. Use the scroll bar or the up and
down arrow keys to move through the Command History window.

Click - to hide the history for a session, and click + to show it. Select a
timestamp to select all entries for that session. With a timestamp selected,
you can press the + or - key to show and hide entries.

The Command History window and the Command Window’s statement recall
feature save to the file history.m, which is stored in the same directory as
MATLAB preferences. Type prefdir in the Command Window to see the
location of the file. The history.m file is loaded when MATLAB starts, and
it stores a maximum of 20,000 bytes, deleting the oldest entries as needed

to maintain that size.

MATLAB automatically saves the history.m file throughout the session
according to the Saving preference you specified. You can choose to
automatically exclude certain statements from being written to the history.m
file with the Settings preference. For details, see “Preferences for Command
History” on page 3-51.
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Using Statements from the Command History
Window

You can select entries in the Command History window and then perform the
following actions for the selected entries.

Action How to Perform the Action

Run statements in the Command | Double-click an entry (entries) in the Command History
Window window to execute the statement(s) in the entries. For
example, double-click edit myfile to open myfile.m in the
Editor/Debugger. You can also run the statements in an
entry by right-clicking the entry and selecting Evaluate
Selection from the context menu, or by selecting an entry
and pressing Enter or Return.

Edit and run statements in the Select an entry or entries and then select Copy from the

Command Window context menu. Paste the selection into the Command
Window. Alternatively, drag the selection to the Command
Window.

Then in the Command Window, edit the statements, and
press Enter or Return to execute them.

Copy statements to another Select an entry or entries and then select Copy from the
window context menu. Paste the selection into an open M-file in the
Editor/Debugger or any application. Alternatively, drag the
selection from the Command History window to an open
M-file or another application.

Create an M-file from statement(s) | Select an entry or entries and then right-click and

select Create M-File from the context menu. The
Editor/Debugger opens a new M-file that contains the
statements you selected from the Command History window.

Create a shortcut from Select an entry or entries and then right-click and select
statement(s) Create Shortcut from the context menu. Alternatively,
drag the selection to the Shortcuts toolbar. The Shortcut
Editor opens and the selected statements appear in the
Callback field. For more information, see “Shortcuts for
MATLAB — Easily Run a Group of Statements” on page
2-23.
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Searching in the Command History Window
There are two types of search in the Command History window:

¢ “Finding Next Entry By Letter” on page 3-47
¢ “Finding Text” on page 3-48

After finding an entry, you can copy and paste it into an M-file or any file, or
you can right-click and select Evaluate Selection to run the entry.

Finding Next Entry By Letter

Type a letter in the Command History window to move to the next entry that
begins with that letter, starting from the top of the Command History, as
illustrated in this example:

1 Position the cursor at which collatz in the Command History window.

) Command History £ N =] 4

File Edit Debug Deskiop “Window Help
E-%-- 09/24/03% 10:30 AM —--% -

which collats

—oollat=s(2)

—oollatzplot (3)

—dboguit

E-%-- 09/25/03 09:11 AN --% —
—load theta

w179 hd

4

2 Type 1. The Command History window selects the next entry that begins
with 1, in this example, load.

3-47



3 Running Functions — Command Window and History
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Type a letter, in this example 1, and the Command History window
salects the next entry that begins with that latter.

) Command History K1 =] B

File Edit Debug Deskiop ‘“Window Help

E-%-- 09/z4/03 10:30 LM —-% |~
—which collats

—cocollat=z(2)

—oollatzplot (3)

—dbouit

E-%—— 09/25/03 09:11 AM —-% =

load thets

{17 =]
2

Finding Text

Select Find from the Edit menu to search for specified text using the Find
dialog box. Complete the dialog box. The search begins at the current cursor
position. MATLAB finds the text you specified and highlights it. Click Find
Next or Find Previous to find another occurrence, or use the keyboard
shortcuts F3 and Shift+F3. Find looks for visible entries only, that is, it does
not find entries in collapsed nodes.

Search for specified text in the Command History window.

x|
Firdl wvhat: I | LI Firdl Mext

Laak ir: I Cammand Histary LI Find Previous

[~ Match caze [ whole word | WYWrap around Cloze

MATLAB beeps when a search for Find Next reaches the end of the
Command History window, or when a search for Find Previous reaches the
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top of the Command History window. If you have Wrap around selected, it
continues searching after beeping.

Change the selection in the Look in field to search for the specified text in
other MATLAB desktop tools.

Printing the Command History Window

To print the contents of the Command History window, select File > Print or
Print Selection. Specify options for printing by selecting File > Page Setup.
For example, you can print the history with a header. For more information,
see “Printing and Page Setup Options for Desktop Tools” on page 2-41.

The printed version is sized to fit the page. If there is a long statement in
the Command History, the reduced page size might be difficult to read. As
a workaround, either use Print Selection, where the long statement is not
part of the selection, or remove any extremely long statements from the
Command History before printing it.

Deleting Entries from the Command History Window

Delete entries from the Command History window when you feel there are
too many and it becomes inconvenient to find the ones you want. All entries
remain until you delete them or until the history.m file exceeds its maximum
size, when MATLAB automatically deletes the oldest entries—see “Viewing
Statements in the Command History Window” on page 3-45.

To delete entries in the Command History window, first select the entries to
delete, using one of these methods:

® Select a single entry.

e Shift+click or Ctrl+click to select multiple entries.

® Select the timestamp for a session to select all entries for that session.
Then use Shift+click or Ctrl+click to select multiple timestamps with all
of their entries.

Then right-click and select Delete selection from the context menu, or press

the Delete key. A confirmation dialog box might appear; see preferences for
“Confirmation Dialogs” on page 2-60 for more information.

3-49



3 Running Functions — Command Window and History

To delete all entries, select Edit > Clear Command History, or select Clear
Entire History from the context menu.

After deleting entries from the Command History window, you will not be able

to recall those statements in the Command Window as described in “Recalling
Previous Lines” on page 3-16.
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Preferences for Command History

Using Command History preferences, you can choose to exclude statements
from the history.m file and specify how often to save it. The history.m
file is used for both the Command History window and statement recall in
the Command Window.

To set preferences for the history.m file, select File > Preferences, and then
select Command History in the Preferences dialog box.

Settings

Specify the types of statements to exclude from the history.m file. Note that
when you exclude statements from the history.m file, you cannot recall them
in the Command Window as described in “Recalling Previous Lines” on page
3-16, nor can you view them in the Command History window.

Save Exit/Quit Commands
Select the check box to save exit and quit commands in the history.m file.

Save Consecutive Duplicate Commands

Select the check box if you want consecutive executions of the same statement
to be saved to the history.m file.

For example, with this option selected, run magic(5), and then run magic (5)
again. The history.m file saves two consecutive entries for magic(5). With
this option cleared, for the same example, the command history file saves only
one entry for magic(5). If you then run magic(10), the command history file
saves both entries, magic (5) followed by magic(10).

Saving
Use Saving preferences to specify how often to automatically save the
history.m file during a MATLAB session.
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Save History File On Quit

Select this option to save the history.m file when you end the MATLAB
session. If the session does not end via a normal termination, that is, via the
exit or quit functions, File > Exit MATLAB, or the MATLAB desktop Close
box, the history file is not saved for that session.

Save After n Commands

Select this option to save the history.m file after n statements are added to
the file. For example, when you select the option and set n to 10, after every
10 statements are added, the history file is automatically saved. Use this
option if you don’t want to risk losing entries to the saved history because of
an abnormal termination, such as a power failure.

Don’t Save History File

Select this option if you do not want to save the history.m file. This feature is
useful when multiple users share the same machine and do not want other
users to view the statements they have run.

Note that any entries already in the history.m file remain. Prior to setting
this preference, you might want to remove any existing entries. Follow the
instructions in “Deleting Entries from the Command History Window” on
page 3-49.

See Also
Additional preferences that relate to the Command History are

¢ “Fonts Preferences for Desktop Tools” on page 2-46

¢ “Confirmation Dialogs” on page 2-60
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The primary means for getting help is the Help browser, which provides
documentation for all your installed products. Other forms of help are
available including M-file help and Technical Support solutions. If you are
viewing this document in the Help browser, you can watch the Help and
Documentation video demo for an overview of the major functionality.

Help Browser Overview (p. 4-3)

Types of Documentation (p. 4-7)

Finding Information with the Help
Browser (p. 4-10)

Viewing Documentation in the Help
Browser (p. 4-25)

Demos in the Help Browser (p. 4-29)

Preferences for the Help Browser
(p. 4-35)

Get information about your
MathWorks products using the Help
browser.

Use the type of documentation that
best meets your need.

Use the contents listing of the online
documentation, a global index, and
full-text search.

After finding documentation, view
the documentation and perform
other operations using the display
pane.

Run demonstration programs, and
view and copy the M-file code behind
them.

Specify fonts used in the Help
browser and limit the documentation
included using the product filter.
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Printed Documentation (p. 4-40)

Help Functions (p. 4-42)

Other Forms of Help (p. 4-47)

Print from the Help browser

or from the PDF version of the
documentation, or purchase printed
documentation.

Use functions to get information,
such as help and doc.

Use product-specific help features,
download M-files, contact Technical
Support, see documentation for
other MathWorks products, view a
list of other books, and participate in
a MATLAB newsgroup.



Help Browser Overview

Help Browser Overview

Use the Help browser to search and view documentation and demonstrations
for MATLAB and all other installed MathWorks products. MATLAB
automatically installs the documentation and demos for a product when you

install that product. The Help browser is an HTML browser integrated with
the MATLAB desktop.

To open the Help browser, click the Help button # in the desktop toolbar, type
helpbrowser in the Command Window, or use the Help menu in any tool.
There are two panes:

¢ The Help Navigator, on the left, for finding information, includes a Search
for field, and Contents, Index, Search Results, and Demos tabs. For
more information, see “Finding Information with the Help Browser” on
page 4-10.

¢ The display pane, on the right, for viewing documentation and demos.
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Resizing the Help Browser

To adjust the relative width of the two panes, drag the separator bar between
them. You can also change the font in either of the panes — see “Help Fonts
and Colors Preferences” on page 4-37.

Once you find the documentation you want, you can close the Help Navigator
pane so there is more screen space to view the information itself. This is
shown in the following figure. To close the Help Navigator pane, click the
Close box Xl in the pane’s upper right corner. To open the Help Navigator
pane from the display pane, click the Help Navigator button [2=| on the toolbar.
Alternatively, use the View menu.
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Desktop Tools and Development Environment —

Tab Completion in the Editor/Debugger

The EditoriDebugaer helps you automatically complete the names ofthese items as you type them in an —
I-file:

# Functions or models on the search path orin the current directory

# ‘ariables, including structures, in the current workspace, where the current workspace is shown in the
Stack on the toolbar.

» Handle Graphics properies for figures in the current warkspace

Type the first few characters ofthe item name and then press the Tab key. To use tab completion, you must
have the tab completion preference for the Editor/CDebugger selected. For details, see Kevboard Preferences.

Tab completion is also availahle in the Command Window. There are a few minar differences in how tab
completion works inthe Command Window, the most notable being that Command Window tab completion
supports the completion of filenames, whereas the Editor/Debugger tab completion does not.

Hote Tab completion does not complete the names of variables you define in an M-file, but anly
those variables in the current workspace. This means that while editing, it only completes the
names of variables in the base workspace. While debugging, it only completes the names of
variables in the current function workspace.

Tah completion is not available in the MATLAB stand-alone Editor.

These examples demaonstrate how to use tab completion:

* Hasic Example — Unigue Completion
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Adding Your Own Help Files to the Help Browser

You can add your own HTML help files so they appear in the Help browser.
For details, see in the online documentation.



Types of Documentation

Types of Documentation

The Help browser and help functions provide access to the following types
of information for all installed MathWorks products. The icons shown here
appear in the Help browser contents listing to help you quickly identify
documentation by type.

Icon

Type of
Documentation Description and When to Use

Getting Started Review Getting Started documentation before you
begin using a product or feature for the first time.
Then, to learn more, go to the user guides, reference
pages or demos and examples.

Release Notes An overview of new products and features in a
release. Release Notes include upgrade information
and any known problems and limitations. Review
the Release Notes for all your products when you
first start using a new release.

@OI‘

Blue book icon

&

Product MATLAB and toolboxes use orange book icons @,
while Simulink, Blocksets, and related products use
blue book icons €.

&

Index of Examples Accessible via the Help browser Contents listing,
this is an index of the major examples included in
the Help browser documentation.

User Guides (blue) User guide material is comprehensive, containing
overviews as well as detailed instructions. Consult
it after reviewing Getting Started material.

Reference Pages Each function has a reference page that provides
(orange) the syntax, description, examples, and other
information for that function. Each reference page
includes links to related functions and additional
information. Reference pages are also provided for
blocks and properties.
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Type of
lcon Documentation Description and When to Use
= Printable Most products provide access to the online
Documentation documentation in a printable format, PDF. Access
PDF files via the Help browser and print them from
your PDF reader, such as Adobe Acrobat. Most PDF
files reside only on the MathWorks Web site, so you
need an Internet connection to view them.
Product Pages Available on the MathWorks Web site, a product
page contains the latest product information.
Support and Web Provides access to the MathWorks Technical
Services Support searchable database, maintained on the
MathWorks Web site. Use it to find solutions to
questions posed by users.
none Demos MathWorks products come with demonstrations

that run key features of the product. Many of the
demos run MATLAB code. Use the Help browser

Demos pane to access demos for the products you
have installed.

none M-File Help Get M-file help in the Command Window to quickly
access basic information for a function or model. It
provides a brief description of a function and its
syntax. It is called M-file help because the text of
the help is a series of comments at the top of the
M-file for a function.

Accessing Documentation on the Web

You can access all product documentation on the MathWorks Web site at
http://www.mathworks.com/access/helpdesk/help/helpdesk.shtml. Use
the Web site documentation for products you have not installed, or for prior
versions of a product, or if you prefer access via your system Web browser.
PDF documentation is available only on the Web site.

You cannot read MATLAB documentation files from the MATLAB CD. You
also cannot use a Web browser to read the documentation files installed with
MATLAB because the files are compressed JAR files.
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Types of Documentation

Documentation in Other Languages

The MathWorks documentation is available in English. Japanese versions of
MATLAB include documentation that has been translated into Japanese. For
more information, go to http://www.cybernet.co.jp/matlab.
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Finding Information with the Help Browser

Use the Help Navigator, the left pane in the Help browser, to find
information. These sections describe the main features:

Contents Listing in the Help View an expandable table of contents
Browser (p. 4-10) for the documentation.

Index for the Help Browser (p. 4-13) Use keywords to find information.

Search Documentation with the Find documentation using full-text

Help Browser (p. 4-16) and other forms of search.

Favorites (p. 4-24) Bookmark pages you want to refer
to again.

Contents Listing in the Help Browser

To list the documentation titles and tables of contents for products you
installed, click the Contents tab in the Help Navigator pane. To show
documentation for only some of the installed products, use the product filter.
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& Help =10] x|
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----- ‘Ways to Edit and Delbi
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=-Creating, Editing, and
----- Entering Statemer
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Tab Completion in the Editor/Debugger

The Editor/Debugger helps you automatically complete the names
ofthese items as you type them in an M-file:

* Functions or models on the search path orinthe current
directory

* ‘ariables, including structures, in the current workspace,
where the current workspace is shown in the Stack on the
toolbar.

* Handle Graphics properies for figures in the current
warkspace

Type the first few characters of the item name and then press the
Tab key. To use tab completion, you must have the tab completion
preference for the Editor/Debugger selected. For details, see
Kevboard Preferences.

Tab completion is also available in the Command Window. There
are a few minor differences in how tab completion works in the
Command Window, the mast notable being that Command
Window tab completion suppaorts the completion of filenames,
whereas the Editor/Debugager tab completion does not.

[ B =

Note Tah completion does not complete the names of
variables you define in an M-file, but only those variables

in the current workspace. This means thatwhille editing, it_ILI

3

v
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Product Roadmap

When you select a product in the Contents pane (any entry with a book
icon @), such as MATLAB or the Communications Toolbox, a roadmap of the
documentation for that product appears in the display pane. The roadmap
includes links to commonly used documentation sections, including

¢ Function and block references pages
¢ An index of major examples in the documentation

¢ The PDF version of the documentation, which is suitable for printing (this
is the only direct access from MATLAB to the printable documentation)

Navigate the Contents Listing
In the Contents listing, you can

® (Click the + to the left of an item to show the first page of that document
or section in the display pane and expand the listing for that item in the
Help Navigator pane. You can instead: double-click the item, press the
right arrow key, or press + on the numeric keypad.

® (Click the - to the left of an item to collapse the listings for that item. You
can instead: double-click the item, press the left arrow key, or press - on
the numeric keypad.

® Select an item to show the first page of that document or section in the
display pane.

® Press * on the numeric keypad to expand all nodes for the selection.

® Use the down and up arrow keys to move through the list of items.

Icons in the Contents Listing

Icons for entries in the top levels of the Contents pane listing represent the
type of documentation so you can quickly find the kind of information you need
for a product. See the table for icons in “Types of Documentation” on page 4-7.

Product Pages

After expanding the listing for a product in the Contents pane, the last entry
is Product Page (Web). This links to the MathWorks Web site for the latest
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information about that product. Like other links to the Web, the page opens
in your system Web browser.

Synchronize the Contents Listing with the Display Pane

By default, the topic highlighted in the Contents pane matches the title of the
page appearing in the display pane. The Contents pane listing is said to be
synchronized with the displayed document. This feature is useful if you access
documentation with a method other than the Contents pane, for example,
using a link in a page in the display pane. With synchronization, you know
what book and section the displayed page is part of. Note that synchronization
only applies to the major headings in a document. For pages that begin with
lower level headings, the Contents pane listing does not synchronize.

You can turn off synchronization. To do so, use preferences. See “General —
Keep Contents Synchronized” on page 4-36.

Synchronization only applies to the Contents pane. The page shown in the
display pane does not necessarily correspond to the selection in the Index,
Search Results, or Demos panes. However, if you return to the Contents
pane, the Contents pane synchronizes with the displayed page, except when
displaying demos.

Index for the Help Browser

To find specific index entries (selected keywords) in the MathWorks
documentation for installed products, use the Index in the Help Navigator
pane.

4-13



4 Help for Using MATLAB

Help Mavigator x

Search For: I LI G_DI

Exarmple: "plok bools" OF plab* kools

Contents  Index | Search Resultsl Demu:usl

ABCDEFGHIJELM
HOPQRETUMWMEYZ
Enter index term: Ial:us
Mame Product I

abs MATLAB i’
Ahe block Simulink

ZEM0 Crossings Simulink
Ahsoft Pro Fortran compiler Installation
absolute accuracy

BWF MATLAB

CDE MATLAB

CDE MATLAB
ahsolute tolerance

definition Simulink

simset parameter [1] [2] Simulink

simulation accuracy Simulink

specifying for a block state Simulink
absolute value

generating Simulink
ahsolute value MATLAB
accelbuild command

building Simulink Accelerator MESimulink
Accelerator

Llimenu property MATLAB
accelerators, keyhoard MATLAB ;I

1 Click the Index tab.
2 Type a word or words in the Enter index term field. As you type, the

Index pane displays matching entries and their subentries (indented).
It might take a moment for the display to appear. The index is not case
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sensitive. If there is not a matching entry, it displays the page for the letter
that your entry begins with.

The product whose documentation includes the matching index entry

is listed next to the index entry, which is useful when there are multiple
matching index entries. You might have to make the Help Navigator
pane wider to see the product.

Select a blue index entry from the list (where blue represents a hyperlink)
to display the page to which the term refers. Multiple links per entry are
denoted by numbers in brackets following the term. (Black index entries
are headings and do not link to any page.)

When you select an entry, its color becomes red. The page whose entry
you selected appears in the display pane, scrolled to the location that the
entry references.

4 To see more matching entries, scroll through the list.

Tips for Using the Index

To see entries for selected products only, select File > Preferences > Help
and set the product filter.

To see entries for all installed products, select File > Preferences > Help,
and clear the Enable product filter check box.

For more or different results, type a different term or reverse the order of
the words you type. For example, if you are looking for creating M-files,
type M-files and look for the subentry creating.

After selecting an entry, search for specified text in the displayed page
using the Find tool, accessible from the Find button # on the display pane
toolbar.

When there are multiple matching entries, refer to the product associated
with each entry, which appears in the second column of the Index results.
You might need to make the pane wider to see it.

For different but related results, try using the Search for field—for
instructions, see “Search Documentation with the Help Browser” on page
4-16.
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® See “Specifying Colors for the Help Browser” on page 4-39 for information
about changing the color of hyperlinks in the Index.

Search Documentation with the Help Browser

e “Searching in the Help Browser” on page 4-16

¢ “Wildcards in Search (Partial Word)” on page 4-21
e “Exact Phrases in Search” on page 4-21

¢ “Boolean Operators in Search” on page 4-22

e “More About Search” on page 4-22

® “Get Fewer Results” on page 4-22

® “Get More Results” on page 4-23

Searching in the Help Browser
To look for a specific word or phrase in the documentation, use the Search
for field in the Help Navigator.
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Help Mavigator

x

Search far: I |

Example: "plok bools" OR plob* bools

Contents | Index Search Results | Demas |

=1

Title | section

Kl |

i

1 To limit (or extend) the products whose documentation is searched, set

the product filter.

Type the word or words you want to find in the Search for field, and

click Go (or press Enter or Return). Some key techniques for honing

your search are

¢ Exact Phrase — Search for an exact phrase by enclosing words in
quotation marks, for example, "plot tools". For more information, see

“Exact Phrases in Search” on page 4-21.

e Wildcard (Partial Word) — Search for variations of a word, also called
partial word searching, by using the wildcard symbol (*) in place of
letters in a word, for example, plot* tools. For more information, see
“Wildcards in Search (Partial Word)” on page 4-21.
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® Boolean Operators — Add the Boolean operators AND, OR, and NOT
between search words to include or exclude words. By default, search
assumes an AND between all search words and exact phrases. For more
information, see “Boolean Operators in Search” on page 4-22.

The documents containing all of the exact search words and exact phrases
are listed in the Search Results tab, with the documentation Section and
the Product name shown in the second third columns, providing context
for the results. You might need to make the Help Navigator pane wider
to see all columns. The total number of results appears at the bottom left
side of the pane.

Select an entry from the list of results. (By default, the first entry is
automatically selected.)

The selected page appears in the display pane with all occurrences of the
search words and exact phrases highlighted, using a different color for each
search word or phrase. Highlights remain until you view another page or
until you click the Refresh button = in the toolbar.

In the display pane, use the Find tool, accessible from the Find button #
on the toolbar, to find a specified word in that page.

Search results are ordered by relevance. For example, reference pages
that match the search term appear first, followed by titles that contain all
search words, with pages containing a single instance of each search word
appearing last. Change the display of search results to more easily find
the most relevant results:

¢ Sort By Column — Change the order of the results by clicking a column
heading. For example, click Product to group results by product. Click
Title to sort titles alphabetically. A triangular icon indicates the column
on which you most recently sorted. Click the heading again to sort by the
column but in the reverse order.

After changing the order of results, to see results ordered by relevance,
click Go to rerun the search.
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¢ Reorder Columns — Change the location of a column by dragging its
heading to a new position. For example, you can drag the Product
column to the middle, which moves the Title column furthest to the right.

® Resize Columns — Make columns wider or narrower by dragging the
separator bar between the column headings. Similarly, make the Help
Navigator wider or narrower.

5 For more results, you can search for the words in the Technical Support

database of bug reports, solutions, and notes on the MathWorks Web site
by clicking the link at the bottom of the Search results pane.
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publish Functions MATLA
Fublishing to HT... Publishing Res... MATLAB
About Published ... Publishing Res... MATLAB
Fublishing M-File... Puhblishing Res... MATLAB
Example of Publi... Publishing Res... MATLAB
Example of Fubli... Publishing Res... MATLAB
See Also Publishi... Publishing Res... MATLAB
Marking Up Text i... Publishing Res... MATLAB _
Fublishing Results “ersion 7 (R14)... MATLAB
Publishing Results Desktop Tools ... MATLAB
Fublishing Prefer... GUI Reference f... MATLAB
grabcode Functions MATLAB
Fublishing Image... GUI Reference f... MATLAB
Using Cells for Ra... Editing and Deb... MATLAB
I[nhnnh‘ l:llnr\-ﬁr\nr\-l RAMATI ﬁ_l:!lll

Search Support Database on Wieb For

[ @

MATLAB Function Reference

publish

Run M-file script containing cells, saving results to file of
specified type

GUI Alternatives

As an alternative to the puklisn function, use the File =
Publish To menu items in the Editor/Debugger.

Syntax
publi=zsh('=cript’')
publizsh("=script', 'format")
publish ('=script', options)

Description

puklish('script') runs the file named scxipt in the
base workspace one cell at a time, and saves the code,
comments, and results to an HTML output file. The output file

: is named script.html and is stored, along with other 7
publisb* bl 4 | ,
27 pages cantain the wards: publish® AND bkl 4

Function Alternative. From the Command Window, use docsearch to open
the Help browser to the Search pane and search for the specified term. For

example

docsearch('publish* html')

finds all pages that contain the word publish or its variations, such as
publishing, published, and so on, and also contains the word html.

docsearch('"plot tools"')
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finds all pages containing the exact phrase plot tools.

For details, see the docsearch reference page.

Wildcards in Search (Partial Word)

You can use the wildcard character (*) in place of letters or digits in your
search terms. For example, plot* finds various forms of the word plot, such
as plot, plots, and plotting. The search term p*t also finds those variations of
plot as well as variations of print and part, among others.

You can use multiple wildcards in a word or search term. For example, plot*
tool* finds plotting tools, among other terms. The term p*t* tool* finds not
only plotting tools, but also pointer tooltip.

You cannot use a wildcard with just one letter or digit, nor can you include
wildcards within an exact phrase. For example, p* fails, and m.* and "plot*
tools" produce invalid results.

Limitation for Japanese Systems. Wildcard searching is not supported
on Japanese systems.

Exact Phrases in Search

To find a phrase, type quotation marks around it. For example, "plot tools"
finds only pages that include plot tools together, but does not find pages
that include plot in one part of the page and tools in another part of the
page. Specify an exact phrase to reduce the number of irrelevant results. For
example, "plot tools" finds about 10 pages in MATLAB documentation,
while plot tools finds about 100 pages.

You can specify more than one exact phrase, such as "plot tools" "figure
palette" to find pages that contain both "plot tools" and "figure

palette". You cannot use a wildcard within an exact phrase.

Limitation for Japanese Systems. Exact phrase searching is not supported
on Japanese systems.

4-21



4 Help for Using MATLAB

Boolean Operators in Search

The search automatically performs a Boolean AND for multiple words. In the
example publish* html, it finds all pages that have the word publish or its
variations, and the word html.

You can refine the search by including the Boolean operators NOT, OR, and AND
between words. The operators must be in all capital letters and there must be
a space before and after each operator. The NOTs are evaluated first, followed

by the ORs, and then the ANDs.

Example Using Boolean Operators in Search. Type

plot* tools NOT time series

to find all pages that contain the words plot or its variations and tools, but
not the phrase time series.

More About Search
These are the guidelines search uses:

® Insignificant words (a, an, the, of) are ignored.
® Search is not case sensitive.

® Search only finds letters and digits, but not symbols. To find a symbol,
look for the word (for example, plus instead of +), use the Index, or see
Operators and Special Characters in the MATLAB Functions by Category.

e Search does not find words in demos.

® If you search for a function that is used in multiple products (called an
overloaded function), the reference pages for all those products are listed.
Use the Product column to determine the reference page you want.

Get Fewer Results
If there are too many results for the search to be useful, try the following.
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Problem Try These Suggestions

Too many products Select File > Preferences > Help and enable the product
filter for specified products. For details, see “Product Filter”
on page 4-35.

Order results by product — click the Product column. If you
cannot see it, make the pane wider.

Pages are not about search Try the Index pane to see more important entries for that
word, but just mention it search word.
Too many irrelevant results Type more than one word in the Search for field.

Look for an exact phrase by enclosing words in quotations
marks, such as "plot tools"

Use Boolean operators (in all capitals), for example, printing
AND figures NOT exporting.

Topic is not relevant Look at the Section column in the search results list, which
provides context for the result. If you cannot see the column,
make the pane wider.

Get More Results
If you want more results, try the following.

Problem Try These Suggestions

No results for the product Be sure the product filter is set correctly. Select

File > Preferences > Help and disable the product filter,
or at least ensure the products of interest are selected. For
details, see “Product Filter” on page 4-35.

No results but you know the Try variations of the search word by using a wildcard symbol
word should be there (*). For example, search for preference* to find all pages that
contain either the word preference or the word preferences.

Not enough information Try searching the Technical Support database of bug reports,
solutions, and technical notes by clicking the link at the bottom
of the Search results pane.

4-23



4 Help for Using MATLAB

4-24

See Also. “Finding Files and Content Within Files” on page 5-45, which
describes the Find Files tool you use to look for files and content within files.

Favorites

Favorites are bookmarks to pages in the Help browser documentation and
M-file type demos.

Add Favorites
To designate the displayed page as a favorite (that is, to bookmark it),

1 Select Favorites > Add to Favorites.

2 The Favorites Editor dialog box opens. You can accept the defaults and
click Save, or make changes to the entries:

1 Use the Label provided, or change it to another term.
2 Do not change the entry for Callback.

3 Maintain the Category as Help Browser Favorites so you can access
them from the Favorites menu.

4 For Icon, keep the default Help icon, or choose another.

A favorite is implemented as a MATLAB shortcut, so the dialog box is
the same as for the Shortcut Editor.

Favorites from previous releases are not migrated to a new release.

Go to Favorites

Select the Favorites menu to view the list of pages you previously designated
as favorites (bookmarks). Select an entry and that page appears in the
display pane.

Organize Favorites

You can rename, remove, and reorder the list of favorites. Select
Favorites > Organize Favorites. For more information, click Help in the
Organize Favorites dialog box.



Viewing Documentation in the Help Browser

Viewing Documentation in the Help Browser

After finding documentation with the Help Navigator, view the
documentation in the display pane. The features available to you while
viewing the documentation are

“Browse to Other Pages” on page 4-26
“Links” on page 4-27

“Find Text in Displayed Pages” on page 4-27
“Copy Information” on page 4-28

“Evaluate a Selection” on page 4-28

“View the Page Source (HTML)” on page 4-28
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Browse to Other Pages
Use the arrow buttons in the page and in the toolbar to go to other pages.

oy RI=TEY

File Edit “ew Go Favorites Deskbop  Window  Help

H eaw | & M

|

Title: I Tab Completion in the Editor/Debugger @1 Editing and Debugging M-Files (Desktop Tools and Development Enviro,., |

Desktop Tools and Development Environment

Tab Completion in the Editor/Debugger

The EditoriDebugaer helps you automatically complete the names ofthese items as you type them in an
I-file:

* Functions or models on the search path arin the current directory

® Variables, including structures, in the current workspace, where the current waorkspace is shown in the
Stack on the toolbar.

* Handle Graphics properies for figures in the current warkspace

Type the first few characters of the item name and then press the Tab key. To use tab completion, you must
have the tab completion preference for the EditorDebugger selected. For details, see Keyboard Preferences.

Tab completion is also availahble in the Command Window. There are a few minar differences in how tab
completion works inthe Command Window, the most notable being that Command Window tab completion
suppors the completion of filenames, whereas the Editor/Debugger tab completion does not.

Hote Tab completion does not complete the names of variables you define in an M-file, but only
those variables in the current workspace. This means that while editing, it only completes the
names of variables inthe base waorkspace. While debugging, it only completes the names of
variables in the current function workspace.

Tab completion is not available in the MATLAB stand-alone Editor.
These examples demaonstrate how to use tab completion:

* Hasic Example — Unigue Completion

Y
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View the next page in a document by clicking the Next page button B at the
top or bottom of the page. View the previous page in a document by clicking
the Previous page button # at the top or bottom of the page. These arrows
allow you to move forward or backward within a single document. The arrows
at the bottom of the page are labeled with the title of the page they go to.

View the page previously shown by clicking the Back button # in the display
pane toolbar. After using the Back button, view the next page shown by
clicking the Forward button # in the display pane toolbar. These buttons work
like the forward and back buttons of popular Web browsers. You can also go
back or forward by right-clicking a page and selecting Back or Forward
from the context menu.

Links

Click links in the displayed page to go to a related topic for more information
on the subject. Links appear underlined and in blue. Visited links appear in
purple. Links to Web addresses open in the MATLAB Web Browser. Click the
middle mouse button to open the linked page in a separate window.

Find Text in Displayed Pages
To find a phrase in the currently displayed page,

1 Click the Find button #4. In the resulting Find dialog box, type the word
or phrase you are looking for. You can type a partial word, for example,
preference to find all occurrences of preference and preferences. Use
the check boxes to specify options. Click Find Next.

The search begins at the current cursor position and the page scrolls to the
first occurrence of the phrase in the page and highlights it.

2 To find more occurrences in that page, click Find Next or Find Previous
in the Find dialog box, or use the keyboard shortcuts F3 and Shift+F3.

MATLAB beeps when a search for Find Next reaches the end of the page,

or when a search for Find Previous reaches the top of the page. If you
have Wrap around selected, it continues searching after beeping.
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You can change the selection in the Look in field to search for the specified
text in other MATLAB desktop tools.

See “Search Documentation with the Help Browser” on page 4-16 for
instructions on looking through all the documentation instead of just one page.

Copy Information

To copy information from the display pane, such as code in an example, first
select the information. Then right-click and select Copy from the context
menu. You can then paste the information into another tool, such as the
Command Window or Editor/Debugger, or into another application, such as a
word processing application.

Evaluate a Selection

To run code examples that appear in the documentation, select the code in
the display pane. Then right-click and select Evaluate Selection from the
context menu. The statements execute in the Command Window.

View the Page Source (HTML)

To view the HTML source for the currently displayed page, select

View > Page Source. A read-only HTML version of the page appears in a

separate window. You can copy selections from the HTML source and paste

them into other tools like the Editor/Debugger or Command Window, or into
other applications.
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Demos in the Help Browser

MATLAB and related products include demos that you can access from the
Help browser Demos pane. There are four types of demos:

¢ [4 M-file: Demos that tell a step-by-step story, including source code,
commentary, and output. They are published from M-file scripts to HTML
output using the Editor/Debugger. The first comment line of the demo
M-file begins with two comment symbols (%%), and similarly, two comment
symbols (%%) create a cell for each step. The MATLAB Graphics Square
Wave from Sine Waves Example is an M-file type demo.

. M-GUI: Stand-alone tools for exploring a feature. An example is the
MATLAB Graphics Vibrating Logo demo.

¢ [ Model: Simulink block diagrams. An example is the Engine Timing
Simulation demo.

e 8 Video: Movies that highlight key features in a tool. They play in your
system browser and require the Macromedia Flash Player plug-in. An
example is the MATLAB Desktop and Command Window demo.

The MATLAB code and Simulink blocks used in the demos (except videos) are
available for you to view and copy for use in your own applications.

See also Examples for each product in the Contents pane. These examples
are similar to demos but are integrated in the documentation.

Using Demos
To access demos for the products you have installed,

1 Click the Demos tab in the Help Navigator.

You can also access demos from the Start button, by using the demo
function, or from the Help menu for some tools.

2 Click the + for a product area to list the products or categories that have
demos. Then click + for a product or product category to list its demos.
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All demos for that product or product area are listed in the display pane,
and each includes the type of demo along with a thumbnail image that
represents output from the demo.

3 Select a specific demo to use it. Information about the demo appears in
the display pane.
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----- Functions of Complex Vari:
----- Interactive Plot Creation wi
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Title: I Square \Wave From Sine Waves

Run in the Command Window

Open xfourier.m in the Editor

Square Wave from Sine Waves

The Fourier series expansion for a square-wave is made up ofa
sum of odd harmonics. We show this graphically using MATLAB.

We start by forming a time vector running from O to 10 in steps of
0.1, and take the sine of all the points. Let's plot this fundamental
frequency.

t 0:.1:210;
v 2in{t):
plot(t,¥):

:

&

4 You can then view and run the demo, with specific options depending on
the type of demo:
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¢ For M-file demos, click the Open filename in the Editor link at
the top left. This opens the M-file in the Editor/Debugger. From the
Editor/Debugger, run the demo step by step by selecting Cell > Evaluate
Current Cell and Advance.

You can also click Run in the Command Window, and then follow the
instructions that appear in the Command Window. You might need to
scroll up to see all of the instructions.

See also “Running Demos and Base Workspace Variables” on page 4-33.

¢ For M-GUI demos, click the Open filename in the Editor link at the
top left. This opens the M-file in the Editor/Debugger.

Click the Run this demo link at the top right to start the GUI. Then
follow the instructions in the GUI to proceed through the demo.

® For Model demos, click Open this model to open the block diagram.

® For Video demos, click the Run this demo link in the top right to play
the video. These demos run in your system browser and require the
Macromedia Flash Player plug-ins.

When you double-click a demo name in the Help Navigator pane, the demo
file opens for M-file and Model demos, or runs for M-GUI and Video demos.

The following example shows the results of running the MATLAB Graphics
Square Wave from Sine Waves demo (xfourier). In it, MATLAB generates
a series of plots, culminating in the final one shown here.
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Running Demos and Base Workspace Variables

M-file demos run as scripts. Their variables are created in the MATLAB
base workspace. If you have variables in the base workspace when you run
an M-file demo, and the demo uses an identical variable name, there could
be problems due to variable name conflicts. For example, a variable of yours
might be overwritten by the demo. The demo’s variables remain in the base
workspace until you clear them or quit MATLAB.

Some Help Browser Features Not Applicable to Demos
Help browser features apply to demos with these exceptions:

® You cannot use the Search for field to look for words or code contained in
the demos. You can use the Find Files tool, accessible from the desktop
Edit menu, to search for code in demo M-files. You can also use the Find
feature in the Help browser display pane, or in the Editor/Debugger to
find terms in the current file.

¢ The product filter does not apply to demos.
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Function Alternative

To view the Demos in the Help browser, type demo in the Command Window.
You can go directly to the demos for a specific product. For example

demo toolbox signal
opens the Demos listing for the Signal Processing Toolbox.

To run an M-GUI demo, type the demo name in the Command Window. For
example, type

vibes

to run the MATLAB Graphics demo showing an animated L-shaped
membrane.

To run an M-file demo step by step from the Command Window, type echodemo
followed by the demo name. For example, run

echodemo xfourier
Typing the demo name for an M-file demo runs the demo, but not step by step.
Typing the name of a Model demo opens the block diagram.

Adding Your Own Demos

You can add your own demos so they appear in the Demos pane. For details,
see in the online documentation.
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Preferences for the Help Browser

“Product Filter” on page 4-35
“PDF Reader — Specifying Its Location” on page 4-36
“General — Keep Contents Synchronized” on page 4-36

“Help Fonts and Colors Preferences” on page 4-37

Product Filter

If you have MathWorks products in addition to MATLAB, such as Simulink,
toolboxes, and blocksets, set the product filter to limit the product
documentation used:

2

SelectFile > Preferences > Help.

Under Produect filter, select the check box for Enable product filter.
Click Select products.

The Help Product Filter dialog box opens.

Select the products whose documentation you want to appear in the Help
Navigator. Click OK.

The Help Navigator updates to include only those products you specified.
The product filter settings are saved for your next MATLAB session.

When you want to use documentation for all installed products, in Help
Preferences, clear the check box for Enable product filter.

With the product filter enabled:

Contents shows only the subset of products you specify.
Index shows only index terms for the subset of products you specify.
Search for only looks through the subset of products you specify.

Demos is not affected; demos for all installed products are always shown.
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The Release Notes entry in the Help Product Filter dialog box applies
only the Release Notes overview document for a release, not to the Release
Notes for an individual product.

Example Using the Product Filter

If you want to perform a search and have many products installed but know
the information you are seeking is in MATLAB or the Communications
Toolbox, in the Help Product Filter, click Clear All and then select MATLAB
and Communications Toolbox.

The Contents only shows MATLAB and the Communications Toolbox
documentation, the Index only shows entries for MATLAB and the
Communications Toolbox, and the Search for feature only looks in and
shows results for MATLAB and the Communications Toolbox. Demos lists
demos for all installed product.

PDF Reader — Specifying lts Location
If you want to view the PDF version of the documentation, use the link on the

roadmap page for that product. To open the PDF file, the Help browser needs
to know the location of your PDF reader (for example, Adobe Acrobat).

For Windows systems, MATLAB reads the PDF reader location from the
registry, so you do not specify its location.

For UNIX systems, the default PDF reader is Acrobat and MATLAB
determines its location. If a different command starts your PDF reader,
specify it using preferences. Selecting File > Preferences > Help, and enter
the full pathname in the PDF reader field or use the Browse for Folder (...)
button to navigate your file system to select it.

General — Keep Contents Synchronized

By default, the displayed page is synchronized with the Contents listing. For
more information about this feature, see “Synchronize the Contents Listing
with the Display Pane” on page 4-13.
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To turn synchronization off, select File > Preferences > Help. Under
General, clear the check box for Keep contents tree synchronized with
displayed document. Select the check box to turn synchronization back on.

Help Fonts and Colors Preferences

Set fonts and colors for the Help browser the same way you would for other
desktop tools. This section describes the process for the Help browser:

® “Specifying Font Name, Style, and Size” on page 4-37
o “Specifying Colors for the Help Browser” on page 4-39

Specifying Font Name, Style, and Size

You can specify the font name (also called font type or family), style, and
size used in the Help Navigator.

For the display pane, you can specify the font name and size for the text font,
but changes do not impact the style. For the code font, your changes to size
apply, but changes to name and style have no impact. The following example
shows the results of specifying Comic Sans MS, bold, 14 point; note that the
bold has no effect
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& Help
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Title: I gig 11 Functions (MATLAE Function Reference)
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MATLAB Function Reference [»

elg

Find eigenvalues and eigenvectors

Syntax

d = eig(d)

d = eig(h,B)

[V,D] = eig(A)

[V,D] = eig(A, "nobalance')
[V,D] = eig(R,B)

[V,D] = eig(RA,B, flaq)

Description

d = eig (&) returns a vector of the eigenvalues of
matrix 4.

d = eig(a,B) refturns a vector containing the
generalized eigenvalues, if A and B are square matrices.

-

i
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Use the same method as you would to specify fonts for any desktop tool — for
more information, see “Fonts Preferences for Desktop Tools” on page 2-46. By
default, the Help Navigator uses the desktop text font. The display pane

is considered to be an HTML Proportional Text tool, and by default, uses

the desktop text font.

This example changes the display pane font:
1 Select File > Preferences > Fonts > Custom.

2 From the Desktop tools list, select HTML Proportional Text. The Help
browser display pane is considered to be an HTML Proportional Text tool,
as is the MATLAB Web Browser. Changing the font preference affects
both tools.

3 For Font to Use, select Custom, then specify the font characteristics:

® Name, for example, SansSerif

e Size in points, for example, 12
After you make a selection, the Sample area shows how the font will look.

4 Click OK. The Help display pane fonts use the new settings. The MATLAB
Web Browser fonts will also use the new settings.

Specifying Colors for the Help Browser

You can specify the background and text color used in the Help Navigator,
as well as the hyperlink color used in the Index pane.

If the background color preference for your desktop tools is a dark color, you
might not be able to see index entries in the Help Navigator because they
are links, for which the default color is blue. To see the links, change the
color preferences for hyperlinks to a light or other contrasting color. Use the
same method as you would to specify colors for any desktop tool — for more
information, see “Colors Preferences for Desktop Tools” on page 2-53.

You cannot specify colors for the Help browser display pane.
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Printed manuals are provided for the major releases of some products and
tools. The online documentation often has information not included with
the printed manuals and is often more current. If you want to purchase
printed documentation, see the online store at the MathWorks Web site at
http://www.mathworks.com.

You can print the current page displayed in the Help browser, or print a page
or an entire book from the PDF version of the documentation.

Printing a Page from the Help Browser

To print the page currently shown in the Help browser, select File > Print,
or click the Print button & in the display pane toolbar. The Print dialog
box appears.

The Pages field in the Print dialog box shows the total number of pages to be
printed and lets you specify the range of pages you want to print. When there
is more than one page, it means that multiple physical pages are needed to
print the single page displayed in the Help browser.

Complete the dialog box and press OK to print the page.

Printing the PDF Version of Documentation

If you need to print more than a few pages of documentation, or if you want
the pages to appear as if they came from a printed book, print the PDF
version of the documentation. PDF documentation is shown and printed using
your PDF reader, usually Adobe Acrobat Reader. The PDF documentation
reproduces the look and feel of the printed book, complete with fonts,
graphics, formatting, and images. In the PDF document, use links from the
table of contents, index, or within the document to go directly to the page of
interest. Note that some documentation available from the Help browser is
not available in PDF format.


http://www.mathworks.com

Printed Documentation

Note The Help browser accesses PDF documentation from the MathWorks
Web site. Therefore, you need Internet access to view or print PDF
documentation.

1 In the Help browser, click the Contents tab and select a product, for
example, MATLAB.

The roadmap page opens for that product, providing links to key
documentation for that product.

2 Near the end of the roadmap page, listed under Printing the
Documentation Set, are links for printing the documentation. Select the
link for the item you want to print.

MATLAB accesses the selected document from the MathWorks Web site.
Your PDF reader opens, displaying the documentation.

If you are using a UNIX platform and cannot open the PDF documentation,
check the Help preferences. See “PDF Reader — Specifying Its Location”
on page 4-36 for more information.

3 To print the documentation, select Print from the File menu in your PDF
reader.

4-41



4 Help for Using MATLAB

Help Functions

There are several help functions that provide forms of help different than
the Help browser documentation, or provide alternative ways to access the
Help browser information.

4-42

Function

Description

dbtype

Displays specified M-file with line numbers. If you want to see only
the input and output arguments for a function, use dbtype function
1, which displays the first line of the M-file.

demo

Displays the Demos pane in the Help browser, from which you can
access demonstrations for the products you have installed. With an
argument, runs the specified demo.

doc

Displays in the Help browser, the reference page for the specified
function, block, or property. Usually more extensive than results for
the help function, the reference page provides syntax, a description,
examples, illustrations, and links to related functions.

docopt

On UNIX systems, specifies Web browser information, used when
displaying Internet Web pages.

docsearch

Run the Help browser search feature for the specified term.

help

Displays M-file help (a description and syntax) in the Command
Window for the specified function. For MDL-files, displays a
description of the model.

helpbrowser

Opens the Help browser, the MATLAB interface for accessing
documentation.

helpdesk

Opens the Help browser. In previous releases, helpdesk displayed
the Help Desk, which was the precursor to the Help browser. This
function will be removed in a future release.

helpwin

Displays in the Help browser a list of all functions, and provides
access to M-file help for the functions.

lookfor

Displays in the Command Window a list and brief description of all
functions whose brief description includes the specified keyword.




Help Functions

Function Description

web Opens the specified URL in the specified browser. Use web in your
own M-files to display HTML documentation you create for your work.

whatsnew Displays the Release Notes in the Help browser.

View Function Reference Pages — the doc Function

To view the reference page for a function, block, or property in the Help
browser, use doc. For example, type

doc format

to view the reference page for the format function.

Overloaded Functions with the doc Function

When a function name is used in multiple products, it is said to be an
overloaded function. The doc function displays the reference page for the
first function on the MATLAB search path having that name, and displays a
hyperlinked list of the overloaded functions in the Command Window.

For example, using the default search path

doc set

displays the reference page for the MATLAB set function in the Help browser.
The Command Window displays a hyperlinked list of the set functions located
in other directories, such as

database/set

which is the set function for the Database Toolbox. Click a link to go to that
set reference page.

To directly get the reference page for an overloaded function, specify the
name of the directory containing the function you want the reference page
for, followed by the function name. For example, to display the reference page
for the set function in the Database Toolbox, type
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doc database/set

Some products have more than one function with the same name. For example,
MATLAB includes a built-in get function in the graphics directory and a get
function in the MATLAB serial directory (for serial port functions). Type

doc get

The reference page for the MATLAB graphics built-in get function appears,
and the Command Window lists overloaded functions in other products.

But the list does not include any overloaded functions in the same product.
Therefore, get in the MATLAB serial directory is not listed as an overloaded
function. Type

doc ('get (serial)')

to display the reference page for the get function located in the MATLAB
serial directory.

Getting Help in the Command Window — the help
Function

To quickly view a brief description and syntax for a function in the Command
Window, use the help function. For example, typing

help bar

displays a description and syntax for the bar function in the Command
Window. This is called the M-file help. For other arguments you can supply,
see the reference page for help.

Note M-file help displayed in the Command Window uses all uppercase

characters for the function and variable names to distinguish them from

the rest of the text. When typing function names, however, use lowercase
characters. Some functions for interfacing to Java do use mixed case; the
M-file help accurately reflects that, and you should use mixed case when
typing them.




Help Functions

If you need more information than the help function provides, use the doc
function, which displays the reference page in the Help browser. It can include
color, images, links, and more extensive examples than the M-file help. For
example, typing

doc bar

displays the reference page for the bar function in the Help browser.

Overloaded Functions with the help Function

When a function name is used in multiple products, it is said to be an
overloaded function. The help function displays M-file help for the first
function on the MATLAB search path having that name, and displays a
hyperlinked list of the overloaded functions at the end.

For example, using the default search path

help set

displays M-file help for the MATLAB set function, and displays a hyperlinked
list of the set functions residing in other directories, such as

database/set

which is the set function for the Database Toolbox. Click a link to display
the M-file help for that set function.

To directly get help for an overloaded function, specify the name of the
directory containing the function you want help for, followed by the function
name. For example, to get help for the set function in the Database Toolbox,

type

help database/set

Creating M-File Help for Your Own M-Files

You can create M-file help for your own M-files and access it using the help
command. See the help reference page for details.
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Help in the Current Directory Browser

The Help Report and the Contents Report provide other ways of looking at
and managing help for M-files — see “Directory Reports in Current Directory
Browser” on page 7-2.

You can also see the help for an M-file in the Current Directory browser if you
have its preference for Show M, MDL, and MAT file contents selected.

Help for Model Files

Use the help function with an MDL filename to display the complete
description for the model file. For example, run

help f14_dap.mdl

and MATLAB displays the description of the Simulink F-14
Digital Autopilot High Angle of Attack Mode, as defined in the
Model > Properties > Description.

Multirate digital pitch loop control for F-14 control design
demonstration.

If Simulink is installed, you do not need to include the .md1 extension.

You can see the same description in the Current Directory browser if you have
its preference for Show M, MDL, and MAT file contents selected.
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Other Forms of Help

In addition to using the Help browser and help functions, there are the other
forms of help for MATLAB and related products:

® “Documentation for Other Products” on page 4-47

® “Product-Specific Help Features” on page 4-47

o “User-Contributed M-Files” on page 4-47

e “Technical Support” on page 4-48

o “Newsgroup for MathWorks Products” on page 4-48

o “Other Resources for MATLAB Information” on page 4-49
® “Version and License Information” on page 4-49

e “Provide Feedback” on page 4-50

Documentation for Other Products

The Help browser provides access to documentation for all products
installed on your system. To view the online documentation

for all MathWorks products, use the MathWorks Web site at
http://www.mathworks.com/access/helpdesk/help/helpdesk.shtml.

Product-Specific Help Features

In addition to the Help browser and help functions, some products and tools
allow other methods for getting help. You will encounter some methods in the
course of using a product, such as entries in the Help menu, Help buttons
in dialog boxes, and selecting Help from a context menu. These methods

all display context-sensitive help. Other methods for getting help, such as
pressing the F1 key, are described in the documentation for the product or
tool that uses the method.

User-Contributed M-Files

You can download M-files contributed by users and developers of MATLAB,
Simulink, and related products from MATLAB Central. Before you write
an M-file yourself, especially if it seems to be a generic utility, check the
list of contributed files to see if someone has already written it. These
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files are freely contributed and can be used without charge by anyone

who downloads them. To view the files available to download, go to

the MATLAB Central File Exchange page on the MathWorks Web site,
http://www.mathworks.com/matlabcentral/fileexchange/index. jsp.
You can access this from any desktop component via Help > Web Resources.

If you write M-files that you think would be of use to others, consider
submitting them to the MATLAB Central File Exchange via the Web page.

Technical Support

Technical Support provides help for problems you have with MathWorks
products:

® Find specific Technical Support information using the Help browser
Search feature. Run a search for a specified term. The end of the results
list includes a link that runs the same search on the support database.
This database, on the MathWorks Web site, provides the most up-to-date
solutions, bug reports, and technical notes for questions posed by users.

* Select Help > Web Resources > Support to go to the Support Web
page (http://www.mathworks.com/support). The page displays in your
system’s default Web browser. You can find out about other types of
information such as third-party books, ask questions, make suggestions,
view known bugs and workarounds, and report possible bugs.

® If you cannot access the Web site, e-mail Technical Support using the
address support@mathworks.com. You must provide your license number
to obtain support. It is helpful if you also provide your operating system
and MATLAB version number. You can obtain the information by running
the ver function or by selecting Help > About.

Newsgroup for MathWorks Products

The Usenet newsgroup for MATLAB and related products,
comp.soft-sys.matlab, (also known as cssm) is read by thousands of users
worldwide. Access the newsgroup to ask for or provide help or advice. You
can read and submit postings as well as view and search through a sizable
archive of postings using the MATLAB Central Newsgroup Access Web page
on the MathWorks Web site, http://www.mathworks.com/matlabcentral.
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Other Forms of Help

You can access this via Help > Web Resources > MATLAB Newsgroup
Access from any desktop component.

First-time users to the newsgroup should read the newsgroup FAQ, linked

to from the MATLAB Central page. It is a good practice to try to solve your
own problem using the documentation and Technical Support database before
posting a question to the newsgroup. Be sure to post with a meaningful
subject that briefly describes the nature of the issue.

Other Resources for MATLAB Information

Following are some additional resources for help with MATLAB and related
products:

® Newsletters — The MathWorks publishes News and Notes twice
a year, containing feature articles, technical notes, and product
information for MATLAB users. More frequently, The MathWorks
issues MATLAB Digest, an electronic bulletin consisting of technical
notes, solutions, and timely announcements to the user community.
Select Help > Web Resources > MATLAB Newsletters or see
http://www.mathworks.com/company/newsletters/.

® Books — There are hundreds of MATLAB based books. For a list with
descriptions, see http://www.mathworks.com/support/books/.

¢ Seminars and Training — The MathWorks regularly presents free
seminars on special topics conducted in various locations. Webinars
on special topics are presented via the Web. The MathWorks offers
training classes for MATLAB and other products. For details, see
http://www.mathworks.com/company/events/.

® Mathtools.net — This is a technical computing Web portal with links to
many resources for MATLAB users. See http://www.mathtools.net/.

Version and License Information

If you need the version or license information for a product, select About from
the Help menu for that product. The version is displayed in an About dialog
box. If the product does not have a Help menu, use the ver function. To see
the license number for MATLAB, type license in the Command Window. See
also the ver, version, and license reference pages.
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You can access information about your passcodes and licenses, as well get trial
versions of products, using Help > Web Resources > MathWorks Account.

Provide Feedback

To report problems or provide comments or suggestions to The MathWorks
about the documentation, help features, or products, use the form on the Web at
www.mathworks.com/support/contact _us/ts/ebd/enhance_bug doc_1.html


http://www.mathworks.com/support/contact_us/ts/ebd/enhance_bug_doc_1.html

Workspace, Search Path,
and File Operations

If you are viewing this document in the Help browser, you can watch the
Workspace Browser video demo, the Array Editor video demo, and the Current
Directory Browser video demo for an overview of the major functionality.

MATLAB Workspace (p. 5-2)

Viewing and Editing Workspace
Variables with the Array Editor
(p. 5-12)

Search Path (p. 5-22)

File Management Operations
(p. 5-34)

The workspace is the set of variables
maintained in memory during

a MATLAB session. Use the
Workspace browser or equivalent
functions to view the workspace.

View and make changes to variables
using the Array Editor.

MATLAB uses a search path to find
M-files and other MATLAB related
files. View and change the path
using the Set Path dialog box or
equivalent functions.

Search for, view, open, and make
changes to MATLAB related
directories and files, using the
Current Directory browser or
equivalent functions.



5 Workspace, Search Path, and File Operations

MATLAB Workspace

The MATLAB workspace consists of the set of variables (named arrays) built

up during a MATLAB session and stored in memory. You add variables to the
workspace by using functions, running M-files, and loading saved workspaces.
For example, if you type

t
y

0:pi/4:2*pi;
sin(t);

the workspace includes two variables, y and t, each having nine values.

You can perform workspace operations and related features using the
Workspace browser. Equivalent functions are available and are documented
with each feature of the Workspace browser. If you are viewing this document
in the Help browser, you can watch the Workspace browser video demo for an
overview of the major functionality:

® “Opening the Workspace Browser” on page 5-2

* “Viewing and Editing Values in the Current Workspace” on page 5-3

* “Saving the Current Workspace” on page 5-5

* “Loading a Saved Workspace and Importing Data” on page 5-6

¢ “Changing and Copying Variable Names” on page 5-7

¢ “Deleting Workspace Variables” on page 5-8

¢ “Viewing Base and Function Workspaces Using the Stack” on page 5-8

® “Creating Plots from the Workspace Browser” on page 5-9

® “Opening Variables and Objects for Viewing and Editing” on page 5-9

e “Preferences for the Workspace Browser” on page 5-9

Opening the Workspace Browser

To open the Workspace browser, select Workspace from the Desktop menu
in the MATLAB desktop, or type workspace at the Command Window prompt.

The Workspace browser opens.
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Viewing and Editing Values in the Current Workspace

The Workspace browser shows the name of each variable, its value, and the
Min and Max calculations, which MATLAB computes using the min and max
functions, and updates automatically. The icon for each variable denotes

its class.

® You can display additional columns, including size (dimensions), size in
bytes, class, and other common statistical calculations such as mode and
standard deviation. To show or hide columns, select View > Choose
Columns or right-click any column heading. To specify the size limit
for calculations and how NaNs are considered, use “Preferences for the
Workspace Browser” on page 5-9.

¢ To resize the columns of information, drag the column header borders. To
reorder columns, drag a column header to a new position.

® You can select the column on which to sort as well as reverse the sort order
of any column. Click a column heading to sort on that column. Click the
column heading again to reverse the sort order in that column. For example,
to sort on Name, click the column heading once. To change from ascending
to descending, click the heading again. You cannot sort by the Value
column in the Workspace browser. Alternatively, select View > Sort By
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® You can edit variable values directly in the Workspace browser Value
column. To edit a value, select the row to change in the Value column and
type the new value.

This illustration shows the Workspace browser with all columns in view,
sorted by the Class column, as indicated by the triangle in that column
heading. Preferences are set to show statistical values only for arrays under
10,000 elements, so results for a, (1 x 20000), do not appear. The preference
for treatment of NaNs is set to include them in calculations, as seen for n.
With the preference set to ignore NaNs, values other than NaN would appear.
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Function Alternative
Use who to list the current workspace variables. Use whos to list the variables
and information about their size and class. For example:

>> who
Your variables are:
A C M R S ¢

>> whos
Name Size Bytes Class Attributes
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A 4x4 128 double
C 1x3 348 cell
M 4x4x24 3072 double
R 3x4x5 480 double
S 1x3 826 struct
c 1x16 32 char

Use exist to see if the specified variable is in the workspace.

Saving the Current Workspace

The workspace is not maintained across MATLAB sessions. When you quit
MATLAB, the workspace is cleared. You can save any or all of the variables in
the current workspace to a MAT-file, which is a MATLAB specific binary file.
You can then load the MAT-file at a later time during the current or another
session to reuse the workspace variables. MAT-files use a .mat extension.

Note The .mat extension is also used by Microsoft Access.

Saving All Variables

To save all of the workspace variables using the Workspace browser,

1 From the File menu, select Save Workspace As, or click the Save button
& in the Workspace browser toolbar.

The Save dialog box opens.

2 Specify the location and File name. MATLAB automatically supplies the
.mat extension.

3 Click Save.
The workspace variables are saved under the MAT-file name you specified.

You can also save the workspace variables from the desktop by selecting Save
Workspace As from the File menu.
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Saving Selected Variables
To save some but not all of the current workspace variables,

1 Select the variable in the Workspace browser. To select multiple variables,
Shift+click or Ctrl+click.

2 Right-click and from the context menu, select Save As.

The Save to MAT-File dialog box opens.

3 Specify the location and File name. MATLAB automatically supplies the
.mat extension.

4 Click Save.
The workspace variables are saved under the MAT-file name you specified.

To specify preferences for saving MAT-files, see “MAT-Files” on page 2-60.

Function Alternative

To save workspace variables, use the save function followed by the filename
you want to save to. For example,

save('junel0')
saves all current workspace variables to the file june10.mat.

If you don’t specify a filename, the workspace is saved to matlab.mat in the
current working directory. You can specify which variables to save, as well
as control the format in which the data is stored, such as ASCII. For these
and other forms of the function, see the reference page for save. For a related
function, see genvarname. MATLAB provides additional functions for saving
information — see “Data Import and Export” in the MATLAB Programming
documentation.

Loading a Saved Workspace and Importing Data

To load saved variables into the workspace,

1 Click the Import Data button 2 on the toolbar in the Workspace browser.
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The Open dialog box opens.

2 Select the MAT-file you want to load and click Open.

The variables and their values, as stored in the MAT-file, are loaded into
the current workspace. If any variables being loaded have the same names
as variables in the current workspace, the values from the MAT-file replace
the values in the current workspace. Any variables in the MAT-file that are
not in the workspace are added to the workspace.

Function Alternative
Use load to open a saved workspace. For example,

load('junel10')

loads all workspace variables from the file june10.mat.

Importing Data

MATLAB provides other methods and functions for loading information.

You can use one of these methods, the Import Wizard, from the Workspace
browser — select Edit > Paste to workspace or use Ctrl+V to import data
to MATLAB using the Import Wizard. For more information on the Import
Wizard and other methods for loading information, see the “Using the Import
Wizard”.

Viewing Variables in MAT-Files

Use the Current Directory browser to view the contents of a MAT-file without
loading the file into MATLAB. For details, see “Finding Files and Content
Within Files” on page 5-45.

Function Alternative. Use whos with the -file option.

Changing and Copying Variable Names

To rename a variable in the workspace, right-click the variable in the
Workspace browser and select Rename from the context menu. Type the new
variable name over the existing name and press Enter or Return.

5-7
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To copy variable names to the clipboard, select the workspace variables and
select Edit > Copy. You can then paste the names, for example, into the
Command Window. Multiple variables are comma separated.

Deleting Workspace Variables

You can delete a variable, which removes it from the workspace. To delete a
variable using the Workspace browser,

1 In the Workspace browser, select the variable, or Shift+click or Ctrl+click
to select multiple variables. To select all variables, choose Select All from
the Edit or context menus.

2 Press the Delete key on your keyboard or click the Delete button % on the
Workspace browser toolbar.

3 A confirmation dialog box might appear. If it does, click OK to clear the
variables.

The confirmation dialog box appears if you selected that preference. For
more information, see “Confirmation Dialogs” on page 2-60.

To delete all variables, select Edit > Clear Workspace from any desktop tool.

Function Alternative
Use the clear function to clear variables from the workspace. For example,

clear A M

clears the variables A and M from the workspace.

Viewing Base and Function Workspaces Using the
Stack

When you run M-files, MATLAB assigns each function its own workspace,
called the function workspace, which is separate from the MATLAB base
workspace. To access the base and function workspaces when running or
debugging M-files, use the Stack field in the Workspace browser. The Stack
field is only available in debug mode and otherwise is grayed out. The Stack
field is also accessible from the Array Editor and the Editor/Debugger. See
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“Debugging and Correcting M-Files” on page 6-56 for more information. See
also the dbstack and evalin functions.

Creating Plots from the Workspace Browser

From the Workspace browser, you can generate a plot of a variable. To create
a plot, click the Plot button [il on the Workspace browser toolbar and select
the plot type. The plot appears in a figure window. The button itself changes
to reflect the currently selected style of plot, for example bar or stem.

This feature is only available for variables whose data types can be plotted,
such as numeric. Open the variable in the Array Editor for additional plotting
options.

In addition, you can right-click the variable you want to plot. From the
context menu, choose the type of plot you want to create.

You can also Shift+click or Ctrl+click to select multiple variables to plot
together. When one of the variables is named time, t, or T, MATLAB assumes
it is the independent variable.

For more information about creating graphs in MATLAB, see the “MATLAB
Graphics” documentation.

Opening Variables and Objects for Viewing and
Editing

In the Workspace browser, double-click a variable and it opens in the Array
Editor, where you can view and edit the contents of the variable. See “Viewing

and Editing Workspace Variables with the Array Editor” on page 5-12 for
more information about opening arrays.

Some toolboxes allow you to double-click an object in the Workspace browser
to open a viewer or other tool appropriate for that object. For details, see the
toolbox documentation for that object type.

Preferences for the Workspace Browser

The Workspace browser displays statistical calculations for variables. Use
preferences to restrict the size of arrays on which calculations are performed
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and to specify if NaNs are included or ignored in calculations. Select
File > Preferences to open the dialog box. Make changes and click OK.
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Specify Maximum Array Size on Which to Compute Statistics
If you show statistical columns in the Workspace browser, and if you work
with very large arrays, you might experience performance issues when the
data changes as MATLAB updates the statistical results. In that event, show
only the columns of interest to you and hide those you do not need.

Another step you can take is specify via a preference that the Workspace
browser not perform statistical calculations on the largest arrays. Use the
arrows to change the value of the maximum array size for which you want
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the Workspace browser to perform statistical calculations. The default value
is 500,000 elements. Any variable exceeding that size reports <Too many
elements> instead of statistical results.

Handling NaN Values in Calculations

If your data includes NaNs, you can specify that the statistical calculations
consider the NaNs, or ignore the NaNs. For example, if a variable includes

a NaN and the preference is set to Use NaNs when calculating statistics,
the values for Min, Max, Var and some others will appear as NaN, although
Mode, for example, shows a numeric result. With the preference set to Ignore
NaNs whenever possible, numeric results appear for most of the statistical
columns including Min and Max, however, Var is still reported as NaN.

For more information about statistical values in the Workspace browser, see
“Viewing and Editing Values in the Current Workspace” on page 5-3.

5-11
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Viewing and Editing Workspace Variables with the Array

Editor

Use the Array Editor to view and edit a visual representation of one or
two-dimensional numeric arrays, strings, cell arrays of strings, and structures.
You can also view the contents of multidimensional arrays. If you are using
the Help browser, watch the Array Editor video demo for an overview